mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [GIT PULL] rv changes for v6.20 (for-next)
@ 2026-01-12  9:50 Gabriele Monaco
  0 siblings, 0 replies; only message in thread
From: Gabriele Monaco @ 2026-01-12  9:50 UTC (permalink / raw)
  To: linux-kernel, Steven Rostedt; +Cc: Gabriele Monaco, Shubham Sharma

Steve,

The following changes since commit 0f61b1860cc3f52aef9036d7235ed1f017632193:

  Linux 6.19-rc5 (2026-01-11 17:03:14 -1000)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/gmonaco/linux.git rv-6.20-next

for you to fetch changes up to 403faa575738a7f92267b2ca2ee56cd1b9373078:

  rv: Fix documentation reference in da_monitor.h (2026-01-12 07:44:09 +0100)

----------------------------------------------------------------
rv changes for v6.20 (for-next)

Summary of changes:

- Refactor da_monitor to minimise macros

  Complete refactor of da_monitor.h to reduce reliance on macros
  generating functions. Use generic static functions and uses the
  preprocessor only when strictly necessary (e.g. for tracepoint
  handlers).
  The change essentially relies on functions with generic names (e.g.
  da_handle) instead of monitor-specific as well adding the need to
  define constant (e.g. MONITOR_NAME, MONITOR_TYPE) before including the
  header rather than calling macros that would define functions.
  Also adapt monitors and documentation accordingly.

- Cleanup DA code generation scripts

  Clean up functions in dot2c removing reimplementations of trivial
  library functions (__buff_to_string) and removing some other unused
  intermediate steps.

- Annotate functions with types in the rvgen python scripts

- Remove superfluous assignments and cleanup generated code

  The rvgen scripts generate a superfluous assignment to 0 for enum
  variables and don't add commas to the last elements, which is against
  the kernel coding standards. Change the generation process for a
  better compliance and slightly simpler logic.

- Remove superfluous declarations from generated code

  The monitor container source files contained a declaration and a
  definition for the rv_monitor variable. The former is superfluous and
  was removed.

- Fix reference to outdated documentation

  s/da_monitor_synthesis.rst/monitor_synthesis.rst in comment in
  da_monitor.h

----------------------------------------------------------------
Gabriele Monaco (8):
      rv: Refactor da_monitor to minimise macros
      rv: Cleanup da_monitor after refactor
      Documentation/rv: Adapt documentation after da_monitor refactoring
      verification/rvgen: Adapt dot2k and templates after refactoring da_monitor.h
      verification/rvgen: Annotate DA functions with types
      verification/dot2c: Remove __buff_to_string() and cleanup
      verification/dot2c: Remove superfluous enum assignment and add last comma
      verification/rvgen: Remove unused variable declaration from containers

Shubham Sharma (1):
      rv: Fix documentation reference in da_monitor.h

 Documentation/trace/rv/monitor_synthesis.rst       |  44 +-
 include/linux/rv.h                                 |   4 +
 include/rv/automata.h                              | 132 +--
 include/rv/da_monitor.h                            | 887 ++++++++++-----------
 kernel/trace/rv/monitors/nrp/nrp.c                 |  30 +-
 kernel/trace/rv/monitors/nrp/nrp.h                 |  22 +-
 kernel/trace/rv/monitors/opid/opid.c               |  40 +-
 kernel/trace/rv/monitors/opid/opid.h               |  24 +-
 kernel/trace/rv/monitors/rtapp/rtapp.c             |   2 -
 kernel/trace/rv/monitors/sched/sched.c             |   2 -
 kernel/trace/rv/monitors/sco/sco.c                 |  26 +-
 kernel/trace/rv/monitors/sco/sco.h                 |  14 +-
 kernel/trace/rv/monitors/scpd/scpd.c               |  28 +-
 kernel/trace/rv/monitors/scpd/scpd.h               |  14 +-
 kernel/trace/rv/monitors/snep/snep.c               |  28 +-
 kernel/trace/rv/monitors/snep/snep.h               |  18 +-
 kernel/trace/rv/monitors/snroc/snroc.c             |  26 +-
 kernel/trace/rv/monitors/snroc/snroc.h             |  14 +-
 kernel/trace/rv/monitors/sssw/sssw.c               |  38 +-
 kernel/trace/rv/monitors/sssw/sssw.h               |  22 +-
 kernel/trace/rv/monitors/sts/sts.c                 |  34 +-
 kernel/trace/rv/monitors/sts/sts.h                 |  28 +-
 kernel/trace/rv/monitors/wip/wip.c                 |  26 +-
 kernel/trace/rv/monitors/wip/wip.h                 |  14 +-
 kernel/trace/rv/monitors/wwnr/wwnr.c               |  28 +-
 kernel/trace/rv/monitors/wwnr/wwnr.h               |  14 +-
 tools/verification/rvgen/rvgen/automata.py         |  20 +-
 tools/verification/rvgen/rvgen/dot2c.py            | 111 +--
 tools/verification/rvgen/rvgen/dot2k.py            |  26 +-
 .../rvgen/rvgen/templates/container/main.c         |   2 -
 .../rvgen/rvgen/templates/dot2k/main.c             |  25 +-
 31 files changed, 835 insertions(+), 908 deletions(-)

To: Steven Rostedt <rostedt@goodmis.org>
Cc: Gabriele Monaco <gmonaco@redhat.com>
Cc: Shubham Sharma <slopixelz@gmail.com>


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2026-01-12  9:51 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-01-12  9:50 [GIT PULL] rv changes for v6.20 (for-next) Gabriele Monaco

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®