mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v2 0/2] imx8mp-frdm: Enhance code readability
@ 2026-03-02 13:38 Daniel Baluta
  2026-03-02 13:38 ` [PATCH v2 1/2] arm64: dts: imx8mp: Make MX8MP_I2C_DEFAULT independent on drive strength Daniel Baluta
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Daniel Baluta @ 2026-03-02 13:38 UTC (permalink / raw)
  To: Frank.Li
  Cc: robh, krzk+dt, conor+dt, s.hauer, kernel, festevam, devicetree,
	imx, linux-arm-kernel, linux-kernel, maudspierings,
	Daniel Baluta

Enhance the readability of IOMUXC_SW_PAD_CTL_PAD configuration by using
symbolic macros instead of magic values.

First patch makes MX8MP_I2C_DEFAULT independent of DS so it can be
re-used in multiple places.

Second patch makes uses on the macros introduce with:
31ff1060175c458 ("arm64: dts: imx8mp: Add pinctrl config definitions")
in order to make code easier to read and understand.

Changes since v1:
   * v1: https://lore.kernel.org/imx/20260227130242.1702329-1-daniel.baluta@nxp.com/
   * remove RFC tag as seems v1 got positive feedback
   * add R-b tag from Maud for patch 1/2
   * update commit message for patch 2/2 as suggested by Frank
   * Use existing macro instead of introducing MX8MP_NAND_DATA_DEFAULT
     as suggested by Maud and Frank

Daniel Baluta (2):
  arm64: dts: imx8mp: Make MX8MP_I2C_DEFAULT independent on drive
    strength
  arm64: dts: imx8mp-frdm: Use symbolic macros for IOMUXC_SW_PAD_CTL_PAD

 arch/arm64/boot/dts/freescale/imx8mp-frdm.dts | 132 +++++++++++-------
 .../arm64/boot/dts/freescale/imx8mp-pinfunc.h |   2 +-
 .../imx8mp-tx8p-ml81-moduline-display-106.dts |  16 +--
 .../boot/dts/freescale/imx8mp-tx8p-ml81.dtsi  |   8 +-
 4 files changed, 97 insertions(+), 61 deletions(-)

-- 
2.45.2


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2026-03-09 19:01 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-03-02 13:38 [PATCH v2 0/2] imx8mp-frdm: Enhance code readability Daniel Baluta
2026-03-02 13:38 ` [PATCH v2 1/2] arm64: dts: imx8mp: Make MX8MP_I2C_DEFAULT independent on drive strength Daniel Baluta
2026-03-02 13:38 ` [PATCH v2 2/2] arm64: dts: imx8mp-frdm: Use symbolic macros for IOMUXC_SW_PAD_CTL_PAD Daniel Baluta
2026-03-09 19:00 ` [PATCH v2 0/2] imx8mp-frdm: Enhance code readability Frank Li

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®