From: Marco Nenciarini <mnencia@kcore.it>
To: "Daniel Scally" <djrscally@gmail.com>,
"Sakari Ailus" <sakari.ailus@linux.intel.com>,
"Hans de Goede" <hdegoede@redhat.com>,
"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org, Marco Nenciarini <mnencia@kcore.it>
Subject: [PATCH v4 1/4] platform/x86: int3472: Rename pled to led in LED registration code
Date: Fri, 27 Mar 2026 10:07:50 +0100 [thread overview]
Message-ID: <20260327090753.1481453-2-mnencia@kcore.it> (raw)
In-Reply-To: <20260327090753.1481453-1-mnencia@kcore.it>
Rename the privacy LED functions, struct type and member from
pled/int3472_pled/register_pled to led/int3472_led/register_led to
prepare for supporting additional LED types (e.g. strobe/IR flood).
No functional change.
Signed-off-by: Marco Nenciarini <mnencia@kcore.it>
---
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
drivers/platform/x86/intel/int3472/discrete.c | 4 +-
drivers/platform/x86/intel/int3472/led.c | 42 +++++++++----------
include/linux/platform_data/x86/int3472.h | 8 ++--
3 files changed, 27 insertions(+), 27 deletions(-)
diff --git a/drivers/platform/x86/intel/int3472/discrete.c b/drivers/platform/x86/intel/int3472/discrete.c
index 1505fc3..cb24763 100644
--- a/drivers/platform/x86/intel/int3472/discrete.c
+++ b/drivers/platform/x86/intel/int3472/discrete.c
@@ -348,7 +348,7 @@ static int skl_int3472_handle_gpio_resources(struct acpi_resource *ares,
break;
case INT3472_GPIO_TYPE_PRIVACY_LED:
- ret = skl_int3472_register_pled(int3472, gpio);
+ ret = skl_int3472_register_led(int3472, gpio);
if (ret)
err_msg = "Failed to register LED\n";
@@ -422,7 +422,7 @@ void int3472_discrete_cleanup(struct int3472_discrete_device *int3472)
gpiod_remove_lookup_table(&int3472->gpios);
skl_int3472_unregister_clock(int3472);
- skl_int3472_unregister_pled(int3472);
+ skl_int3472_unregister_led(int3472);
skl_int3472_unregister_regulator(int3472);
}
EXPORT_SYMBOL_NS_GPL(int3472_discrete_cleanup, "INTEL_INT3472_DISCRETE");
diff --git a/drivers/platform/x86/intel/int3472/led.c b/drivers/platform/x86/intel/int3472/led.c
index b1d84b9..ccd51f2 100644
--- a/drivers/platform/x86/intel/int3472/led.c
+++ b/drivers/platform/x86/intel/int3472/led.c
@@ -6,55 +6,55 @@
#include <linux/leds.h>
#include <linux/platform_data/x86/int3472.h>
-static int int3472_pled_set(struct led_classdev *led_cdev,
+static int int3472_led_set(struct led_classdev *led_cdev,
enum led_brightness brightness)
{
struct int3472_discrete_device *int3472 =
- container_of(led_cdev, struct int3472_discrete_device, pled.classdev);
+ container_of(led_cdev, struct int3472_discrete_device, led.classdev);
- gpiod_set_value_cansleep(int3472->pled.gpio, brightness);
+ gpiod_set_value_cansleep(int3472->led.gpio, brightness);
return 0;
}
-int skl_int3472_register_pled(struct int3472_discrete_device *int3472, struct gpio_desc *gpio)
+int skl_int3472_register_led(struct int3472_discrete_device *int3472, struct gpio_desc *gpio)
{
char *p;
int ret;
- if (int3472->pled.classdev.dev)
+ if (int3472->led.classdev.dev)
return -EBUSY;
- int3472->pled.gpio = gpio;
+ int3472->led.gpio = gpio;
/* Generate the name, replacing the ':' in the ACPI devname with '_' */
- snprintf(int3472->pled.name, sizeof(int3472->pled.name),
+ snprintf(int3472->led.name, sizeof(int3472->led.name),
"%s::privacy_led", acpi_dev_name(int3472->sensor));
- p = strchr(int3472->pled.name, ':');
+ p = strchr(int3472->led.name, ':');
if (p)
*p = '_';
- int3472->pled.classdev.name = int3472->pled.name;
- int3472->pled.classdev.max_brightness = 1;
- int3472->pled.classdev.brightness_set_blocking = int3472_pled_set;
+ int3472->led.classdev.name = int3472->led.name;
+ int3472->led.classdev.max_brightness = 1;
+ int3472->led.classdev.brightness_set_blocking = int3472_led_set;
- ret = led_classdev_register(int3472->dev, &int3472->pled.classdev);
+ ret = led_classdev_register(int3472->dev, &int3472->led.classdev);
if (ret)
return ret;
- int3472->pled.lookup.provider = int3472->pled.name;
- int3472->pled.lookup.dev_id = int3472->sensor_name;
- int3472->pled.lookup.con_id = "privacy";
- led_add_lookup(&int3472->pled.lookup);
+ int3472->led.lookup.provider = int3472->led.name;
+ int3472->led.lookup.dev_id = int3472->sensor_name;
+ int3472->led.lookup.con_id = "privacy";
+ led_add_lookup(&int3472->led.lookup);
return 0;
}
-void skl_int3472_unregister_pled(struct int3472_discrete_device *int3472)
+void skl_int3472_unregister_led(struct int3472_discrete_device *int3472)
{
- if (IS_ERR_OR_NULL(int3472->pled.classdev.dev))
+ if (IS_ERR_OR_NULL(int3472->led.classdev.dev))
return;
- led_remove_lookup(&int3472->pled.lookup);
- led_classdev_unregister(&int3472->pled.classdev);
- gpiod_put(int3472->pled.gpio);
+ led_remove_lookup(&int3472->led.lookup);
+ led_classdev_unregister(&int3472->led.classdev);
+ gpiod_put(int3472->led.gpio);
}
diff --git a/include/linux/platform_data/x86/int3472.h b/include/linux/platform_data/x86/int3472.h
index b1b8375..7af6731 100644
--- a/include/linux/platform_data/x86/int3472.h
+++ b/include/linux/platform_data/x86/int3472.h
@@ -121,12 +121,12 @@ struct int3472_discrete_device {
u8 imgclk_index;
} clock;
- struct int3472_pled {
+ struct int3472_led {
struct led_classdev classdev;
struct led_lookup_data lookup;
char name[INT3472_LED_MAX_NAME_LEN];
struct gpio_desc *gpio;
- } pled;
+ } led;
struct int3472_discrete_quirks quirks;
@@ -160,7 +160,7 @@ int skl_int3472_register_regulator(struct int3472_discrete_device *int3472,
const char *second_sensor);
void skl_int3472_unregister_regulator(struct int3472_discrete_device *int3472);
-int skl_int3472_register_pled(struct int3472_discrete_device *int3472, struct gpio_desc *gpio);
-void skl_int3472_unregister_pled(struct int3472_discrete_device *int3472);
+int skl_int3472_register_led(struct int3472_discrete_device *int3472, struct gpio_desc *gpio);
+void skl_int3472_unregister_led(struct int3472_discrete_device *int3472);
#endif
--
2.47.3
next prev parent reply other threads:[~2026-03-27 9:08 UTC|newest]
Thread overview: 52+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <ab0URIrzZPsYjWrM@spark.kcore.it>
2026-03-25 22:38 ` [PATCH v3 0/2] platform/x86: int3472: Add support for strobe LED (GPIO type 0x02) Marco Nenciarini
2026-03-25 22:38 ` [PATCH v3 1/2] platform/x86: int3472: Rename pled to led in LED registration code Marco Nenciarini
2026-03-25 22:38 ` [PATCH v3 2/2] platform/x86: int3472: Add support for GPIO type 0x02 (strobe LED) Marco Nenciarini
2026-03-26 10:46 ` Ilpo Järvinen
2026-03-26 10:51 ` Andy Shevchenko
2026-03-26 10:55 ` Andy Shevchenko
2026-03-26 10:57 ` Andy Shevchenko
2026-03-26 11:05 ` Andy Shevchenko
2026-03-27 9:07 ` [PATCH v4 0/4] platform/x86: int3472: Add support for strobe LED (GPIO type 0x02) Marco Nenciarini
2026-03-27 9:07 ` Marco Nenciarini [this message]
2026-03-27 10:08 ` [PATCH v4 1/4] platform/x86: int3472: Rename pled to led in LED registration code Andy Shevchenko
2026-03-27 10:35 ` Andy Shevchenko
2026-03-27 9:07 ` [PATCH v4 2/4] platform/x86: int3472: Use local variable for LED struct access Marco Nenciarini
2026-03-27 10:15 ` Andy Shevchenko
2026-03-27 9:07 ` [PATCH v4 3/4] platform/x86: int3472: Introduce LED type enum and multi-LED support Marco Nenciarini
2026-03-27 10:30 ` Andy Shevchenko
2026-03-27 9:07 ` [PATCH v4 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (strobe LED) Marco Nenciarini
2026-03-27 10:34 ` Andy Shevchenko
2026-03-27 10:37 ` [PATCH v4 0/4] platform/x86: int3472: Add support for strobe LED (GPIO type 0x02) Andy Shevchenko
2026-03-27 18:10 ` [PATCH v5 0/4] platform/x86: int3472: Add support for GPIO type 0x02 (strobe) Marco Nenciarini
2026-03-27 18:10 ` [PATCH v5 1/4] platform/x86: int3472: Use local variable for LED struct access Marco Nenciarini
2026-03-30 9:23 ` Andy Shevchenko
2026-03-27 18:10 ` [PATCH v5 2/4] platform/x86: int3472: Rename pled to led in LED registration code Marco Nenciarini
2026-03-27 18:10 ` [PATCH v5 3/4] platform/x86: int3472: Parameterize LED name in registration Marco Nenciarini
2026-03-30 9:26 ` Andy Shevchenko
2026-03-27 18:10 ` [PATCH v5 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (strobe) Marco Nenciarini
2026-03-30 9:35 ` Andy Shevchenko
2026-03-30 9:36 ` [PATCH v5 0/4] " Andy Shevchenko
2026-03-30 13:23 ` johannes.goede
2026-03-30 14:55 ` Marco Nenciarini
2026-03-30 15:12 ` johannes.goede
2026-03-30 20:21 ` Sakari Ailus
2026-03-31 7:10 ` Marco Nenciarini
2026-03-31 10:15 ` johannes.goede
2026-03-31 21:28 ` Sakari Ailus
2026-04-01 13:38 ` johannes.goede
2026-04-01 17:13 ` Marco Nenciarini
2026-04-01 18:47 ` johannes.goede
2026-03-31 7:52 ` [PATCH v6 0/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED) Marco Nenciarini
2026-03-31 7:52 ` [PATCH v6 1/4] platform/x86: int3472: Use local variable for LED struct access Marco Nenciarini
2026-03-31 10:16 ` Andy Shevchenko
2026-03-31 7:52 ` [PATCH v6 2/4] platform/x86: int3472: Rename pled to led in LED registration code Marco Nenciarini
2026-03-31 10:17 ` Andy Shevchenko
2026-03-31 7:52 ` [PATCH v6 3/4] platform/x86: int3472: Parameterize LED con_id in registration Marco Nenciarini
2026-03-31 10:20 ` Andy Shevchenko
2026-03-31 7:52 ` [PATCH v6 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED) Marco Nenciarini
2026-03-31 10:36 ` Hans de Goede
2026-03-31 10:55 ` Andy Shevchenko
2026-04-01 13:36 ` Hans de Goede
2026-04-01 13:56 ` Andy Shevchenko
2026-03-31 10:48 ` Andy Shevchenko
2026-03-31 10:25 ` [PATCH v6 0/4] " Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260327090753.1481453-2-mnencia@kcore.it \
--to=mnencia@kcore.it \
--cc=andriy.shevchenko@linux.intel.com \
--cc=djrscally@gmail.com \
--cc=hdegoede@redhat.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®