From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Marco Nenciarini <mnencia@kcore.it>
Cc: "Daniel Scally" <djrscally@gmail.com>,
"Sakari Ailus" <sakari.ailus@linux.intel.com>,
"Hans de Goede" <hdegoede@redhat.com>,
"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4 3/4] platform/x86: int3472: Introduce LED type enum and multi-LED support
Date: Fri, 27 Mar 2026 12:30:40 +0200 [thread overview]
Message-ID: <acZcUOSm4LUA75_d@ashevche-desk.local> (raw)
In-Reply-To: <20260327090753.1481453-4-mnencia@kcore.it>
On Fri, Mar 27, 2026 at 10:07:52AM +0100, Marco Nenciarini wrote:
> Add an enum int3472_led_type to parameterize LED registration, and
> lookup tables to derive the LED name suffix and con_id from the type.
> This replaces the hardcoded "privacy" name and prepares for additional
> LED types.
>
> Convert the single struct int3472_led member to an array with a
> counter to support devices with multiple LEDs. The LED lookup is now
> conditionally registered based on the con_id lookup table entry, and
> a has_lookup flag tracks whether to remove it during cleanup.
...
> +static const char * const int3472_led_names[] = {
> + [INT3472_LED_TYPE_PRIVACY] = "privacy",
> +};
> +
> +static const char * const int3472_led_con_ids[] = {
> + [INT3472_LED_TYPE_PRIVACY] = "privacy",
> +};
But why? Do we expect a deviation in these?
...
> + if (con_id) {
Too early, we have only up to one led for now and we know what is that.
> + led->lookup.provider = led->name;
> + led->lookup.dev_id = int3472->sensor_name;
> + led->lookup.con_id = con_id;
> + led_add_lookup(&led->lookup);
> + led->has_lookup = true;
> + }
...
> -void skl_int3472_unregister_led(struct int3472_discrete_device *int3472)
> +void skl_int3472_unregister_leds(struct int3472_discrete_device *int3472)
> {
> - struct int3472_led *led = &int3472->led;
> + unsigned int i;
>
> - if (IS_ERR_OR_NULL(led->classdev.dev))
> - return;
> + for (i = 0; i < int3472->n_leds; i++) {
for (unsigned int i = 0; i < int3472->n_leds; i++) {
> + struct int3472_led *led = &int3472->leds[i];
>
> - led_remove_lookup(&led->lookup);
> - led_classdev_unregister(&led->classdev);
> - gpiod_put(led->gpio);
> + if (led->has_lookup)
Too early, we know we don't have this right now.
> + led_remove_lookup(&led->lookup);
> + led_classdev_unregister(&led->classdev);
> + gpiod_put(led->gpio);
> + }
> }
...
> #define INT3472_LED_MAX_NAME_LEN 32
> +#define INT3472_MAX_LEDS 2
Too early. It's 1 for now.
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2026-03-27 10:30 UTC|newest]
Thread overview: 52+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <ab0URIrzZPsYjWrM@spark.kcore.it>
2026-03-25 22:38 ` [PATCH v3 0/2] platform/x86: int3472: Add support for strobe LED (GPIO type 0x02) Marco Nenciarini
2026-03-25 22:38 ` [PATCH v3 1/2] platform/x86: int3472: Rename pled to led in LED registration code Marco Nenciarini
2026-03-25 22:38 ` [PATCH v3 2/2] platform/x86: int3472: Add support for GPIO type 0x02 (strobe LED) Marco Nenciarini
2026-03-26 10:46 ` Ilpo Järvinen
2026-03-26 10:51 ` Andy Shevchenko
2026-03-26 10:55 ` Andy Shevchenko
2026-03-26 10:57 ` Andy Shevchenko
2026-03-26 11:05 ` Andy Shevchenko
2026-03-27 9:07 ` [PATCH v4 0/4] platform/x86: int3472: Add support for strobe LED (GPIO type 0x02) Marco Nenciarini
2026-03-27 9:07 ` [PATCH v4 1/4] platform/x86: int3472: Rename pled to led in LED registration code Marco Nenciarini
2026-03-27 10:08 ` Andy Shevchenko
2026-03-27 10:35 ` Andy Shevchenko
2026-03-27 9:07 ` [PATCH v4 2/4] platform/x86: int3472: Use local variable for LED struct access Marco Nenciarini
2026-03-27 10:15 ` Andy Shevchenko
2026-03-27 9:07 ` [PATCH v4 3/4] platform/x86: int3472: Introduce LED type enum and multi-LED support Marco Nenciarini
2026-03-27 10:30 ` Andy Shevchenko [this message]
2026-03-27 9:07 ` [PATCH v4 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (strobe LED) Marco Nenciarini
2026-03-27 10:34 ` Andy Shevchenko
2026-03-27 10:37 ` [PATCH v4 0/4] platform/x86: int3472: Add support for strobe LED (GPIO type 0x02) Andy Shevchenko
2026-03-27 18:10 ` [PATCH v5 0/4] platform/x86: int3472: Add support for GPIO type 0x02 (strobe) Marco Nenciarini
2026-03-27 18:10 ` [PATCH v5 1/4] platform/x86: int3472: Use local variable for LED struct access Marco Nenciarini
2026-03-30 9:23 ` Andy Shevchenko
2026-03-27 18:10 ` [PATCH v5 2/4] platform/x86: int3472: Rename pled to led in LED registration code Marco Nenciarini
2026-03-27 18:10 ` [PATCH v5 3/4] platform/x86: int3472: Parameterize LED name in registration Marco Nenciarini
2026-03-30 9:26 ` Andy Shevchenko
2026-03-27 18:10 ` [PATCH v5 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (strobe) Marco Nenciarini
2026-03-30 9:35 ` Andy Shevchenko
2026-03-30 9:36 ` [PATCH v5 0/4] " Andy Shevchenko
2026-03-30 13:23 ` johannes.goede
2026-03-30 14:55 ` Marco Nenciarini
2026-03-30 15:12 ` johannes.goede
2026-03-30 20:21 ` Sakari Ailus
2026-03-31 7:10 ` Marco Nenciarini
2026-03-31 10:15 ` johannes.goede
2026-03-31 21:28 ` Sakari Ailus
2026-04-01 13:38 ` johannes.goede
2026-04-01 17:13 ` Marco Nenciarini
2026-04-01 18:47 ` johannes.goede
2026-03-31 7:52 ` [PATCH v6 0/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED) Marco Nenciarini
2026-03-31 7:52 ` [PATCH v6 1/4] platform/x86: int3472: Use local variable for LED struct access Marco Nenciarini
2026-03-31 10:16 ` Andy Shevchenko
2026-03-31 7:52 ` [PATCH v6 2/4] platform/x86: int3472: Rename pled to led in LED registration code Marco Nenciarini
2026-03-31 10:17 ` Andy Shevchenko
2026-03-31 7:52 ` [PATCH v6 3/4] platform/x86: int3472: Parameterize LED con_id in registration Marco Nenciarini
2026-03-31 10:20 ` Andy Shevchenko
2026-03-31 7:52 ` [PATCH v6 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED) Marco Nenciarini
2026-03-31 10:36 ` Hans de Goede
2026-03-31 10:55 ` Andy Shevchenko
2026-04-01 13:36 ` Hans de Goede
2026-04-01 13:56 ` Andy Shevchenko
2026-03-31 10:48 ` Andy Shevchenko
2026-03-31 10:25 ` [PATCH v6 0/4] " Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=acZcUOSm4LUA75_d@ashevche-desk.local \
--to=andriy.shevchenko@linux.intel.com \
--cc=djrscally@gmail.com \
--cc=hdegoede@redhat.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mnencia@kcore.it \
--cc=platform-driver-x86@vger.kernel.org \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome