* [PATCH] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc
@ 2026-05-30 20:13 Rosen Penev
2026-07-12 9:37 ` Dmitry Baryshkov
2026-07-12 23:46 ` Dmitry Baryshkov
0 siblings, 2 replies; 5+ messages in thread
From: Rosen Penev @ 2026-05-30 20:13 UTC (permalink / raw)
To: dri-devel
Cc: Rob Clark, Dmitry Baryshkov, Abhinav Kumar, Jessica Zhang,
Sean Paul, Marijn Suijten, David Airlie, Simona Vetter,
open list:DRM DRIVER for Qualcomm display hardware,
open list:DRM DRIVER for Qualcomm display hardware, open list
The kernel-doc referred to @crtc_clk_rate but the actual parameter is @mode_clk_rate.
Assisted-by: Opencode:Big-pickle
Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c b/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
index 13cc658065c5..2ff255d7795e 100644
--- a/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
+++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
@@ -34,7 +34,7 @@ enum dpu_perf_mode {
/**
* dpu_core_perf_adjusted_mode_clk - Adjust given mode clock rate according to
* the perf clock factor.
- * @crtc_clk_rate - Unadjusted mode clock rate
+ * @mode_clk_rate: unadjusted mode clock rate
* @perf_cfg: performance configuration
*/
u64 dpu_core_perf_adjusted_mode_clk(u64 mode_clk_rate,
--
2.54.0
^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc
2026-05-30 20:13 [PATCH] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc Rosen Penev
@ 2026-07-12 9:37 ` Dmitry Baryshkov
2026-07-12 19:19 ` Rosen Penev
2026-07-12 23:46 ` Dmitry Baryshkov
1 sibling, 1 reply; 5+ messages in thread
From: Dmitry Baryshkov @ 2026-07-12 9:37 UTC (permalink / raw)
To: Rosen Penev
Cc: dri-devel, Rob Clark, Dmitry Baryshkov, Abhinav Kumar,
Jessica Zhang, Sean Paul, Marijn Suijten, David Airlie,
Simona Vetter,
open list:DRM DRIVER for Qualcomm display hardware,
open list:DRM DRIVER for Qualcomm display hardware, open list
On Sat, May 30, 2026 at 01:13:42PM -0700, Rosen Penev wrote:
> The kernel-doc referred to @crtc_clk_rate but the actual parameter is @mode_clk_rate.
>
> Assisted-by: Opencode:Big-pickle
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---
> drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
Fixes: 62b7d6835288 ("drm/msm/dpu: Filter modes based on adjusted mode clock")
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
>
> diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c b/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> index 13cc658065c5..2ff255d7795e 100644
> --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> @@ -34,7 +34,7 @@ enum dpu_perf_mode {
> /**
> * dpu_core_perf_adjusted_mode_clk - Adjust given mode clock rate according to
> * the perf clock factor.
> - * @crtc_clk_rate - Unadjusted mode clock rate
> + * @mode_clk_rate: unadjusted mode clock rate
> * @perf_cfg: performance configuration
> */
> u64 dpu_core_perf_adjusted_mode_clk(u64 mode_clk_rate,
> --
> 2.54.0
>
--
With best wishes
Dmitry
^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc
2026-07-12 9:37 ` Dmitry Baryshkov
@ 2026-07-12 19:19 ` Rosen Penev
2026-07-12 23:46 ` Dmitry Baryshkov
0 siblings, 1 reply; 5+ messages in thread
From: Rosen Penev @ 2026-07-12 19:19 UTC (permalink / raw)
To: Dmitry Baryshkov
Cc: dri-devel, Rob Clark, Dmitry Baryshkov, Abhinav Kumar,
Jessica Zhang, Sean Paul, Marijn Suijten, David Airlie,
Simona Vetter,
open list:DRM DRIVER for Qualcomm display hardware,
open list:DRM DRIVER for Qualcomm display hardware, open list
On Sun, Jul 12, 2026 at 2:37 AM Dmitry Baryshkov
<dmitry.baryshkov@oss.qualcomm.com> wrote:
>
> On Sat, May 30, 2026 at 01:13:42PM -0700, Rosen Penev wrote:
> > The kernel-doc referred to @crtc_clk_rate but the actual parameter is @mode_clk_rate.
> >
> > Assisted-by: Opencode:Big-pickle
> > Signed-off-by: Rosen Penev <rosenp@gmail.com>
> > ---
> > drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
>
> Fixes: 62b7d6835288 ("drm/msm/dpu: Filter modes based on adjusted mode clock")
Is a v2 needed?
>
> Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
>
>
>
> >
> > diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c b/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> > index 13cc658065c5..2ff255d7795e 100644
> > --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> > +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> > @@ -34,7 +34,7 @@ enum dpu_perf_mode {
> > /**
> > * dpu_core_perf_adjusted_mode_clk - Adjust given mode clock rate according to
> > * the perf clock factor.
> > - * @crtc_clk_rate - Unadjusted mode clock rate
> > + * @mode_clk_rate: unadjusted mode clock rate
> > * @perf_cfg: performance configuration
> > */
> > u64 dpu_core_perf_adjusted_mode_clk(u64 mode_clk_rate,
> > --
> > 2.54.0
> >
>
> --
> With best wishes
> Dmitry
^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc
2026-07-12 19:19 ` Rosen Penev
@ 2026-07-12 23:46 ` Dmitry Baryshkov
0 siblings, 0 replies; 5+ messages in thread
From: Dmitry Baryshkov @ 2026-07-12 23:46 UTC (permalink / raw)
To: Rosen Penev
Cc: dri-devel, Rob Clark, Dmitry Baryshkov, Abhinav Kumar,
Jessica Zhang, Sean Paul, Marijn Suijten, David Airlie,
Simona Vetter,
open list:DRM DRIVER for Qualcomm display hardware,
open list:DRM DRIVER for Qualcomm display hardware, open list
On Sun, Jul 12, 2026 at 12:19:59PM -0700, Rosen Penev wrote:
> On Sun, Jul 12, 2026 at 2:37 AM Dmitry Baryshkov
> <dmitry.baryshkov@oss.qualcomm.com> wrote:
> >
> > On Sat, May 30, 2026 at 01:13:42PM -0700, Rosen Penev wrote:
> > > The kernel-doc referred to @crtc_clk_rate but the actual parameter is @mode_clk_rate.
> > >
> > > Assisted-by: Opencode:Big-pickle
> > > Signed-off-by: Rosen Penev <rosenp@gmail.com>
> > > ---
> > > drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c | 2 +-
> > > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > Fixes: 62b7d6835288 ("drm/msm/dpu: Filter modes based on adjusted mode clock")
> Is a v2 needed?
No
> >
> > Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
--
With best wishes
Dmitry
^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc
2026-05-30 20:13 [PATCH] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc Rosen Penev
2026-07-12 9:37 ` Dmitry Baryshkov
@ 2026-07-12 23:46 ` Dmitry Baryshkov
1 sibling, 0 replies; 5+ messages in thread
From: Dmitry Baryshkov @ 2026-07-12 23:46 UTC (permalink / raw)
To: dri-devel, Rosen Penev
Cc: Rob Clark, Dmitry Baryshkov, Abhinav Kumar, Jessica Zhang,
Sean Paul, Marijn Suijten, David Airlie, Simona Vetter,
linux-arm-msm, freedreno, linux-kernel
On Sat, 30 May 2026 13:13:42 -0700, Rosen Penev wrote:
> The kernel-doc referred to @crtc_clk_rate but the actual parameter is @mode_clk_rate.
Applied to msm-fixes, thanks!
[1/1] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc
https://gitlab.freedesktop.org/lumag/msm/-/commit/14ea7c582879
Best regards,
--
With best wishes
Dmitry
^ permalink raw reply [flat|nested] 5+ messages in thread
end of thread, other threads:[~2026-07-12 23:46 UTC | newest]
Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-05-30 20:13 [PATCH] drm/msm/dpu: fix parameter name in dpu_core_perf_adjusted_mode_clk kernel-doc Rosen Penev
2026-07-12 9:37 ` Dmitry Baryshkov
2026-07-12 19:19 ` Rosen Penev
2026-07-12 23:46 ` Dmitry Baryshkov
2026-07-12 23:46 ` Dmitry Baryshkov
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome