mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] HID: logitech-hidpp: remove excess kernel-doc member in hidpp_scroll_counter
@ 2026-05-31  0:01 Rosen Penev
  2026-06-01 18:20 ` Benjamin Tissoires
  0 siblings, 1 reply; 2+ messages in thread
From: Rosen Penev @ 2026-05-31  0:01 UTC (permalink / raw)
  To: linux-input
  Cc: Filipe Laíns, Bastien Nocera, Jiri Kosina,
	Benjamin Tissoires, Hans de Goede, open list

The @dev member described in the kernel-doc does not exist in the
struct. Remove the stale entry.

Fixes: 0610430e3dea ("HID: logitech-hidpp: add input_device ptr to struct
hidpp_device")
Assisted-by: opencode:big-pickle

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 drivers/hid/hid-logitech-hidpp.c | 1 -
 1 file changed, 1 deletion(-)

diff --git a/drivers/hid/hid-logitech-hidpp.c b/drivers/hid/hid-logitech-hidpp.c
index ccbf28869a96..1990ba5b26ea 100644
--- a/drivers/hid/hid-logitech-hidpp.c
+++ b/drivers/hid/hid-logitech-hidpp.c
@@ -164,7 +164,6 @@ struct hidpp_battery {
 /**
  * struct hidpp_scroll_counter - Utility class for processing high-resolution
  *                             scroll events.
- * @dev: the input device for which events should be reported.
  * @wheel_multiplier: the scalar multiplier to be applied to each wheel event
  * @remainder: counts the number of high-resolution units moved since the last
  *             low-resolution event (REL_WHEEL or REL_HWHEEL) was sent. Should
-- 
2.54.0


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] HID: logitech-hidpp: remove excess kernel-doc member in hidpp_scroll_counter
  2026-05-31  0:01 [PATCH] HID: logitech-hidpp: remove excess kernel-doc member in hidpp_scroll_counter Rosen Penev
@ 2026-06-01 18:20 ` Benjamin Tissoires
  0 siblings, 0 replies; 2+ messages in thread
From: Benjamin Tissoires @ 2026-06-01 18:20 UTC (permalink / raw)
  To: linux-input, Rosen Penev
  Cc: Filipe Laíns, Bastien Nocera, Jiri Kosina, Hans de Goede,
	linux-kernel

On Sat, 30 May 2026 17:01:50 -0700, Rosen Penev wrote:
> The @dev member described in the kernel-doc does not exist in the
> struct. Remove the stale entry.
> 
> Fixes: 0610430e3dea ("HID: logitech-hidpp: add input_device ptr to struct
> hidpp_device")
> Assisted-by: opencode:big-pickle
> 
> [...]

Applied to https://git.kernel.org/pub/scm/linux/kernel/git/hid/hid.git (for-7.2/logitech), thanks!

[1/1] HID: logitech-hidpp: remove excess kernel-doc member in hidpp_scroll_counter
      https://git.kernel.org/hid/hid/c/f22a5db8a7d3

Cheers,
-- 
Benjamin Tissoires <bentiss@kernel.org>


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2026-06-01 18:20 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-05-31  0:01 [PATCH] HID: logitech-hidpp: remove excess kernel-doc member in hidpp_scroll_counter Rosen Penev
2026-06-01 18:20 ` Benjamin Tissoires

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®