mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] xfs: convert dquot iterator map allocation to kmalloc_array()
@ 2026-06-01 19:18 William Theesfeld
  2026-06-02  5:14 ` Darrick J. Wong
  2026-06-02 11:25 ` [PATCH v2] xfs: convert dquot iterator map allocation to kmalloc_objs() William Theesfeld
  0 siblings, 2 replies; 5+ messages in thread
From: William Theesfeld @ 2026-06-01 19:18 UTC (permalink / raw)
  To: Carlos Maiolino; +Cc: linux-xfs, linux-kernel

Convert the open-coded kmalloc(n * sizeof(*p), ...) pattern in
xfs_qm_dqiterate() to kmalloc_array(n, sizeof(*p), ...).  This matches
the convention adopted across fs/xfs/ in commit 910bbdf2f4dXX ("xfs:
convert buf_cancel_table allocation to kmalloc_array") and is the only
remaining instance of the old pattern in fs/xfs/.

No functional change.  XFS_DQITER_MAP_SIZE is a compile-time constant
(10) so the runtime overflow check added by kmalloc_array() folds away;
the conversion is for consistency and to keep fs/xfs/ free of the
deprecated form.

Signed-off-by: William Theesfeld <william@theesfeld.net>
---
 fs/xfs/xfs_qm.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/xfs/xfs_qm.c b/fs/xfs/xfs_qm.c
index 7bd15d9e7..eebdeb181 100644
--- a/fs/xfs/xfs_qm.c
+++ b/fs/xfs/xfs_qm.c
@@ -1170,7 +1170,7 @@ xfs_qm_reset_dqcounts_buf(
 	if (qip->i_nblocks == 0)
 		return 0;
 
-	map = kmalloc(XFS_DQITER_MAP_SIZE * sizeof(*map),
+	map = kmalloc_array(XFS_DQITER_MAP_SIZE, sizeof(*map),
 			GFP_KERNEL | __GFP_NOFAIL);
 
 	lblkno = 0;
-- 
2.54.0


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2026-06-02 14:01 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-06-01 19:18 [PATCH] xfs: convert dquot iterator map allocation to kmalloc_array() William Theesfeld
2026-06-02  5:14 ` Darrick J. Wong
2026-06-02  5:56   ` Christoph Hellwig
2026-06-02 11:25 ` [PATCH v2] xfs: convert dquot iterator map allocation to kmalloc_objs() William Theesfeld
2026-06-02 14:01   ` Carlos Maiolino

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®