From: Vipin Sharma <vipinsh@google.com>
To: Pasha Tatashin <pasha.tatashin@soleen.com>
Cc: rppt@kernel.org, pratyush@kernel.org, tarunsahu@google.com,
skhawaja@google.com, shuah@kernel.org, dmatlack@google.com,
linux-kernel@vger.kernel.org, kexec@lists.infradead.org,
linux-kselftest@vger.kernel.org
Subject: Re: [PATCH v2 1/2] selftests/liveupdate: Move luo_test_utils.* into a reusable library
Date: Fri, 12 Jun 2026 10:29:02 -0700 [thread overview]
Message-ID: <20260612172349.GA40404.vipinsh@google.com> (raw)
In-Reply-To: <178123377286.908199.18067987861441109485.b4-review@b4>
On Fri, Jun 12, 2026 at 03:09:32AM +0000, Pasha Tatashin wrote:
> On Wed, 10 Jun 2026 16:09:07 -0700, Vipin Sharma <vipinsh@google.com> wrote:
> > diff --git a/tools/testing/selftests/liveupdate/lib/libliveupdate.mk b/tools/testing/selftests/liveupdate/lib/libliveupdate.mk
> > new file mode 100644
> > index 000000000000..0fb738c02330
> > --- /dev/null
> > +++ b/tools/testing/selftests/liveupdate/lib/libliveupdate.mk
> > @@ -0,0 +1,20 @@
> > [ ... skip 14 lines ... ]
> > + $(Q)mkdir -p $@
> > +
> > +$(LIBLIVEUPDATE_O): $(LIBLIVEUPDATE_OUTPUT)/%.o : $(LIBLIVEUPDATE_SRCDIR)/%.c | $(LIBLIVEUPDATE_OUTPUT)
> > + $(CC) $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -c $< -o $@
> > +
> > +EXTRA_CLEAN += $(LIBLIVEUPDATE_OUTPUT)
>
> since this file contains utility functions (luo_open_device, luo_test,
> etc.), naming it liveupdate.c makes it sound like the main
> implementation rather than a test helper library. Using something
> distinct like lu_utils.c would make more sense.
Okay, I will rename the new file to lu_utils.[ch]
>
> >
> > diff --git a/tools/testing/selftests/liveupdate/luo_test_utils.c b/tools/testing/selftests/liveupdate/lib/liveupdate.c
> > similarity index 99%
> > rename from tools/testing/selftests/liveupdate/luo_test_utils.c
> > rename to tools/testing/selftests/liveupdate/lib/liveupdate.c
> > index 333a3530051b..897c200f3845 100644
> > --- a/tools/testing/selftests/liveupdate/luo_test_utils.c
> > +++ b/tools/testing/selftests/liveupdate/lib/liveupdate.c
> > @@ -22,7 +22,7 @@
> > #include <errno.h>
> > #include <stdarg.h>
> >
> > -#include "luo_test_utils.h"
> > +#include <libliveupdate.h>
>
> Linux kernel coding style generally prefers block headers to be sorted
> alphabetically.
>
Okay, I will reoder them here and in the other files.
Thanks!
next prev parent reply other threads:[~2026-06-12 17:29 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-10 23:09 [PATCH v2 0/2] Make liveupdate selftests library Vipin Sharma
2026-06-10 23:09 ` [PATCH v2 1/2] selftests/liveupdate: Move luo_test_utils.* into a reusable library Vipin Sharma
2026-06-12 3:09 ` Pasha Tatashin
2026-06-12 17:29 ` Vipin Sharma [this message]
2026-06-10 23:09 ` [PATCH v2 2/2] selftests/liveupdate: Add helpers to preserve/retrieve FDs Vipin Sharma
2026-06-11 8:56 ` Pratyush Yadav
2026-06-12 3:09 ` Pasha Tatashin
2026-06-12 17:34 ` Vipin Sharma
2026-06-12 19:32 ` Vipin Sharma
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260612172349.GA40404.vipinsh@google.com \
--to=vipinsh@google.com \
--cc=dmatlack@google.com \
--cc=kexec@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=pasha.tatashin@soleen.com \
--cc=pratyush@kernel.org \
--cc=rppt@kernel.org \
--cc=shuah@kernel.org \
--cc=skhawaja@google.com \
--cc=tarunsahu@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome