* [PATCH v2] xfs: use kmalloc_objs() instead of kmalloc() in xfs_da_grow_inode_int
@ 2026-07-16 21:48 Cihan Karadag
2026-07-17 15:16 ` Darrick J. Wong
0 siblings, 1 reply; 2+ messages in thread
From: Cihan Karadag @ 2026-07-16 21:48 UTC (permalink / raw)
To: Carlos Maiolino, Darrick J . Wong
Cc: Cihan Karadag, Shuah Khan, linux-xfs, linux-kernel
Convert open-coded kmalloc() multiplication to the modern kmalloc_objs()
interface to improve type safety and prevent potential integer
overflows.
No functional changes are intended.
Signed-off-by: Cihan Karadag <cihan.cihan@gmail.com>
---
Changes since v1:
- Use kmalloc_objs() instead of kmalloc_array(), per Darrick's suggestion.
fs/xfs/libxfs/xfs_da_btree.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/fs/xfs/libxfs/xfs_da_btree.c b/fs/xfs/libxfs/xfs_da_btree.c
index 9debb95d86fa0..f190c088591bc 100644
--- a/fs/xfs/libxfs/xfs_da_btree.c
+++ b/fs/xfs/libxfs/xfs_da_btree.c
@@ -2354,8 +2354,7 @@ xfs_da_grow_inode_int(
* If we didn't get it and the block might work if fragmented,
* try without the CONTIG flag. Loop until we get it all.
*/
- mapp = kmalloc(sizeof(*mapp) * count,
- GFP_KERNEL | __GFP_NOFAIL);
+ mapp = kmalloc_objs(*mapp, count, GFP_KERNEL | __GFP_NOFAIL);
for (b = *bno, mapi = 0; b < *bno + count; ) {
c = (int)(*bno + count - b);
nmap = min(XFS_BMAP_MAX_NMAP, c);
--
2.54.0
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH v2] xfs: use kmalloc_objs() instead of kmalloc() in xfs_da_grow_inode_int
2026-07-16 21:48 [PATCH v2] xfs: use kmalloc_objs() instead of kmalloc() in xfs_da_grow_inode_int Cihan Karadag
@ 2026-07-17 15:16 ` Darrick J. Wong
0 siblings, 0 replies; 2+ messages in thread
From: Darrick J. Wong @ 2026-07-17 15:16 UTC (permalink / raw)
To: Cihan Karadag; +Cc: Carlos Maiolino, Shuah Khan, linux-xfs, linux-kernel
On Thu, Jul 16, 2026 at 03:48:12PM -0600, Cihan Karadag wrote:
> Convert open-coded kmalloc() multiplication to the modern kmalloc_objs()
> interface to improve type safety and prevent potential integer
> overflows.
>
> No functional changes are intended.
>
> Signed-off-by: Cihan Karadag <cihan.cihan@gmail.com>
Looks ok,
Reviewed-by: "Darrick J. Wong" <djwong@kernel.org>
--D
> ---
> Changes since v1:
> - Use kmalloc_objs() instead of kmalloc_array(), per Darrick's suggestion.
>
> fs/xfs/libxfs/xfs_da_btree.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/fs/xfs/libxfs/xfs_da_btree.c b/fs/xfs/libxfs/xfs_da_btree.c
> index 9debb95d86fa0..f190c088591bc 100644
> --- a/fs/xfs/libxfs/xfs_da_btree.c
> +++ b/fs/xfs/libxfs/xfs_da_btree.c
> @@ -2354,8 +2354,7 @@ xfs_da_grow_inode_int(
> * If we didn't get it and the block might work if fragmented,
> * try without the CONTIG flag. Loop until we get it all.
> */
> - mapp = kmalloc(sizeof(*mapp) * count,
> - GFP_KERNEL | __GFP_NOFAIL);
> + mapp = kmalloc_objs(*mapp, count, GFP_KERNEL | __GFP_NOFAIL);
> for (b = *bno, mapi = 0; b < *bno + count; ) {
> c = (int)(*bno + count - b);
> nmap = min(XFS_BMAP_MAX_NMAP, c);
> --
> 2.54.0
>
>
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-07-17 15:16 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-07-16 21:48 [PATCH v2] xfs: use kmalloc_objs() instead of kmalloc() in xfs_da_grow_inode_int Cihan Karadag
2026-07-17 15:16 ` Darrick J. Wong
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox