mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v2] i3c: dw: rename "pclk" to "apb" to match dt-binding
@ 2026-08-14  4:03 Jisheng Zhang
  2026-08-14 17:01 ` Frank Li
  2026-08-18 21:16 ` Alexandre Belloni
  0 siblings, 2 replies; 3+ messages in thread
From: Jisheng Zhang @ 2026-08-14  4:03 UTC (permalink / raw)
  To: Alexandre Belloni, Frank Li; +Cc: linux-i3c, linux-kernel

Change clock name "pclk" to "apb" to match dt-binding doc. No upstream
device tree sources currently use the "pclk" clock name, so no any
backward compatibility issues.

Fixes: a0d48ebf39ce ("i3c: dw: Add optional apb clock")
Signed-off-by: Jisheng Zhang <jszhang@kernel.org>
---

since v1:
 - update commit msg

 drivers/i3c/master/dw-i3c-master.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/i3c/master/dw-i3c-master.c b/drivers/i3c/master/dw-i3c-master.c
index d6f84f0f4c2d..1053cfb05c05 100644
--- a/drivers/i3c/master/dw-i3c-master.c
+++ b/drivers/i3c/master/dw-i3c-master.c
@@ -1582,7 +1582,7 @@ int dw_i3c_common_probe(struct dw_i3c_master *master,
 	if (IS_ERR(master->core_clk))
 		return PTR_ERR(master->core_clk);
 
-	master->pclk = devm_clk_get_optional_enabled(&pdev->dev, "pclk");
+	master->pclk = devm_clk_get_optional_enabled(&pdev->dev, "apb");
 	if (IS_ERR(master->pclk))
 		return PTR_ERR(master->pclk);
 
-- 
2.51.0


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v2] i3c: dw: rename "pclk" to "apb" to match dt-binding
  2026-08-14  4:03 [PATCH v2] i3c: dw: rename "pclk" to "apb" to match dt-binding Jisheng Zhang
@ 2026-08-14 17:01 ` Frank Li
  2026-08-18 21:16 ` Alexandre Belloni
  1 sibling, 0 replies; 3+ messages in thread
From: Frank Li @ 2026-08-14 17:01 UTC (permalink / raw)
  To: Jisheng Zhang; +Cc: Alexandre Belloni, Frank Li, linux-i3c, linux-kernel

On Fri, Aug 14, 2026 at 12:03:45PM +0800, Jisheng Zhang wrote:
> Change clock name "pclk" to "apb" to match dt-binding doc. No upstream
> device tree sources currently use the "pclk" clock name, so no any
> backward compatibility issues.
>
> Fixes: a0d48ebf39ce ("i3c: dw: Add optional apb clock")
> Signed-off-by: Jisheng Zhang <jszhang@kernel.org>
> ---

Reviewed-by: Frank Li <Frank.Li@nxp.com>

>
> since v1:
>  - update commit msg
>
>  drivers/i3c/master/dw-i3c-master.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/i3c/master/dw-i3c-master.c b/drivers/i3c/master/dw-i3c-master.c
> index d6f84f0f4c2d..1053cfb05c05 100644
> --- a/drivers/i3c/master/dw-i3c-master.c
> +++ b/drivers/i3c/master/dw-i3c-master.c
> @@ -1582,7 +1582,7 @@ int dw_i3c_common_probe(struct dw_i3c_master *master,
>  	if (IS_ERR(master->core_clk))
>  		return PTR_ERR(master->core_clk);
>
> -	master->pclk = devm_clk_get_optional_enabled(&pdev->dev, "pclk");
> +	master->pclk = devm_clk_get_optional_enabled(&pdev->dev, "apb");
>  	if (IS_ERR(master->pclk))
>  		return PTR_ERR(master->pclk);
>
> --
> 2.51.0
>

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v2] i3c: dw: rename "pclk" to "apb" to match dt-binding
  2026-08-14  4:03 [PATCH v2] i3c: dw: rename "pclk" to "apb" to match dt-binding Jisheng Zhang
  2026-08-14 17:01 ` Frank Li
@ 2026-08-18 21:16 ` Alexandre Belloni
  1 sibling, 0 replies; 3+ messages in thread
From: Alexandre Belloni @ 2026-08-18 21:16 UTC (permalink / raw)
  To: Frank Li, Jisheng Zhang; +Cc: linux-i3c, linux-kernel

On Fri, 14 Aug 2026 12:03:45 +0800, Jisheng Zhang wrote:
> Change clock name "pclk" to "apb" to match dt-binding doc. No upstream
> device tree sources currently use the "pclk" clock name, so no any
> backward compatibility issues.

Applied, thanks!

[1/1] i3c: dw: rename "pclk" to "apb" to match dt-binding
      https://git.kernel.org/i3c/c/ff2eee2b8686

Best regards,

-- 
Alexandre Belloni, co-owner and COO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2026-08-18 21:16 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-08-14  4:03 [PATCH v2] i3c: dw: rename "pclk" to "apb" to match dt-binding Jisheng Zhang
2026-08-14 17:01 ` Frank Li
2026-08-18 21:16 ` Alexandre Belloni

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®