From: Lian Wang <lianux.mm@gmail.com>
To: "Barry Song (Xiaomi)" <baohua@kernel.org>
Cc: akpm@linux-foundation.org, lianux.mm@gmail.com,
axelrasmussen@google.com, baolin.wang@linux.alibaba.com,
baoquan.he@linux.dev, chenridong@xiaomi.com, david@kernel.org,
hannes@cmpxchg.org, kasong@tencent.com,
linux-kernel@vger.kernel.org, linux-mm@kvack.org, ljs@kernel.org,
lyugaofei@xiaomi.com, mhocko@kernel.org, qi.zheng@linux.dev,
shakeel.butt@linux.dev, stevensd@chromium.org,
wangzicheng@honor.com, weixugc@google.com, yuanchu@google.com,
zhangbo56@xiaomi.com, Xueyuan Chen <xueyuan.chen21@gmail.com>
Subject: Re: [PATCH v2 5/7] mm/mglru: make LRU folio prefetch helper an inline function
Date: Sun, 30 Aug 2026 15:43:56 +0800 [thread overview]
Message-ID: <20260830074405.79857-1-lianux.mm@gmail.com> (raw)
In-Reply-To: <20260827234704.63163-6-baohua@kernel.org>
On Fri, 28 Aug 2026 07:47:02 +0800 "Barry Song (Xiaomi)" <baohua@kernel.org> wrote:
> `prefetchw_prev_lru_folio()` is currently implemented as a macro with a
> potentially unused argument. This makes the helper harder to read and can
> also trigger checkpatch warnings about unused macro arguments.
>
> Make it a `static inline` function and remove the unnecessary `_field`
> argument. The helper always prefetches the previous folio's `flags`, so
> there is no need to make the field configurable.
>
> Signed-off-by: Barry Song (Xiaomi) <baohua@kernel.org>
> Tested-by: Xueyuan Chen <xueyuan.chen21@gmail.com>
> ---
> mm/vmscan.c | 26 +++++++++++++++-----------
> 1 file changed, 15 insertions(+), 11 deletions(-)
>
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index 2b33d3f44682..81f95a968447 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -182,17 +182,21 @@ struct scan_control {
> };
>
> #ifdef ARCH_HAS_PREFETCHW
> -#define prefetchw_prev_lru_folio(_folio, _base, _field) \
> - do { \
> - if ((_folio)->lru.prev != _base) { \
> - struct folio *prev; \
> - \
> - prev = lru_to_folio(&(_folio->lru)); \
> - prefetchw(&prev->_field); \
> - } \
> - } while (0)
> +static inline void prefetchw_prev_lru_folio(struct folio *folio,
> + struct list_head *base)
> +{
> + if (folio->lru.prev != base) {
> + struct folio *prev;
> +
> + prev = lru_to_folio(&folio->lru);
> + prefetchw(&prev->flags);
> + }
> +}
> #else
> -#define prefetchw_prev_lru_folio(_folio, _base, _field) do { } while (0)
> +static inline void prefetchw_prev_lru_folio(struct folio *folio,
> + struct list_head *base)
> +{
> +}
> #endif
>
> /*
> @@ -1695,7 +1699,7 @@ static unsigned long isolate_lru_folios(unsigned long nr_to_scan,
> struct folio *folio;
>
> folio = lru_to_folio(src);
> - prefetchw_prev_lru_folio(folio, src, flags);
> + prefetchw_prev_lru_folio(folio, src);
>
> nr_pages = folio_nr_pages(folio);
> total_scan += nr_pages;
> --
> 2.34.1
This preserves the prefetch behavior while making the helper
interface clearer. Looks good to me.
Reviewed-by: Lian Wang <lianux.mm@gmail.com>
next prev parent reply other threads:[~2026-08-30 7:44 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-27 23:46 [PATCH v2 0/7] mm/mglru: speed up inc_min_seq() and fix cold/hot inversions Barry Song (Xiaomi)
2026-08-27 23:46 ` [PATCH v2 1/7] mm/mglru: separate folio generation update from LRU accounting Barry Song (Xiaomi)
2026-08-30 7:26 ` Lian Wang
2026-08-27 23:46 ` [PATCH v2 2/7] mm/mglru: batch update lrugen->nr_pages in inc_min_seq() Barry Song (Xiaomi)
2026-08-30 3:58 ` Kunwu Chan
2026-08-30 4:26 ` Barry Song
2026-08-30 4:47 ` KunWu Chan
2026-08-30 7:01 ` Lian Wang
2026-08-27 23:47 ` [PATCH v2 3/7] mm/mglru: enhance cold/hot inversion handling " Barry Song (Xiaomi)
2026-08-30 2:43 ` Ridong Chen
2026-08-30 4:28 ` Barry Song
2026-08-30 7:02 ` Lian Wang
2026-08-27 23:47 ` [PATCH v2 4/7] mm/mglru: exclude folios promoted by aging from protected " Barry Song (Xiaomi)
2026-08-30 6:13 ` Ridong Chen
2026-08-30 7:03 ` Lian Wang
2026-08-27 23:47 ` [PATCH v2 5/7] mm/mglru: make LRU folio prefetch helper an inline function Barry Song (Xiaomi)
2026-08-30 7:43 ` Lian Wang [this message]
2026-08-27 23:47 ` [PATCH v2 6/7] mm/mglru: move folios from oldest gen to second-oldest gen from head to tail Barry Song (Xiaomi)
2026-08-30 7:44 ` Lian Wang
2026-08-27 23:47 ` [PATCH v2 7/7] mm/mglru: batch move folios to the second-oldest gen's LRU Barry Song (Xiaomi)
2026-08-28 3:29 ` Barry Song
2026-08-30 7:45 ` Lian Wang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260830074405.79857-1-lianux.mm@gmail.com \
--to=lianux.mm@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=axelrasmussen@google.com \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=baoquan.he@linux.dev \
--cc=chenridong@xiaomi.com \
--cc=david@kernel.org \
--cc=hannes@cmpxchg.org \
--cc=kasong@tencent.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=lyugaofei@xiaomi.com \
--cc=mhocko@kernel.org \
--cc=qi.zheng@linux.dev \
--cc=shakeel.butt@linux.dev \
--cc=stevensd@chromium.org \
--cc=wangzicheng@honor.com \
--cc=weixugc@google.com \
--cc=xueyuan.chen21@gmail.com \
--cc=yuanchu@google.com \
--cc=zhangbo56@xiaomi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®