mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mukesh R <mrathor@linux.microsoft.com>
To: linux-hyperv@vger.kernel.org, linux-kernel@vger.kernel.org
Cc: kys@microsoft.com, wei.liu@kernel.org, mhkelley58@gmail.com,
	mrathor@linux.microsoft.com
Subject: [PATCH V1 0/3] Redesign memory deposit logic
Date: Mon,  7 Sep 2026 19:13:37 -0700	[thread overview]
Message-ID: <20260908021340.2548924-1-mrathor@linux.microsoft.com> (raw)

This small series redesigns the memory deposit logic when Linux runs on
Hyper-V hypervisor as a privileged VM, the second patch explains why.
The series is split in three patches, the first patch renames the
functions to _old and this makes the 2 main patch much easier and nicer
to review. Last patch just removes the *_old functions from first patch.

Thanks,
-Mukesh

V1:
 o Remove hv_alloc_contig_pages() and make contiguous allocation part of
   hv_alloc_dep_pages(), thus getting rid of the kmalloc.
 o Instead of stubbing out functions, rename them to *_old.

Mukesh R (3):
  mshv: Rename memory deposit memory functions to old
  mshv: Redesign hypervisor memory deposit logic
  mshv: Remove unused *_old memory deposit functions

 drivers/hv/hv_proc.c           | 250 +++++++++++++++++++--------------
 drivers/hv/mshv_root_hv_call.c |  10 +-
 include/asm-generic/mshyperv.h |   5 -
 3 files changed, 145 insertions(+), 120 deletions(-)

-- 
2.51.2.vfs.0.1


             reply	other threads:[~2026-09-08  2:13 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-08  2:13 Mukesh R [this message]
2026-09-08  2:13 ` [PATCH V1 1/3] mshv: Rename memory deposit memory functions to _old Mukesh R
2026-09-08 18:01   ` Michael Kelley
2026-09-08 20:43     ` Mukesh R
2026-09-08 21:31       ` Michael Kelley
2026-09-08  2:13 ` [PATCH V1 2/3] mshv: Redesign hypervisor memory deposit logic Mukesh R
2026-09-08 18:02   ` Michael Kelley
2026-09-08 22:32     ` Mukesh R
2026-09-09 17:32       ` Michael Kelley
2026-09-09 18:22         ` Mukesh R
2026-09-08  2:13 ` [PATCH V1 3/3] mshv: Remove unused *_old memory deposit functions Mukesh R
2026-09-08 18:03   ` Michael Kelley

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260908021340.2548924-1-mrathor@linux.microsoft.com \
    --to=mrathor@linux.microsoft.com \
    --cc=kys@microsoft.com \
    --cc=linux-hyperv@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mhkelley58@gmail.com \
    --cc=wei.liu@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®