* [PATCH] mtd: rawnand: fsl_ifc: use devm_kasprintf for mtd name
@ 2026-09-09 22:38 Rosen Penev
2026-09-09 23:03 ` Rosen Penev
0 siblings, 1 reply; 2+ messages in thread
From: Rosen Penev @ 2026-09-09 22:38 UTC (permalink / raw)
To: linux-mtd
Cc: Miquel Raynal, Richard Weinberger, Vignesh Raghavendra, open list
Replace the manual kasprintf() in probe with devm_kasprintf() so the
name is freed automatically on driver removal, and drop the now
unnecessary kfree() in fsl_ifc_chip_remove() and its leftover mtd
local.
Assisted-by: opencode:big-pickle
Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
drivers/mtd/nand/raw/fsl_ifc_nand.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/drivers/mtd/nand/raw/fsl_ifc_nand.c b/drivers/mtd/nand/raw/fsl_ifc_nand.c
index 469b233db73e..cc75b6a67e07 100644
--- a/drivers/mtd/nand/raw/fsl_ifc_nand.c
+++ b/drivers/mtd/nand/raw/fsl_ifc_nand.c
@@ -963,10 +963,6 @@ static int fsl_ifc_chip_init(struct fsl_ifc_mtd *priv)
static int fsl_ifc_chip_remove(struct fsl_ifc_mtd *priv)
{
- struct mtd_info *mtd = nand_to_mtd(&priv->chip);
-
- kfree(mtd->name);
-
ifc_nand_ctrl->chips[priv->bank] = NULL;
return 0;
@@ -1061,7 +1057,7 @@ static int fsl_ifc_nand_probe(struct platform_device *dev)
&ifc->ifc_nand.nand_evter_intr_en);
mtd = nand_to_mtd(&priv->chip);
- mtd->name = kasprintf(GFP_KERNEL, "%llx.flash", (u64)res->start);
+ mtd->name = devm_kasprintf(priv->dev, GFP_KERNEL, "%llx.flash", (u64)res->start);
if (!mtd->name) {
ret = -ENOMEM;
goto err;
--
2.55.0
^ permalink raw reply [flat|nested] 2+ messages in thread* Re: [PATCH] mtd: rawnand: fsl_ifc: use devm_kasprintf for mtd name
2026-09-09 22:38 [PATCH] mtd: rawnand: fsl_ifc: use devm_kasprintf for mtd name Rosen Penev
@ 2026-09-09 23:03 ` Rosen Penev
0 siblings, 0 replies; 2+ messages in thread
From: Rosen Penev @ 2026-09-09 23:03 UTC (permalink / raw)
To: linux-mtd
Cc: Miquel Raynal, Richard Weinberger, Vignesh Raghavendra, open list
On Wed, Sep 9, 2026 at 3:38 PM Rosen Penev <rosenp@gmail.com> wrote:
>
> Replace the manual kasprintf() in probe with devm_kasprintf() so the
> name is freed automatically on driver removal, and drop the now
> unnecessary kfree() in fsl_ifc_chip_remove() and its leftover mtd
> local.
>
> Assisted-by: opencode:big-pickle
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---
> drivers/mtd/nand/raw/fsl_ifc_nand.c | 6 +-----
> 1 file changed, 1 insertion(+), 5 deletions(-)
>
> diff --git a/drivers/mtd/nand/raw/fsl_ifc_nand.c b/drivers/mtd/nand/raw/fsl_ifc_nand.c
> index 469b233db73e..cc75b6a67e07 100644
> --- a/drivers/mtd/nand/raw/fsl_ifc_nand.c
> +++ b/drivers/mtd/nand/raw/fsl_ifc_nand.c
> @@ -963,10 +963,6 @@ static int fsl_ifc_chip_init(struct fsl_ifc_mtd *priv)
>
> static int fsl_ifc_chip_remove(struct fsl_ifc_mtd *priv)
> {
> - struct mtd_info *mtd = nand_to_mtd(&priv->chip);
> -
> - kfree(mtd->name);
> -
> ifc_nand_ctrl->chips[priv->bank] = NULL;
>
> return 0;
> @@ -1061,7 +1057,7 @@ static int fsl_ifc_nand_probe(struct platform_device *dev)
> &ifc->ifc_nand.nand_evter_intr_en);
>
> mtd = nand_to_mtd(&priv->chip);
> - mtd->name = kasprintf(GFP_KERNEL, "%llx.flash", (u64)res->start);
> + mtd->name = devm_kasprintf(priv->dev, GFP_KERNEL, "%llx.flash", (u64)res->start);
Having &mtd->dev as the first argument would be interesting but nobody
does this.
> if (!mtd->name) {
> ret = -ENOMEM;
> goto err;
> --
> 2.55.0
>
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-09-09 23:03 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-09-09 22:38 [PATCH] mtd: rawnand: fsl_ifc: use devm_kasprintf for mtd name Rosen Penev
2026-09-09 23:03 ` Rosen Penev
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®