From: fangyu.yu@linux.alibaba.com
To: gsh517025@gmail.com
Cc: alex@ghiti.fr, andrew.jones@oss.qualcomm.com,
anup@brainfault.org, aou@eecs.berkeley.edu,
atish.patra@linux.dev, baolu.lu@linux.intel.com,
fangyu.yu@linux.alibaba.com, gong.shuai@sanechips.com.cn,
guoren@kernel.org, iommu@lists.linux.dev, jgg@nvidia.com,
jgg@ziepe.ca, joerg.roedel@amd.com, joro@8bytes.org,
jroedel@suse.de, kevin.tian@intel.com,
kvm-riscv@lists.infradead.org, linux-kernel@vger.kernel.org,
linux-riscv@lists.infradead.org, palmer@dabbelt.com,
pjw@kernel.org, robin.murphy@arm.com, skhawaja@google.com,
tomasz.jeznach@linux.dev, vasant.hegde@amd.com, will@kernel.org,
zong.li@sifive.com
Subject: Re: [RFC PATCH v4 04/10] iommu/riscv: use data structure instead of individual values
Date: Sun, 20 Sep 2026 11:08:46 +0800 [thread overview]
Message-ID: <20260920030846.20403-1-fangyu.yu@linux.alibaba.com> (raw)
In-Reply-To: <6d1bfb10-fd04-4e4e-895d-55c16fcea13f@gmail.com>
>Hi Fangyu,
>
>On 9/15/2026 11:28 AM, fangyu.yu@linux.alibaba.com wrote:
>> From: Zong Li <zong.li@sifive.com>
>>
>> The parameter will be increased when we need to set up more
>> bit fields in the device context. Use a data structure to
>> wrap them up.
>>
>> Signed-off-by: Zong Li <zong.li@sifive.com>
>> Signed-off-by: Fangyu Yu <fangyu.yu@linux.alibaba.com>
>> ---
>> drivers/iommu/riscv/iommu.c | 27 +++++++++++++++++----------
>> 1 file changed, 17 insertions(+), 10 deletions(-)
>>
>> diff --git a/drivers/iommu/riscv/iommu.c b/drivers/iommu/riscv/iommu.c
>> index a6c8307e82ea..c5b6214ee672 100644
>> --- a/drivers/iommu/riscv/iommu.c
>> +++ b/drivers/iommu/riscv/iommu.c
>> @@ -1165,7 +1165,7 @@ static void riscv_iommu_iodir_iotinval(struct riscv_iommu_device *iommu,
>> * interim translation faults.
>> */
>> static void riscv_iommu_iodir_update(struct riscv_iommu_device *iommu,
>> - struct device *dev, u64 fsc, u64 ta)
>> + struct device *dev, struct riscv_iommu_dc *new_dc)
>> {
>> struct iommu_fwspec *fwspec = dev_iommu_fwspec_get(dev);
>> struct riscv_iommu_dc *dc;
>> @@ -1204,10 +1204,10 @@ static void riscv_iommu_iodir_update(struct riscv_iommu_device *iommu,
>> for (i = 0; i < fwspec->num_ids; i++) {
>> dc = riscv_iommu_get_dc(iommu, fwspec->ids[i]);
>> tc = READ_ONCE(dc->tc);
>> - tc |= ta & RISCV_IOMMU_DC_TC_V;
>> + tc |= new_dc->ta & RISCV_IOMMU_DC_TC_V;
>
>According to SPEC 3.1.3.3, the "V bit" does not exist in DC.ta.
>This should be a convention from when the iodir_update() function
>did not yet use `struct riscv_iommu_dc` as a parameter, using bit 0
>of DC.ta to indicate that the DC is valid. Now that iodir_update()
>receives the complete dc, it can directly access DC.tc.V, so this
>convention should no longer be necessary and will cause confusion.
>
Hi Shuai:
Thanks for the clarification.
My understanding is that `ta` here is used as a
combined concept, not only for `DC.ta`, but also
for `PC.ta` in this flow.
The `V` bit is only initialized when `ta` is first
set up, so the current usage still follows the
original design, without changing most of the
existing logic.
The original code also has comments describing
this behavior.
Thanks,
Fangyu
>>
>> - WRITE_ONCE(dc->fsc, fsc);
>> - WRITE_ONCE(dc->ta, ta & RISCV_IOMMU_PC_TA_PSCID);
>> + WRITE_ONCE(dc->fsc, new_dc->fsc);
>> + WRITE_ONCE(dc->ta, new_dc->ta & RISCV_IOMMU_PC_TA_PSCID);
>
>`RISCV_IOMMU_PC_*` should be replaced with `RISCV_IOMMU_DC_*` for
>readability. There are several other similar places in this file
>that are unrelated to Process Context or PASID but use the *PC* macros.
>
My understanding is similar to the `ta` case: `fsc`
likely refers to both `dc.fsc` and `pc.fsc` in this
path, since some of their fields share the same bit
layout.
If we want to rename these for readability, I think
that should be done in a separate patch set, rather
than as part of this one.
>
>Thanks,
>Shuai
>
>> /* Update device context, write TC.V as the last step. */
>> dma_wmb();
>> WRITE_ONCE(dc->tc, tc);
>> @@ -1288,22 +1288,22 @@ static int riscv_iommu_attach_paging_domain(struct iommu_domain *iommu_domain,
>> struct riscv_iommu_device *iommu = dev_to_iommu(dev);
>> struct riscv_iommu_info *info = dev_iommu_priv_get(dev);
>> struct pt_iommu_riscv_64_hw_info pt_info;
>> - u64 fsc, ta;
>> + struct riscv_iommu_dc dc = {0};
>>
>> pt_iommu_riscv_64_hw_info(&domain->riscvpt, &pt_info);
>>
>> if (!riscv_iommu_pt_supported(iommu, pt_info.fsc_iosatp_mode))
>> return -ENODEV;
>>
>> - fsc = FIELD_PREP(RISCV_IOMMU_PC_FSC_MODE, pt_info.fsc_iosatp_mode) |
>> + dc.fsc = FIELD_PREP(RISCV_IOMMU_PC_FSC_MODE, pt_info.fsc_iosatp_mode) |
>> FIELD_PREP(RISCV_IOMMU_PC_FSC_PPN, pt_info.ppn);
>> - ta = FIELD_PREP(RISCV_IOMMU_PC_TA_PSCID, domain->pscid) |
>> + dc.ta = FIELD_PREP(RISCV_IOMMU_PC_TA_PSCID, domain->pscid) |
>> RISCV_IOMMU_PC_TA_V;
>>
>> if (riscv_iommu_bond_link(domain, dev))
>> return -ENOMEM;
>>
>> - riscv_iommu_iodir_update(iommu, dev, fsc, ta);
>> + riscv_iommu_iodir_update(iommu, dev, &dc);
>> riscv_iommu_bond_unlink(info->domain, dev);
>> info->domain = domain;
>>
>> @@ -1378,9 +1378,12 @@ static int riscv_iommu_attach_blocking_domain(struct iommu_domain *iommu_domain,
>> {
>> struct riscv_iommu_device *iommu = dev_to_iommu(dev);
>> struct riscv_iommu_info *info = dev_iommu_priv_get(dev);
>> + struct riscv_iommu_dc dc = {0};
>> +
>> + dc.fsc = RISCV_IOMMU_FSC_BARE;
>>
>> /* Make device context invalid, translation requests will fault w/ #258 */
>> - riscv_iommu_iodir_update(iommu, dev, RISCV_IOMMU_FSC_BARE, 0);
>> + riscv_iommu_iodir_update(iommu, dev, &dc);
>> riscv_iommu_bond_unlink(info->domain, dev);
>> info->domain = NULL;
>>
>> @@ -1400,8 +1403,12 @@ static int riscv_iommu_attach_identity_domain(struct iommu_domain *iommu_domain,
>> {
>> struct riscv_iommu_device *iommu = dev_to_iommu(dev);
>> struct riscv_iommu_info *info = dev_iommu_priv_get(dev);
>> + struct riscv_iommu_dc dc = {0};
>> +
>> + dc.fsc = RISCV_IOMMU_FSC_BARE;
>> + dc.ta = RISCV_IOMMU_PC_TA_V;
>>
>> - riscv_iommu_iodir_update(iommu, dev, RISCV_IOMMU_FSC_BARE, RISCV_IOMMU_PC_TA_V);
>> + riscv_iommu_iodir_update(iommu, dev, &dc);
>> riscv_iommu_bond_unlink(info->domain, dev);
>> info->domain = NULL;
>>
next prev parent reply other threads:[~2026-09-20 3:08 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-15 3:28 [RFC PATCH v4 00/10] iommu/riscv: Add hardware dirty tracking for second-stage domains fangyu.yu
2026-09-15 3:28 ` [RFC PATCH v4 01/10] iommupt: Add RISC-V Second-stage (iohgatp) page table support fangyu.yu
2026-09-15 3:28 ` [RFC PATCH v4 02/10] iommupt: Add RISC-V dirty tracking PTE ops fangyu.yu
2026-09-15 3:28 ` [RFC PATCH v4 03/10] iommu/riscv: report iommu capabilities fangyu.yu
2026-09-18 3:39 ` Nutty.Liu
2026-09-15 3:28 ` [RFC PATCH v4 04/10] iommu/riscv: use data structure instead of individual values fangyu.yu
2026-09-18 3:42 ` Nutty.Liu
2026-09-18 16:08 ` Gong Shuai
2026-09-20 3:08 ` fangyu.yu [this message]
2026-09-20 5:27 ` Gong Shuai
2026-09-15 3:28 ` [RFC PATCH v4 05/10] iommu/riscv: support GSCID and GVMA invalidation command fangyu.yu
2026-09-18 4:03 ` Nutty.Liu
2026-09-15 3:28 ` [RFC PATCH v4 06/10] RISC-V: KVM: Enable KVM_VFIO interfaces on RISC-V arch fangyu.yu
2026-09-18 4:03 ` Nutty.Liu
2026-09-15 3:28 ` [RFC PATCH v4 07/10] iommu/riscv: Add domain_alloc_paging_flags for second-stage domain fangyu.yu
2026-09-15 3:28 ` [RFC PATCH v4 08/10] iommu/riscv: Pre-enable GADE for second-stage domains fangyu.yu
2026-09-18 16:18 ` Gong Shuai
2026-09-20 3:12 ` fangyu.yu
2026-09-20 5:05 ` Gong Shuai
2026-09-20 7:42 ` fangyu.yu
2026-09-15 3:28 ` [RFC PATCH v4 09/10] iommu/riscv: Add dirty tracking support " fangyu.yu
2026-09-17 1:40 ` [RFC PATCH v4 00/10] iommu/riscv: Add hardware dirty tracking " Gong Shuai
2026-09-17 2:02 ` fangyu.yu
2026-09-17 2:54 ` [RFC PATCH v4 10/10] iommu/riscv: Add IOTINVAL.GVMA after updating DDT/PDT entries fangyu.yu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260920030846.20403-1-fangyu.yu@linux.alibaba.com \
--to=fangyu.yu@linux.alibaba.com \
--cc=alex@ghiti.fr \
--cc=andrew.jones@oss.qualcomm.com \
--cc=anup@brainfault.org \
--cc=aou@eecs.berkeley.edu \
--cc=atish.patra@linux.dev \
--cc=baolu.lu@linux.intel.com \
--cc=gong.shuai@sanechips.com.cn \
--cc=gsh517025@gmail.com \
--cc=guoren@kernel.org \
--cc=iommu@lists.linux.dev \
--cc=jgg@nvidia.com \
--cc=jgg@ziepe.ca \
--cc=joerg.roedel@amd.com \
--cc=joro@8bytes.org \
--cc=jroedel@suse.de \
--cc=kevin.tian@intel.com \
--cc=kvm-riscv@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-riscv@lists.infradead.org \
--cc=palmer@dabbelt.com \
--cc=pjw@kernel.org \
--cc=robin.murphy@arm.com \
--cc=skhawaja@google.com \
--cc=tomasz.jeznach@linux.dev \
--cc=vasant.hegde@amd.com \
--cc=will@kernel.org \
--cc=zong.li@sifive.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®