mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Manivannan Sadhasivam" <mani@kernel.org>,
	"Gabor Juhos" <j4g8y7@gmail.com>,
	"Miquel Raynal" <miquel.raynal@bootlin.com>,
	"Richard Weinberger" <richard@nod.at>,
	"Vignesh Raghavendra" <vigneshr@ti.com>
Cc: linux-arm-msm@vger.kernel.org, linux-kernel@vger.kernel.org,
	"Md Sadre Alam" <md.alam@oss.qualcomm.com>,
	linux-mtd@lists.infradead.org
Subject: Re: [PATCH 6/8] mtd: rawnand: qcom: make nandc_set_read_loc_last() more generic
Date: Thu, 24 Sep 2026 20:09:53 +0000	[thread overview]
Message-ID: <20260924200953.63D471F00893@smtp.kernel.org> (raw)
In-Reply-To: <20260924-qcom_nandc-share-more-code-v1-6-f3012199b161@gmail.com>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Medium] mtd: commit message incorrectly claims 'qpic_nandc' prefix is used
--

commit 640e8b0121507d995cca38494c17f8a44fcdb750
Author: Gabor Juhos <j4g8y7@gmail.com>

mtd: rawnand: qcom: make nandc_set_read_loc_last() more generic

This commit modifies nandc_set_read_loc_last() to take a qcom_nand_controller
pointer directly instead of a nand_chip pointer, aiming to make it more
generic. It also renames the function as part of a preparation to move it
into common code.

>     In order to make the function more generic, change the declaration
>     to get a 'qcom_nandc_controller' pointer directly, and update the
>     callers accordingly. While at it, also change the function name to
>     use a 'qpic_nandc' prefix.

[Severity: Medium]
Does the commit message accurately reflect the new function name? The message
states the function is renamed using a 'qpic_nandc' prefix, but looking at
the changes to drivers/mtd/nand/raw/qcom_nandc.c, the function is actually
renamed to use a 'qcom_nandc' prefix:

> --- a/drivers/mtd/nand/raw/qcom_nandc.c
> +++ b/drivers/mtd/nand/raw/qcom_nandc.c

[ ... ]

> -static void nandc_set_read_loc_last(struct nand_chip *chip,
> -				    int reg_base, u32 cw_offset,
> -				    u32 read_size, u32 is_last_read_loc)
> +static void qcom_nandc_set_read_loc_last(struct qcom_nand_controller *nandc,
> +					 int reg_base, u32 cw_offset,
> +					 u32 read_size, u32 is_last_read_loc)

Should the commit message be updated to mention 'qcom_nandc' instead, or was
the function intended to be named qpic_nandc_set_read_loc_last()?

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260924-qcom_nandc-share-more-code-v1-0-f3012199b161@gmail.com?part=6

  reply	other threads:[~2026-09-24 20:09 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-24 20:04 [PATCH 0/8] mtd: rawnand: qcom: share more common code Gabor Juhos
2026-09-24 20:04 ` [PATCH 1/8] mtd: rawnand: qcom: make check_flash_errors() more generic Gabor Juhos
2026-09-24 20:09   ` sashiko-bot
2026-09-24 20:22     ` Gabor Juhos
2026-09-24 20:04 ` [PATCH 2/8] mtd: rawnand: qcom: make config_nand_page_read() " Gabor Juhos
2026-09-24 20:10   ` sashiko-bot
2026-09-24 20:04 ` [PATCH 3/8] mtd: rawnand: qcom: make config_nand_page_write() " Gabor Juhos
2026-09-24 20:09   ` sashiko-bot
2026-09-24 20:04 ` [PATCH 4/8] mtd: rawnand: qcom: make config_nand_cw_write() " Gabor Juhos
2026-09-24 20:09   ` sashiko-bot
2026-09-24 20:04 ` [PATCH 5/8] mtd: rawnand: qcom: make nandc_set_read_loc_first() " Gabor Juhos
2026-09-24 20:10   ` sashiko-bot
2026-09-24 20:04 ` [PATCH 6/8] mtd: rawnand: qcom: make nandc_set_read_loc_last() " Gabor Juhos
2026-09-24 20:09   ` sashiko-bot [this message]
2026-09-24 20:04 ` [PATCH 7/8] mtd: rawnand: qcom: rename 'nand_stats' structure Gabor Juhos
2026-09-24 20:04 ` [PATCH 8/8] mtd: rawnand: qcom: move common code to the 'qpic_common' module Gabor Juhos

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260924200953.63D471F00893@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=j4g8y7@gmail.com \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=mani@kernel.org \
    --cc=md.alam@oss.qualcomm.com \
    --cc=miquel.raynal@bootlin.com \
    --cc=richard@nod.at \
    --cc=sashiko-reviews@lists.linux.dev \
    --cc=vigneshr@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®