From: Gabor Juhos <j4g8y7@gmail.com>
To: sashiko-reviews@lists.linux.dev,
Vignesh Raghavendra <vigneshr@ti.com>,
Manivannan Sadhasivam <mani@kernel.org>,
Miquel Raynal <miquel.raynal@bootlin.com>,
Richard Weinberger <richard@nod.at>
Cc: linux-kernel@vger.kernel.org,
Md Sadre Alam <md.alam@oss.qualcomm.com>,
linux-arm-msm@vger.kernel.org, linux-mtd@lists.infradead.org
Subject: Re: [PATCH 1/8] mtd: rawnand: qcom: make check_flash_errors() more generic
Date: Thu, 24 Sep 2026 22:22:24 +0200 [thread overview]
Message-ID: <bebf5c3e-74c9-4355-b4da-294a87549d38@gmail.com> (raw)
In-Reply-To: <20260924200931.6ED351F00893@smtp.kernel.org>
2026. 09. 24. 22:09 keltezéssel, sashiko-bot@kernel.org írta:
> Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
> - [Medium] mtd: rawnand: qcom: mismatch between commit message and function prefix
> --
>
> commit a83607e63ec53429dc425262093eef9dee3bfd4e
> Author: Gabor Juhos <j4g8y7@gmail.com>
>
> mtd: rawnand: qcom: make check_flash_errors() more generic
>
> The function gets a qcom_nand_host pointer as a parameter but it is
> only used to extract the nand controller's private structure from that.
> In order to make the function more generic, change the declaration to
> get a qcom_nandc_controller pointer directly, and update the callers
> accordingly.
>
>> diff --git a/drivers/mtd/nand/raw/qcom_nandc.c b/drivers/mtd/nand/raw/qcom_nandc.c
>> index d7642db2e2df1..12bfb14cd9a37 100644
>> --- a/drivers/mtd/nand/raw/qcom_nandc.c
>> +++ b/drivers/mtd/nand/raw/qcom_nandc.c
>> @@ -449,10 +449,9 @@ struct read_stats {
>> };
>>
>> /* reads back FLASH_STATUS register set by the controller */
>> -static int check_flash_errors(struct qcom_nand_host *host, int cw_cnt)
>> +static int qcom_nandc_check_flash_errors(struct qcom_nand_controller *nandc,
>> + int cw_cnt)
>> {
>
> [Severity: Medium]
> This isn't a bug, but there is a mismatch between the commit message and
> the actual function renaming.
>
> The commit message states the function will use the "qpic_nandc" prefix:
> "While at it, also change the function name to use a 'qpic_nandc' prefix."
>
> However, the code changes the name to qcom_nandc_check_flash_errors, using
> the "qcom_nandc" prefix instead.
>
> Could the commit message be updated to match the code, or should the
> function be named qpic_nandc_check_flash_errors?
>
May bad, the commit message is wrong of course. I will fix it in the next
version, also in the the other patches.
-Gabor
next prev parent reply other threads:[~2026-09-24 20:22 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-24 20:04 [PATCH 0/8] mtd: rawnand: qcom: share more common code Gabor Juhos
2026-09-24 20:04 ` [PATCH 1/8] mtd: rawnand: qcom: make check_flash_errors() more generic Gabor Juhos
2026-09-24 20:09 ` sashiko-bot
2026-09-24 20:22 ` Gabor Juhos [this message]
2026-09-24 20:04 ` [PATCH 2/8] mtd: rawnand: qcom: make config_nand_page_read() " Gabor Juhos
2026-09-24 20:10 ` sashiko-bot
2026-09-24 20:04 ` [PATCH 3/8] mtd: rawnand: qcom: make config_nand_page_write() " Gabor Juhos
2026-09-24 20:09 ` sashiko-bot
2026-09-24 20:04 ` [PATCH 4/8] mtd: rawnand: qcom: make config_nand_cw_write() " Gabor Juhos
2026-09-24 20:09 ` sashiko-bot
2026-09-24 20:04 ` [PATCH 5/8] mtd: rawnand: qcom: make nandc_set_read_loc_first() " Gabor Juhos
2026-09-24 20:10 ` sashiko-bot
2026-09-24 20:04 ` [PATCH 6/8] mtd: rawnand: qcom: make nandc_set_read_loc_last() " Gabor Juhos
2026-09-24 20:09 ` sashiko-bot
2026-09-24 20:04 ` [PATCH 7/8] mtd: rawnand: qcom: rename 'nand_stats' structure Gabor Juhos
2026-09-24 20:04 ` [PATCH 8/8] mtd: rawnand: qcom: move common code to the 'qpic_common' module Gabor Juhos
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=bebf5c3e-74c9-4355-b4da-294a87549d38@gmail.com \
--to=j4g8y7@gmail.com \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=mani@kernel.org \
--cc=md.alam@oss.qualcomm.com \
--cc=miquel.raynal@bootlin.com \
--cc=richard@nod.at \
--cc=sashiko-reviews@lists.linux.dev \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®