mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] staging: rtl8723bs: rename phy_status_rpt_8192cd_t to rtl8723bs_phy_status_rpt.
@ 2026-10-01 12:17 Timo Joannin
  2026-10-01 12:26 ` Greg Kroah-Hartman
  0 siblings, 1 reply; 2+ messages in thread
From: Timo Joannin @ 2026-10-01 12:17 UTC (permalink / raw)
  To: Greg Kroah-Hartman
  Cc: Jennifer Guo, Michael Straube, Michael Steinmötzger,
	Dan Carpenter, Atharv Margur, linux-staging, linux-kernel,
	Timo Joannin

The struct identifier references the 8192CD chip while being in a
rtl8723bs codebase. Additionally, the identifier uses the _t suffix,
while being generally reserved for typedef identifiers.

Rename the struct to rtl8723bs_phy_status_rpt
across the rtl8723bs driver to accurately
reflect the codebase and clean up the naming.

Signed-off-by: Timo Joannin <timo.joannin@gmail.com>
---
 drivers/staging/rtl8723bs/hal/odm_HWConfig.c | 3 ++-
 drivers/staging/rtl8723bs/hal/odm_HWConfig.h | 2 +-
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/rtl8723bs/hal/odm_HWConfig.c b/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
index 34b0369a7936..bf2479c01873 100644
--- a/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
+++ b/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
@@ -105,7 +105,8 @@ static void odm_rx_phy_status_parsing(struct dm_odm_t *dm_odm,
 	bool is_cck_rate = false;
 	u8 rf_rx_num = 0;
 	u8 lna_idx, vga_idx;
-	struct phy_status_rpt_8192cd_t *phy_sta_rpt = (struct phy_status_rpt_8192cd_t *)phy_status;
+	struct rtl8723bs_phy_status_rpt *phy_sta_rpt =
+		(struct rtl8723bs_phy_status_rpt *)phy_status;
 
 	is_cck_rate = pkt_info->data_rate <= DESC_RATE11M;
 	phy_info->rx_mimo_signal_quality[RF_PATH_A] = -1;
diff --git a/drivers/staging/rtl8723bs/hal/odm_HWConfig.h b/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
index ca3380328a72..ae010cae9dd7 100644
--- a/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
+++ b/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
@@ -18,7 +18,7 @@ struct phy_rx_agc_info_t {
 	#endif
 };
 
-struct phy_status_rpt_8192cd_t {
+struct rtl8723bs_phy_status_rpt {
 	struct phy_rx_agc_info_t path_agc[2];
 	u8 ch_corr[2];
 	u8 cck_sig_qual_ofdm_pwdb_all;
-- 
2.55.0


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] staging: rtl8723bs: rename phy_status_rpt_8192cd_t to rtl8723bs_phy_status_rpt.
  2026-10-01 12:17 [PATCH] staging: rtl8723bs: rename phy_status_rpt_8192cd_t to rtl8723bs_phy_status_rpt Timo Joannin
@ 2026-10-01 12:26 ` Greg Kroah-Hartman
  0 siblings, 0 replies; 2+ messages in thread
From: Greg Kroah-Hartman @ 2026-10-01 12:26 UTC (permalink / raw)
  To: Timo Joannin
  Cc: Jennifer Guo, Michael Straube, Michael Steinmötzger,
	Dan Carpenter, Atharv Margur, linux-staging, linux-kernel

On Thu, Oct 01, 2026 at 02:17:00PM +0200, Timo Joannin wrote:
> The struct identifier references the 8192CD chip while being in a
> rtl8723bs codebase. Additionally, the identifier uses the _t suffix,
> while being generally reserved for typedef identifiers.
> 
> Rename the struct to rtl8723bs_phy_status_rpt
> across the rtl8723bs driver to accurately
> reflect the codebase and clean up the naming.
> 
> Signed-off-by: Timo Joannin <timo.joannin@gmail.com>
> ---
>  drivers/staging/rtl8723bs/hal/odm_HWConfig.c | 3 ++-
>  drivers/staging/rtl8723bs/hal/odm_HWConfig.h | 2 +-
>  2 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/staging/rtl8723bs/hal/odm_HWConfig.c b/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
> index 34b0369a7936..bf2479c01873 100644
> --- a/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
> +++ b/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
> @@ -105,7 +105,8 @@ static void odm_rx_phy_status_parsing(struct dm_odm_t *dm_odm,
>  	bool is_cck_rate = false;
>  	u8 rf_rx_num = 0;
>  	u8 lna_idx, vga_idx;
> -	struct phy_status_rpt_8192cd_t *phy_sta_rpt = (struct phy_status_rpt_8192cd_t *)phy_status;
> +	struct rtl8723bs_phy_status_rpt *phy_sta_rpt =
> +		(struct rtl8723bs_phy_status_rpt *)phy_status;

Why is this pointer being cast from a structure type, to a u8 *, and now
back to the real structure again?  That's a mess, please propagate the
real structure type all the way through the call chain so that there is
no more casts needed.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2026-10-01 12:27 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-10-01 12:17 [PATCH] staging: rtl8723bs: rename phy_status_rpt_8192cd_t to rtl8723bs_phy_status_rpt Timo Joannin
2026-10-01 12:26 ` Greg Kroah-Hartman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®