mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v3] staging: rtl8723bs: rename phy_status_rpt_8192cd_t to rtl8723bs_phy_status_rpt.
@ 2026-10-01 15:51 Timo Joannin
  2026-10-01 16:06 ` Greg KH
  0 siblings, 1 reply; 2+ messages in thread
From: Timo Joannin @ 2026-10-01 15:51 UTC (permalink / raw)
  To: gregkh
  Cc: guojy.bj, m.steinmoetzger, atharvmargur, straube.linux,
	andriy.shevchenko, s9430939, qstrydom0, dev.lmmrtns, khomenkov,
	linux-staging, linux-kernel, Timo Joannin

The struct identifier references the 8192CD chip while being in a
rtl8723bs codebase. Additionally, the identifier uses the _t suffix,
while being generally reserved for typedef identifiers.

Rename the struct to rtl8723bs_phy_status_rpt
across the rtl8723bs codebase to accurately
reflect the driver and clean up the naming.

Additionally, propagate the real structure type all the way
through the call chain to remove redundant casts to and from u8 *.

Signed-off-by: Timo Joannin <timo.joannin@gmail.com>
---
Changes in v3:
- Included patch version changelog (missed in v2, sorry).

Changes in v2:
- Propagated the real struct type through the call chain to remove u8 * casting.

 drivers/staging/rtl8723bs/hal/odm_HWConfig.c   | 6 +++---
 drivers/staging/rtl8723bs/hal/odm_HWConfig.h   | 5 +++--
 drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c | 7 ++++---
 3 files changed, 10 insertions(+), 8 deletions(-)

diff --git a/drivers/staging/rtl8723bs/hal/odm_HWConfig.c b/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
index 34b0369a7936..c85194c8fe67 100644
--- a/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
+++ b/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
@@ -95,7 +95,7 @@ static s8 odm_cck_rssi(u8 lna_idx, u8 vga_idx)
 
 static void odm_rx_phy_status_parsing(struct dm_odm_t *dm_odm,
 				      struct odm_phy_info *phy_info,
-				      u8 *phy_status,
+				      struct rtl8723bs_phy_status_rpt *phy_sta_rpt,
 				      struct odm_packet_info *pkt_info)
 {
 	u8 i;
@@ -105,7 +105,6 @@ static void odm_rx_phy_status_parsing(struct dm_odm_t *dm_odm,
 	bool is_cck_rate = false;
 	u8 rf_rx_num = 0;
 	u8 lna_idx, vga_idx;
-	struct phy_status_rpt_8192cd_t *phy_sta_rpt = (struct phy_status_rpt_8192cd_t *)phy_status;
 
 	is_cck_rate = pkt_info->data_rate <= DESC_RATE11M;
 	phy_info->rx_mimo_signal_quality[RF_PATH_A] = -1;
@@ -383,7 +382,8 @@ static void odm_Process_RSSIForDM(
 
 /*  Endianness before calling this API */
 void odm_phy_status_query(struct dm_odm_t *dm_odm, struct odm_phy_info *phy_info,
-			  u8 *phy_status, struct odm_packet_info *pkt_info)
+			  struct rtl8723bs_phy_status_rpt *phy_status,
+			  struct odm_packet_info *pkt_info)
 {
 
 	odm_rx_phy_status_parsing(dm_odm, phy_info, phy_status, pkt_info);
diff --git a/drivers/staging/rtl8723bs/hal/odm_HWConfig.h b/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
index ca3380328a72..21182a880da3 100644
--- a/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
+++ b/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
@@ -18,7 +18,7 @@ struct phy_rx_agc_info_t {
 	#endif
 };
 
-struct phy_status_rpt_8192cd_t {
+struct rtl8723bs_phy_status_rpt {
 	struct phy_rx_agc_info_t path_agc[2];
 	u8 ch_corr[2];
 	u8 cck_sig_qual_ofdm_pwdb_all;
@@ -57,7 +57,8 @@ struct phy_status_rpt_8192cd_t {
 };
 
 void odm_phy_status_query(struct dm_odm_t *dm_odm, struct odm_phy_info *phy_info,
-			  u8 *phy_status, struct odm_packet_info *pkt_info);
+			  struct rtl8723bs_phy_status_rpt *phy_status,
+			  struct odm_packet_info *pkt_info);
 
 enum hal_status ODM_ConfigRFWithTxPwrTrackHeaderFile(struct dm_odm_t *pDM_Odm);
 
diff --git a/drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c b/drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c
index 304fda3a3b5c..a62b845c69f9 100644
--- a/drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c
+++ b/drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c
@@ -73,7 +73,7 @@ static void update_recvframe_attrib(struct adapter *padapter,
  *precvframe->u.hdr.rx_data should be ready!
  */
 static void update_recvframe_phyinfo(union recv_frame *precvframe,
-				     struct phy_stat *pphy_status)
+				     struct rtl8723bs_phy_status_rpt *pphy_status)
 {
 	struct adapter *padapter = precvframe->u.hdr.adapter;
 	struct rx_pkt_attrib *pattrib = &precvframe->u.hdr.attrib;
@@ -125,7 +125,7 @@ static void update_recvframe_phyinfo(union recv_frame *precvframe,
 	pkt_info.data_rate = pattrib->data_rate;
 
 	odm_phy_status_query(&p_hal_data->odmpriv, p_phy_info,
-			   (u8 *)pphy_status, &(pkt_info));
+			   pphy_status, &(pkt_info));
 	if (psta)
 		psta->rssi = pattrib->phy_info.RecvSignalPower;
 	precvframe->u.hdr.psta = NULL;
@@ -317,7 +317,8 @@ static void rtl8723bs_recv_tasklet(struct tasklet_struct *t)
 
 				if (pattrib->pkt_rpt_type == NORMAL_RX) { /* Normal rx packet */
 					if (pattrib->physt)
-						update_recvframe_phyinfo(precvframe, (struct phy_stat *)ptr);
+						update_recvframe_phyinfo(precvframe,
+							(struct rtl8723bs_phy_status_rpt *)ptr);
 
 					rtw_recv_entry(precvframe);
 				} else if (pattrib->pkt_rpt_type == C2H_PACKET) {
-- 
2.55.0


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH v3] staging: rtl8723bs: rename phy_status_rpt_8192cd_t to rtl8723bs_phy_status_rpt.
  2026-10-01 15:51 [PATCH v3] staging: rtl8723bs: rename phy_status_rpt_8192cd_t to rtl8723bs_phy_status_rpt Timo Joannin
@ 2026-10-01 16:06 ` Greg KH
  0 siblings, 0 replies; 2+ messages in thread
From: Greg KH @ 2026-10-01 16:06 UTC (permalink / raw)
  To: Timo Joannin
  Cc: guojy.bj, m.steinmoetzger, atharvmargur, straube.linux,
	andriy.shevchenko, s9430939, qstrydom0, dev.lmmrtns, khomenkov,
	linux-staging, linux-kernel

On Thu, Oct 01, 2026 at 05:51:34PM +0200, Timo Joannin wrote:
> The struct identifier references the 8192CD chip while being in a
> rtl8723bs codebase. Additionally, the identifier uses the _t suffix,
> while being generally reserved for typedef identifiers.
> 
> Rename the struct to rtl8723bs_phy_status_rpt
> across the rtl8723bs codebase to accurately
> reflect the driver and clean up the naming.
> 
> Additionally, propagate the real structure type all the way
> through the call chain to remove redundant casts to and from u8 *.
> 
> Signed-off-by: Timo Joannin <timo.joannin@gmail.com>
> ---
> Changes in v3:
> - Included patch version changelog (missed in v2, sorry).
> 
> Changes in v2:
> - Propagated the real struct type through the call chain to remove u8 * casting.
> 
>  drivers/staging/rtl8723bs/hal/odm_HWConfig.c   | 6 +++---
>  drivers/staging/rtl8723bs/hal/odm_HWConfig.h   | 5 +++--
>  drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c | 7 ++++---
>  3 files changed, 10 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/staging/rtl8723bs/hal/odm_HWConfig.c b/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
> index 34b0369a7936..c85194c8fe67 100644
> --- a/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
> +++ b/drivers/staging/rtl8723bs/hal/odm_HWConfig.c
> @@ -95,7 +95,7 @@ static s8 odm_cck_rssi(u8 lna_idx, u8 vga_idx)
>  
>  static void odm_rx_phy_status_parsing(struct dm_odm_t *dm_odm,
>  				      struct odm_phy_info *phy_info,
> -				      u8 *phy_status,
> +				      struct rtl8723bs_phy_status_rpt *phy_sta_rpt,
>  				      struct odm_packet_info *pkt_info)
>  {
>  	u8 i;
> @@ -105,7 +105,6 @@ static void odm_rx_phy_status_parsing(struct dm_odm_t *dm_odm,
>  	bool is_cck_rate = false;
>  	u8 rf_rx_num = 0;
>  	u8 lna_idx, vga_idx;
> -	struct phy_status_rpt_8192cd_t *phy_sta_rpt = (struct phy_status_rpt_8192cd_t *)phy_status;
>  
>  	is_cck_rate = pkt_info->data_rate <= DESC_RATE11M;
>  	phy_info->rx_mimo_signal_quality[RF_PATH_A] = -1;
> @@ -383,7 +382,8 @@ static void odm_Process_RSSIForDM(
>  
>  /*  Endianness before calling this API */
>  void odm_phy_status_query(struct dm_odm_t *dm_odm, struct odm_phy_info *phy_info,
> -			  u8 *phy_status, struct odm_packet_info *pkt_info)
> +			  struct rtl8723bs_phy_status_rpt *phy_status,
> +			  struct odm_packet_info *pkt_info)
>  {
>  
>  	odm_rx_phy_status_parsing(dm_odm, phy_info, phy_status, pkt_info);
> diff --git a/drivers/staging/rtl8723bs/hal/odm_HWConfig.h b/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
> index ca3380328a72..21182a880da3 100644
> --- a/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
> +++ b/drivers/staging/rtl8723bs/hal/odm_HWConfig.h
> @@ -18,7 +18,7 @@ struct phy_rx_agc_info_t {
>  	#endif
>  };
>  
> -struct phy_status_rpt_8192cd_t {
> +struct rtl8723bs_phy_status_rpt {
>  	struct phy_rx_agc_info_t path_agc[2];
>  	u8 ch_corr[2];
>  	u8 cck_sig_qual_ofdm_pwdb_all;
> @@ -57,7 +57,8 @@ struct phy_status_rpt_8192cd_t {
>  };
>  
>  void odm_phy_status_query(struct dm_odm_t *dm_odm, struct odm_phy_info *phy_info,
> -			  u8 *phy_status, struct odm_packet_info *pkt_info);
> +			  struct rtl8723bs_phy_status_rpt *phy_status,
> +			  struct odm_packet_info *pkt_info);
>  
>  enum hal_status ODM_ConfigRFWithTxPwrTrackHeaderFile(struct dm_odm_t *pDM_Odm);
>  
> diff --git a/drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c b/drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c
> index 304fda3a3b5c..a62b845c69f9 100644
> --- a/drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c
> +++ b/drivers/staging/rtl8723bs/hal/rtl8723bs_recv.c
> @@ -73,7 +73,7 @@ static void update_recvframe_attrib(struct adapter *padapter,
>   *precvframe->u.hdr.rx_data should be ready!
>   */
>  static void update_recvframe_phyinfo(union recv_frame *precvframe,
> -				     struct phy_stat *pphy_status)
> +				     struct rtl8723bs_phy_status_rpt *pphy_status)
>  {
>  	struct adapter *padapter = precvframe->u.hdr.adapter;
>  	struct rx_pkt_attrib *pattrib = &precvframe->u.hdr.attrib;
> @@ -125,7 +125,7 @@ static void update_recvframe_phyinfo(union recv_frame *precvframe,
>  	pkt_info.data_rate = pattrib->data_rate;
>  
>  	odm_phy_status_query(&p_hal_data->odmpriv, p_phy_info,
> -			   (u8 *)pphy_status, &(pkt_info));
> +			   pphy_status, &(pkt_info));
>  	if (psta)
>  		psta->rssi = pattrib->phy_info.RecvSignalPower;
>  	precvframe->u.hdr.psta = NULL;
> @@ -317,7 +317,8 @@ static void rtl8723bs_recv_tasklet(struct tasklet_struct *t)
>  
>  				if (pattrib->pkt_rpt_type == NORMAL_RX) { /* Normal rx packet */
>  					if (pattrib->physt)
> -						update_recvframe_phyinfo(precvframe, (struct phy_stat *)ptr);
> +						update_recvframe_phyinfo(precvframe,
> +							(struct rtl8723bs_phy_status_rpt *)ptr);

Something is wrong here.  WHy is this "phy_stat" to start with and not
just struct rtl8723bs_phy_status_rpt?

This should probably be a patch series, first one renames the structure,
and then the rest unwind the cast mess so that you end up with just one
structure being used here and not two different ones with different
fields in them.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2026-10-01 16:06 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-10-01 15:51 [PATCH v3] staging: rtl8723bs: rename phy_status_rpt_8192cd_t to rtl8723bs_phy_status_rpt Timo Joannin
2026-10-01 16:06 ` Greg KH

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®