From: "Sven Peter" <sven@svenpeter.dev>
To: "Hector Martin" <marcan@marcan.st>,
"Joerg Roedel" <joro@8bytes.org>, "Will Deacon" <will@kernel.org>,
"Robin Murphy" <robin.murphy@arm.com>
Cc: "Alyssa Rosenzweig" <alyssa@rosenzweig.io>,
"Janne Grunau" <j@jannau.net>, "Rob Herring" <robh+dt@kernel.org>,
"Krzysztof Kozlowski" <krzysztof.kozlowski+dt@linaro.org>,
devicetree@vger.kernel.org, iommu@lists.linux.dev,
asahi@lists.linux.dev, linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 6/7] iommu: dart: Support different variants with different registers
Date: Thu, 05 Jan 2023 10:46:09 +0100 [thread overview]
Message-ID: <2267ef84-a167-4cd6-86fd-725e064eae62@app.fastmail.com> (raw)
In-Reply-To: <57a52e19-e121-6082-a4d8-f58ade353782@marcan.st>
Hi,
On Thu, Jan 5, 2023, at 06:16, Hector Martin wrote:
> On 2023/01/04 22:43, Sven Peter wrote:
>> On Wed, Jan 4, 2023, at 12:00, Hector Martin wrote:
>>> + u64 enable_streams;
>>> + u64 disable_streams;
>> I don't think disable_streams is used anywhere. I assume you just left it in
>> here to document it?
>
> Yeah, we don't use this field ever, so we might as well drop it. I'll
> leave the #define for T8110 in though, as documentation.
>
>>> + u64 ttbr;
>>> + u64 ttbr_valid;
>>> + u64 ttbr_addr_off;
>>
>> This name confused me a bit since off sounds like offset to me while
>> this is actually another shift. Can't really think of a better name
>> right now though. I'd at least a comment here to describe it.
>
> How about `ttbr_addr_field_shift`?
Sounds good to me!
Sven
next prev parent reply other threads:[~2023-01-05 9:46 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-04 11:00 [PATCH 0/7] iommu: dart: Apple t8110 DART support Hector Martin
2023-01-04 11:00 ` [PATCH 1/7] dt-bindings: iommu: dart: add t8110 compatible Hector Martin
2023-01-04 13:08 ` Sven Peter
2023-01-06 12:54 ` Krzysztof Kozlowski
2023-01-04 11:00 ` [PATCH 2/7] iommu: dart: Add suspend/resume support Hector Martin
2023-01-04 11:00 ` [PATCH 3/7] iommu: dart: Support >64 stream IDs Hector Martin
2023-01-04 13:37 ` Sven Peter
2023-01-05 4:43 ` Hector Martin
2023-01-05 9:47 ` Sven Peter
2023-01-04 11:00 ` [PATCH 4/7] iommu: dart: Support a variable number of TTBRs per stream Hector Martin
2023-01-04 13:18 ` Sven Peter
2023-01-05 4:51 ` Hector Martin
2023-01-04 11:00 ` [PATCH 5/7] iommu: dart: Fix DART_PARAMS1/2 bit define names Hector Martin
2023-01-04 13:23 ` Sven Peter
2023-01-04 11:00 ` [PATCH 6/7] iommu: dart: Support different variants with different registers Hector Martin
2023-01-04 13:43 ` Sven Peter
2023-01-05 5:16 ` Hector Martin
2023-01-05 9:46 ` Sven Peter [this message]
2023-01-04 11:00 ` [PATCH 7/7] iommu: dart: Add t8110 DART support Hector Martin
2023-01-04 13:50 ` Sven Peter
2023-01-05 5:19 ` Hector Martin
2023-01-05 9:45 ` Sven Peter
2023-01-13 10:50 [PATCH 0/7] iommu: dart: Apple " Hector Martin
2023-01-13 10:50 ` [PATCH 6/7] iommu: dart: Support different variants with different registers Hector Martin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2267ef84-a167-4cd6-86fd-725e064eae62@app.fastmail.com \
--to=sven@svenpeter.dev \
--cc=alyssa@rosenzweig.io \
--cc=asahi@lists.linux.dev \
--cc=devicetree@vger.kernel.org \
--cc=iommu@lists.linux.dev \
--cc=j@jannau.net \
--cc=joro@8bytes.org \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=marcan@marcan.st \
--cc=robh+dt@kernel.org \
--cc=robin.murphy@arm.com \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®