mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Tomeu Vizoso <tomeu.vizoso@collabora.com>
Cc: linux-pm@vger.kernel.org, Alan Stern <stern@rowland.harvard.edu>,
	martyn.welch@collabora.co.uk,
	Ulf Hansson <ulf.hansson@linaro.org>,
	David Airlie <airlied@linux.ie>,
	Tomas Winkler <tomas.winkler@intel.com>,
	linux-usb@vger.kernel.org, linux-acpi@vger.kernel.org,
	linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org,
	Russell King <linux@arm.linux.org.uk>,
	Len Brown <lenb@kernel.org>, Len Brown <len.brown@intel.com>,
	Kevin Hilman <khilman@kernel.org>,
	Tony Lindgren <tony@atomide.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-omap@vger.kernel.org, Pavel Machek <pavel@ucw.cz>,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v11 0/4] Allow USB devices to remain runtime-suspended when sleeping
Date: Mon, 02 Nov 2015 02:50:40 +0100	[thread overview]
Message-ID: <2496228.i2Z9PmMBtz@vostro.rjw.lan> (raw)
In-Reply-To: <1445956731-6304-1-git-send-email-tomeu.vizoso@collabora.com>

On Tuesday, October 27, 2015 03:38:47 PM Tomeu Vizoso wrote:
> Hi,
> 
> this is v11 of an attempt to make it easier for devices to remain in
> runtime PM when the system goes to sleep, mainly to reduce the time
> spent resuming devices.
> 
> For this, we interpret the absence of all PM callback implementations as
> it being safe to do direct_complete, so their ancestors aren't prevented
> from remaining runtime-suspended.
> 
> Additionally, the prepare() callback of USB devices will return 1 if
> runtime PM is enabled and the current wakeup settings are correct.
> 
> With these changes, a uvcvideo device (for example) stays in runtime
> suspend when the system goes to sleep and is left in that state when the
> system resumes, not delaying it unnecessarily.
> 
> Thanks,
> 
> Tomeu
> 
> Changes in v11:
> - Move calls to dev_pm_domain_set() out from &dev->power.lock as that
>   isn't needed for dev->pm_domain.
> 
> Changes in v10:
> - Remove superfluous call to pm_runtime_enabled() as suggested by Alan
> 
> Changes in v9:
> - Add docs noting the need for the device lock to be held before calling
>   device_is_bound()
> - Add docs noting the need for the device lock to be held before calling
>   dev_pm_domain_set()
> - Move to CONFIG_PM_SLEEP as suggested by Rafael and Ulf.
> - Rename from device_check_pm_callbacks to device_pm_check_callbacks to
>   follow with the naming convention of existing API.
> - Re-add calling to device_pm_check_callbacks from device registration
>   and when updating the PM domain of a device.
> 
> Changes in v8:
> - Add device_is_bound()
> - Add dev_pm_domain_set() and update code to use it
> - Move no_pm_callbacks field into CONFIG_PM_SLEEP
> - Call device_check_pm_callbacks only after a device is bound or unbound
> 
> Changes in v7:
> - Reduce indentation by adding a label in device_prepare()
> 
> Changes in v6:
> - Add stub for !CONFIG_PM.
> - Move implementation of device_check_pm_callbacks to power/main.c as it
>   doesn't belong to CONFIG_PM_SLEEP.
> - Take dev->power.lock before modifying flag.
> 
> Changes in v5:
> - Check for all dev_pm_ops instances associated to a device, updating a
>   no_pm_callbacks flag at the times when that could change.
> 
> Tomeu Vizoso (4):
>   device core: add device_is_bound()
>   PM / Domains: add setter for dev.pm_domain
>   PM / sleep: Go direct_complete if driver has no callbacks
>   USB / PM: Allow USB devices to remain runtime-suspended when sleeping
> 
>  arch/arm/mach-omap2/omap_device.c |  7 ++++---
>  drivers/acpi/acpi_lpss.c          |  5 +++--
>  drivers/acpi/device_pm.c          |  5 +++--
>  drivers/base/dd.c                 | 21 +++++++++++++++++++--
>  drivers/base/power/clock_ops.c    |  5 +++--
>  drivers/base/power/common.c       | 24 ++++++++++++++++++++++++
>  drivers/base/power/domain.c       |  8 ++++++--
>  drivers/base/power/main.c         | 35 +++++++++++++++++++++++++++++++++++
>  drivers/base/power/power.h        |  3 +++
>  drivers/gpu/vga/vga_switcheroo.c  | 10 +++++-----
>  drivers/misc/mei/pci-me.c         |  5 +++--
>  drivers/misc/mei/pci-txe.c        |  5 +++--
>  drivers/usb/core/port.c           |  6 ++++++
>  drivers/usb/core/usb.c            |  8 +++++++-
>  include/linux/device.h            |  2 ++
>  include/linux/pm.h                |  1 +
>  include/linux/pm_domain.h         |  3 +++
>  17 files changed, 130 insertions(+), 23 deletions(-)

I've queued up this series for the second half of the v4.4 merge window.

Thanks,
Rafael


  parent reply	other threads:[~2015-11-02  1:21 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-10-27 14:38 Tomeu Vizoso
2015-10-27 14:38 ` [PATCH v11 1/4] device core: add device_is_bound() Tomeu Vizoso
2015-10-27 14:38 ` [PATCH v11 2/4] PM / Domains: add setter for dev.pm_domain Tomeu Vizoso
2015-11-10  9:33   ` Daniel Kurtz
2016-01-07 14:47     ` Tomeu Vizoso
2016-01-08  0:20       ` Rafael J. Wysocki
2016-01-11 14:35       ` Fabio Estevam
2016-01-11 14:45         ` Rafael J. Wysocki
2016-01-11 14:52           ` Fabio Estevam
2016-01-11 21:09           ` Ulf Hansson
2015-10-27 14:38 ` [PATCH v11 3/4] PM / sleep: Go direct_complete if driver has no callbacks Tomeu Vizoso
2015-10-27 14:38 ` [PATCH v11 4/4] USB / PM: Allow USB devices to remain runtime-suspended when sleeping Tomeu Vizoso
2015-11-02  1:50 ` Rafael J. Wysocki [this message]
2016-01-05  2:27   ` Re: [PATCH v11 0/4] " Derek Basehore
2016-01-05 12:48     ` Rafael J. Wysocki
2016-01-05 23:38       ` dbasehore .

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2496228.i2Z9PmMBtz@vostro.rjw.lan \
    --to=rjw@rjwysocki.net \
    --cc=airlied@linux.ie \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=khilman@kernel.org \
    --cc=len.brown@intel.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=linux@arm.linux.org.uk \
    --cc=martyn.welch@collabora.co.uk \
    --cc=pavel@ucw.cz \
    --cc=stern@rowland.harvard.edu \
    --cc=tomas.winkler@intel.com \
    --cc=tomeu.vizoso@collabora.com \
    --cc=tony@atomide.com \
    --cc=ulf.hansson@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®