From: Gladyshev Ilya <foxido@foxido.dev>
To: Kari Argillander <kari.argillander@gmail.com>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>,
Len Brown <lenb@kernel.org>, Miguel Ojeda <ojeda@kernel.org>,
Boqun Feng <boqun.feng@gmail.com>, Gary Guo <gary@garyguo.net>,
Benno Lossin <lossin@kernel.org>,
Andreas Hindborg <a.hindborg@kernel.org>,
Alice Ryhl <aliceryhl@google.com>,
Trevor Gross <tmgross@umich.edu>,
Danilo Krummrich <dakr@kernel.org>,
Tamir Duberstein <tamird@gmail.com>, Armin Wolf <W_Armin@gmx.de>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org, rust-for-linux@vger.kernel.org,
linux-acpi@vger.kernel.org
Subject: Re: [PATCH 3/3] rust: add WMI abstractions
Date: Fri, 9 Jan 2026 14:31:08 +0300 [thread overview]
Message-ID: <284c09c9-c4ed-4838-a76b-dc90210b0be6@foxido.dev> (raw)
In-Reply-To: <CAC=eVgRHu9UzPyTMcWZFGAwo0+6wO+v-iuqmoKmznj_kSPVL=Q@mail.gmail.com>
On 1/9/26 14:15, Kari Argillander wrote:
> pe 9.1.2026 klo 13.01 Gladyshev Ilya (foxido@foxido.dev) kirjoitti:
>>
>> On 1/8/26 23:48, Kari Argillander wrote:
>>> On Wed, 7 Jan 2026 at 22:56, Gladyshev Ilya <foxido@foxido.dev> wrote:
>>> <snip>
>>>
>>>> +impl DeviceId {
>>>> + /// Constructs new DeviceId from GUID string.
>>>> + pub const fn new(guid: &[u8; bindings::UUID_STRING_LEN as usize]) -> Self {
>>>> + // SAFETY: FFI type is valid to be zero-initialized.
>>>> + let mut inner: bindings::wmi_device_id = unsafe { MaybeUninit::zeroed().assume_init() };
>>>> +
>>>> + build_assert!(inner.guid_string.len() == bindings::UUID_STRING_LEN as usize + 1);
>>>> +
>>>> + // SAFETY: It's safe to copy UUID_STRING_LEN, because we validated lengths.
>>>> + // Also we leave last byte zeroed, so guid_string is valid C string.
>>>> + unsafe {
>>>> + ::core::ptr::copy_nonoverlapping(
>>>> + guid.as_ptr(),
>>>> + &raw mut inner.guid_string[0],
>>>> + bindings::UUID_STRING_LEN as usize,
>>>> + );
>>>> + }
>>>
>>> Just use while here so no unsafe is needed at all. Then probably patch
>>> 1/3 is not needed.
>>
>> Overall this operation is still unsafe because we are constructing C
>> string in FFI object. So for me avoiding `unsafe` via less readable
>> (imo) loop will just mask unsafe operation without any real benefits.
>
> It is not unsafe if you also use pin_init::zeroed()
> let mut inner: bindings::wmi_device_id = pin_init::zeroed();
>
> let mut i = 0usize;
> while i < bindings::UUID_STRING_LEN as usize {
> inner.guid_string[i] = guid[i];
> i += 1;
> }
>
> you can then also remove 'core::mem::MaybeUninit'
I was talking more about "constructing C string is still 'unsafe'
because you shouldn't miss the \0 byte". IMO unsafe but primitive memcpy
is more readable and alerting than while loop, but that's not something
I will insist on
I'll play around more with `guid: &CStr` API, probably I missed
something simple)
prev parent reply other threads:[~2026-01-09 11:31 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-01-07 20:35 [PATCH 0/3] rust: " Gladyshev Ilya
2026-01-07 20:35 ` [PATCH 1/3] rust: enable const_intrinsic_copy feature Gladyshev Ilya
2026-01-07 20:35 ` [PATCH 2/3] rust: implement wrapper for acpi_object Gladyshev Ilya
2026-01-08 13:21 ` Gary Guo
2026-01-08 17:11 ` Gladyshev Ilya
2026-01-08 18:46 ` Miguel Ojeda
2026-01-09 10:57 ` Gladyshev Ilya
2026-01-11 17:57 ` Miguel Ojeda
2026-01-08 20:06 ` Gary Guo
2026-01-09 10:30 ` Gladyshev Ilya
2026-01-07 20:35 ` [PATCH 3/3] rust: add WMI abstractions Gladyshev Ilya
2026-01-08 19:48 ` Kari Argillander
2026-01-09 11:12 ` Gladyshev Ilya
2026-01-09 11:17 ` Kari Argillander
2026-01-08 20:48 ` Kari Argillander
2026-01-09 11:01 ` Gladyshev Ilya
2026-01-09 11:15 ` Kari Argillander
2026-01-09 11:31 ` Gladyshev Ilya [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=284c09c9-c4ed-4838-a76b-dc90210b0be6@foxido.dev \
--to=foxido@foxido.dev \
--cc=W_Armin@gmx.de \
--cc=a.hindborg@kernel.org \
--cc=aliceryhl@google.com \
--cc=boqun.feng@gmail.com \
--cc=dakr@kernel.org \
--cc=gary@garyguo.net \
--cc=kari.argillander@gmail.com \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=ojeda@kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
--cc=rafael@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=tamird@gmail.com \
--cc=tmgross@umich.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®