mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Gladyshev Ilya <foxido@foxido.dev>
To: Kari Argillander <kari.argillander@gmail.com>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>,
	Len Brown <lenb@kernel.org>, Miguel Ojeda <ojeda@kernel.org>,
	Boqun Feng <boqun.feng@gmail.com>, Gary Guo <gary@garyguo.net>,
	Benno Lossin <lossin@kernel.org>,
	Andreas Hindborg <a.hindborg@kernel.org>,
	Alice Ryhl <aliceryhl@google.com>,
	Trevor Gross <tmgross@umich.edu>,
	Danilo Krummrich <dakr@kernel.org>,
	Tamir Duberstein <tamird@gmail.com>, Armin Wolf <W_Armin@gmx.de>,
	platform-driver-x86@vger.kernel.org,
	linux-kernel@vger.kernel.org, rust-for-linux@vger.kernel.org,
	linux-acpi@vger.kernel.org, foxido@foxido.dev
Subject: Re: [PATCH 3/3] rust: add WMI abstractions
Date: Fri, 9 Jan 2026 14:12:10 +0300	[thread overview]
Message-ID: <622213c0-1793-4b1f-ba9a-aa99f73047f6@foxido.dev> (raw)
In-Reply-To: <CAKBF=psGUwgr7e+EM1d2OAv8H1A6zKfhQaSPS56vVcnc=Ez_KA@mail.gmail.com>

On 1/8/26 22:48, Kari Argillander wrote:
> On Wed, 7 Jan 2026 at 22:56, Gladyshev Ilya <foxido@foxido.dev> wrote:
[snip]
>> +    /// WMI device notify.
>> +    ///
>> +    /// Called when new WMI event received from bounded device.
>> +    fn notify(self: Pin<&Self>, _dev: &Device<device::Core>, _event: Option<&AcpiObject>) {
> 
> This should be device::Bound
> 
> Also probably _ marks are not needed. I think compiler does give
> unused build warnings.
> 
> I do not know reason but usually other drivers use this over self. And
> device first so this
> would be:
> 
>      fn notify(dev: &Device<device::Bound>, this: Pin<&Self>, event:
> Option<&AcpiObject>) {
> 
> Same also in unbind. But like I said I'm not completely sure about this.

I thought the reason for using this instead of self was because of the 
limited set of possible self types in previous versions of Rust...

IMO using Rust's self is more readable

>> +        build_error!(VTABLE_DEFAULT_ERROR);
>> +    }
>> +
>> +    /// WMI driver remove.
>> +    fn unbind(self: Pin<&Self>, _dev: &Device<device::Core>) {
>> +        build_error!(VTABLE_DEFAULT_ERROR);
>> +    }
> 
> unbind should not be mandatory so here just do
It's not mandatory, that why there is default implementation. See 
https://rust.docs.kernel.org/macros/attr.vtable.html


For other comments: Ack, thanks!

  reply	other threads:[~2026-01-09 11:12 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-01-07 20:35 [PATCH 0/3] rust: " Gladyshev Ilya
2026-01-07 20:35 ` [PATCH 1/3] rust: enable const_intrinsic_copy feature Gladyshev Ilya
2026-01-07 20:35 ` [PATCH 2/3] rust: implement wrapper for acpi_object Gladyshev Ilya
2026-01-08 13:21   ` Gary Guo
2026-01-08 17:11     ` Gladyshev Ilya
2026-01-08 18:46       ` Miguel Ojeda
2026-01-09 10:57         ` Gladyshev Ilya
2026-01-11 17:57           ` Miguel Ojeda
2026-01-08 20:06       ` Gary Guo
2026-01-09 10:30         ` Gladyshev Ilya
2026-01-07 20:35 ` [PATCH 3/3] rust: add WMI abstractions Gladyshev Ilya
2026-01-08 19:48   ` Kari Argillander
2026-01-09 11:12     ` Gladyshev Ilya [this message]
2026-01-09 11:17       ` Kari Argillander
2026-01-08 20:48   ` Kari Argillander
2026-01-09 11:01     ` Gladyshev Ilya
2026-01-09 11:15       ` Kari Argillander
2026-01-09 11:31         ` Gladyshev Ilya

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=622213c0-1793-4b1f-ba9a-aa99f73047f6@foxido.dev \
    --to=foxido@foxido.dev \
    --cc=W_Armin@gmx.de \
    --cc=a.hindborg@kernel.org \
    --cc=aliceryhl@google.com \
    --cc=boqun.feng@gmail.com \
    --cc=dakr@kernel.org \
    --cc=gary@garyguo.net \
    --cc=kari.argillander@gmail.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lossin@kernel.org \
    --cc=ojeda@kernel.org \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=rust-for-linux@vger.kernel.org \
    --cc=tamird@gmail.com \
    --cc=tmgross@umich.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®