From: Logan Gunthorpe <logang@deltatee.com>
To: Randy Dunlap <rdunlap@infradead.org>,
linux-kernel@vger.kernel.org, linux-pci@vger.kernel.org,
linux-ntb@googlegroups.com
Cc: Bjorn Helgaas <bhelgaas@google.com>,
Alex Williamson <alex.williamson@redhat.com>,
Doug Meyer <dmeyer@gigaio.com>
Subject: Re: [PATCH v2] PCI: Expand documentation for pci_add_dma_alias()
Date: Thu, 24 May 2018 11:51:03 -0600 [thread overview]
Message-ID: <2ab7b5f8-f068-026a-bc79-5c589dcdb07e@deltatee.com> (raw)
In-Reply-To: <b2481367-3acc-4d54-bae7-cc27fb38232e@infradead.org>
On 24/05/18 11:44 AM, Randy Dunlap wrote:
>> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
>> index dbfe7c4f3776..1c0c1ea23b90 100644
>> --- a/drivers/pci/pci.c
>> +++ b/drivers/pci/pci.c
>> @@ -5395,8 +5395,19 @@ int pci_set_vga_state(struct pci_dev *dev, bool decode,
>> * @dev: the PCI device for which alias is added
>> * @devfn: alias slot and function
>> *
>> - * This helper encodes 8-bit devfn as bit number in dma_alias_mask.
>> - * It should be called early, preferably as PCI fixup header quirk.
>> + * This helper encodes an 8-bit devfn as a bit number in dma_alias_mask
>> + * which is used to program permissible BDF source addresses for DMA
>
> It took me a few seconds to decode BDF. FWIW, I would prefer to see
> bus-devfn or bus-dev-fn or bus-dev-func or bus-dev-function.
Yes, there's a lot of overlapping terminology here. In circles I've
discussed this stuff, BDF is a common acronym. The kernel uses
Bus/Slot/Function in some places, but devfn is also common. In any case,
I like bus-devfn so I'll make these changes and send a v3 shortly.
Thanks,
Logan
prev parent reply other threads:[~2018-05-24 17:51 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-05-24 17:39 Logan Gunthorpe
2018-05-24 17:44 ` Randy Dunlap
2018-05-24 17:51 ` Logan Gunthorpe [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2ab7b5f8-f068-026a-bc79-5c589dcdb07e@deltatee.com \
--to=logang@deltatee.com \
--cc=alex.williamson@redhat.com \
--cc=bhelgaas@google.com \
--cc=dmeyer@gigaio.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-ntb@googlegroups.com \
--cc=linux-pci@vger.kernel.org \
--cc=rdunlap@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®