* [PATCH 1/2] drm/msm/adreno: Change chip_id format
2026-03-16 18:34 [PATCH 0/2] drm/msm/adreno: Update GPU name format Rob Clark
@ 2026-03-16 18:34 ` Rob Clark
2026-03-16 18:50 ` Dmitry Baryshkov
2026-03-16 18:34 ` [PATCH 2/2] drm/msm/a8xx: Update GPU name with slice_mask Rob Clark
2026-03-16 20:55 ` [PATCH 0/2] drm/msm/adreno: Update GPU name format Akhil P Oommen
2 siblings, 1 reply; 6+ messages in thread
From: Rob Clark @ 2026-03-16 18:34 UTC (permalink / raw)
To: dri-devel
Cc: freedreno, linux-arm-msm, Rob Clark, Sean Paul, Konrad Dybcio,
Akhil P Oommen, Dmitry Baryshkov, Abhinav Kumar, Jessica Zhang,
Marijn Suijten, David Airlie, Simona Vetter, open list
The "ipv4-style" %u.%u.%u.%u used to make sense when the chip_id was
simply encoding gen.major.minor.patch. But this hasn't been true for
at least a couple years.
Switch to %08x, which is still easy enough to read for older devices,
and much easier to read with the new scheme.
Signed-off-by: Rob Clark <robin.clark@oss.qualcomm.com>
---
drivers/gpu/drm/msm/adreno/adreno_gpu.h | 8 ++------
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/drivers/gpu/drm/msm/adreno/adreno_gpu.h b/drivers/gpu/drm/msm/adreno/adreno_gpu.h
index 1d0145f8b3ec..6cdfafcb0c57 100644
--- a/drivers/gpu/drm/msm/adreno/adreno_gpu.h
+++ b/drivers/gpu/drm/msm/adreno/adreno_gpu.h
@@ -67,12 +67,8 @@ enum adreno_family {
/* Helper for formating the chip_id in the way that userspace tools like
* crashdec expect.
*/
-#define ADRENO_CHIPID_FMT "u.%u.%u.%u"
-#define ADRENO_CHIPID_ARGS(_c) \
- (((_c) >> 24) & 0xff), \
- (((_c) >> 16) & 0xff), \
- (((_c) >> 8) & 0xff), \
- ((_c) & 0xff)
+#define ADRENO_CHIPID_FMT "08x"
+#define ADRENO_CHIPID_ARGS(_c) (_c)
struct adreno_gpu;
--
2.53.0
^ permalink raw reply [flat|nested] 6+ messages in thread* Re: [PATCH 1/2] drm/msm/adreno: Change chip_id format
2026-03-16 18:34 ` [PATCH 1/2] drm/msm/adreno: Change chip_id format Rob Clark
@ 2026-03-16 18:50 ` Dmitry Baryshkov
0 siblings, 0 replies; 6+ messages in thread
From: Dmitry Baryshkov @ 2026-03-16 18:50 UTC (permalink / raw)
To: Rob Clark
Cc: dri-devel, freedreno, linux-arm-msm, Sean Paul, Konrad Dybcio,
Akhil P Oommen, Dmitry Baryshkov, Abhinav Kumar, Jessica Zhang,
Marijn Suijten, David Airlie, Simona Vetter, open list
On Mon, Mar 16, 2026 at 11:34:33AM -0700, Rob Clark wrote:
> The "ipv4-style" %u.%u.%u.%u used to make sense when the chip_id was
> simply encoding gen.major.minor.patch. But this hasn't been true for
> at least a couple years.
>
> Switch to %08x, which is still easy enough to read for older devices,
> and much easier to read with the new scheme.
>
> Signed-off-by: Rob Clark <robin.clark@oss.qualcomm.com>
> ---
> drivers/gpu/drm/msm/adreno/adreno_gpu.h | 8 ++------
> 1 file changed, 2 insertions(+), 6 deletions(-)
>
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
--
With best wishes
Dmitry
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 2/2] drm/msm/a8xx: Update GPU name with slice_mask
2026-03-16 18:34 [PATCH 0/2] drm/msm/adreno: Update GPU name format Rob Clark
2026-03-16 18:34 ` [PATCH 1/2] drm/msm/adreno: Change chip_id format Rob Clark
@ 2026-03-16 18:34 ` Rob Clark
2026-03-16 18:51 ` Dmitry Baryshkov
2026-03-16 20:55 ` [PATCH 0/2] drm/msm/adreno: Update GPU name format Akhil P Oommen
2 siblings, 1 reply; 6+ messages in thread
From: Rob Clark @ 2026-03-16 18:34 UTC (permalink / raw)
To: dri-devel
Cc: freedreno, linux-arm-msm, Rob Clark, Sean Paul, Konrad Dybcio,
Akhil P Oommen, Dmitry Baryshkov, Abhinav Kumar, Jessica Zhang,
Marijn Suijten, David Airlie, Simona Vetter, open list
Once we've updated the chip_id after reading the slice_mask, also update
the GPU name so it matches.
Signed-off-by: Rob Clark <robin.clark@oss.qualcomm.com>
---
drivers/gpu/drm/msm/adreno/a8xx_gpu.c | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/drivers/gpu/drm/msm/adreno/a8xx_gpu.c b/drivers/gpu/drm/msm/adreno/a8xx_gpu.c
index 5a320f5bde41..fb1d92095db7 100644
--- a/drivers/gpu/drm/msm/adreno/a8xx_gpu.c
+++ b/drivers/gpu/drm/msm/adreno/a8xx_gpu.c
@@ -87,6 +87,7 @@ void a8xx_gpu_get_slice_info(struct msm_gpu *gpu)
struct adreno_gpu *adreno_gpu = to_adreno_gpu(gpu);
struct a6xx_gpu *a6xx_gpu = to_a6xx_gpu(adreno_gpu);
const struct a6xx_info *info = adreno_gpu->info->a6xx;
+ struct device *dev = &gpu->pdev->dev;
u32 slice_mask;
if (adreno_gpu->info->family < ADRENO_8XX_GEN1)
@@ -110,6 +111,15 @@ void a8xx_gpu_get_slice_info(struct msm_gpu *gpu)
/* Chip ID depends on the number of slices available. So update it */
adreno_gpu->chip_id |= FIELD_PREP(GENMASK(7, 4), hweight32(slice_mask));
+
+ /* Update the gpu-name to reflect the slice config: */
+ const char *name = devm_kasprintf(dev, GFP_KERNEL,
+ "%"ADRENO_CHIPID_FMT,
+ ADRENO_CHIPID_ARGS(adreno_gpu->chip_id));
+ if (name) {
+ devm_kfree(dev, adreno_gpu->base.name);
+ adreno_gpu->base.name = name;
+ }
}
static u32 a8xx_get_first_slice(struct a6xx_gpu *a6xx_gpu)
--
2.53.0
^ permalink raw reply [flat|nested] 6+ messages in thread* Re: [PATCH 2/2] drm/msm/a8xx: Update GPU name with slice_mask
2026-03-16 18:34 ` [PATCH 2/2] drm/msm/a8xx: Update GPU name with slice_mask Rob Clark
@ 2026-03-16 18:51 ` Dmitry Baryshkov
0 siblings, 0 replies; 6+ messages in thread
From: Dmitry Baryshkov @ 2026-03-16 18:51 UTC (permalink / raw)
To: Rob Clark
Cc: dri-devel, freedreno, linux-arm-msm, Sean Paul, Konrad Dybcio,
Akhil P Oommen, Dmitry Baryshkov, Abhinav Kumar, Jessica Zhang,
Marijn Suijten, David Airlie, Simona Vetter, open list
On Mon, Mar 16, 2026 at 11:34:34AM -0700, Rob Clark wrote:
> Once we've updated the chip_id after reading the slice_mask, also update
> the GPU name so it matches.
>
> Signed-off-by: Rob Clark <robin.clark@oss.qualcomm.com>
> ---
> drivers/gpu/drm/msm/adreno/a8xx_gpu.c | 10 ++++++++++
> 1 file changed, 10 insertions(+)
>
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
>
--
With best wishes
Dmitry
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 0/2] drm/msm/adreno: Update GPU name format
2026-03-16 18:34 [PATCH 0/2] drm/msm/adreno: Update GPU name format Rob Clark
2026-03-16 18:34 ` [PATCH 1/2] drm/msm/adreno: Change chip_id format Rob Clark
2026-03-16 18:34 ` [PATCH 2/2] drm/msm/a8xx: Update GPU name with slice_mask Rob Clark
@ 2026-03-16 20:55 ` Akhil P Oommen
2 siblings, 0 replies; 6+ messages in thread
From: Akhil P Oommen @ 2026-03-16 20:55 UTC (permalink / raw)
To: Rob Clark, dri-devel
Cc: freedreno, linux-arm-msm, Abhinav Kumar, David Airlie,
Dmitry Baryshkov, Jessica Zhang, Konrad Dybcio, open list,
Marijn Suijten, Sean Paul, Simona Vetter
On 3/17/2026 12:04 AM, Rob Clark wrote:
> The "ipv4 style" of formatting the chip_id is less useful after a740
> with the new chip_id format. Rather than doing dec->hex conversion in
> my head, just switch to using %08x, which is still easy enough to read
> for the old scheme.
>
> Also, for a8xx update the name after patching in the slice-count.
>
> This series only changes things for kernel dmesg.
>
> Rob Clark (2):
> drm/msm/adreno: Change chip_id format
> drm/msm/a8xx: Update GPU name with slice_mask
>
> drivers/gpu/drm/msm/adreno/a8xx_gpu.c | 10 ++++++++++
> drivers/gpu/drm/msm/adreno/adreno_gpu.h | 8 ++------
> 2 files changed, 12 insertions(+), 6 deletions(-)
>
Reviewed-by: Akhil P Oommen <akhilpo@oss.qualcomm.com>
-Akhil.
^ permalink raw reply [flat|nested] 6+ messages in thread