mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jie Luo <quic_luoj@quicinc.com>
To: "Russell King (Oracle)" <linux@armlinux.org.uk>
Cc: Yury Norov <yury.norov@gmail.com>,
	Rasmus Villemoes <linux@rasmusvillemoes.dk>,
	Julia Lawall <Julia.Lawall@inria.fr>,
	"Nicolas Palix" <nicolas.palix@imag.fr>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will@kernel.org>, Marc Zyngier <maz@kernel.org>,
	Oliver Upton <oliver.upton@linux.dev>,
	Joey Gouly <joey.gouly@arm.com>,
	Suzuki K Poulose <suzuki.poulose@arm.com>,
	Zenghui Yu <yuzenghui@huawei.com>, <linux-kernel@vger.kernel.org>,
	<cocci@inria.fr>, <linux-arm-kernel@lists.infradead.org>,
	<kvmarm@lists.linux.dev>, <andrew@lunn.ch>,
	<quic_kkumarcs@quicinc.com>, <quic_linchen@quicinc.com>,
	<quic_leiwei@quicinc.com>, <quic_suruchia@quicinc.com>,
	<quic_pavir@quicinc.com>
Subject: Re: [PATCH v3 3/6] arm64: tlb: Convert the opencoded field modify
Date: Wed, 23 Apr 2025 21:15:37 +0800	[thread overview]
Message-ID: <2b7ca78e-18f8-41bf-979d-8d502f6f8fe1@quicinc.com> (raw)
In-Reply-To: <aAFEOr_PnZRH2ocR@shell.armlinux.org.uk>



On 4/18/2025 2:11 AM, Russell King (Oracle) wrote:
> On Thu, Apr 17, 2025 at 06:47:10PM +0800, Luo Jie wrote:
>> Replaced below code with the wrapper FIELD_MODIFY(MASK, &reg, val)
>> - reg &= ~MASK;
>> - reg |= FIELD_PREP(MASK, val);
>> The semantic patch that makes this change is available
>> in scripts/coccinelle/misc/field_modify.cocci.
>>
>> More information about semantic patching is available at
>> https://coccinelle.gitlabpages.inria.fr/website
>>
>> Signed-off-by: Luo Jie <quic_luoj@quicinc.com>
>> ---
>>   arch/arm64/include/asm/tlbflush.h | 3 +--
>>   1 file changed, 1 insertion(+), 2 deletions(-)
>>
>> diff --git a/arch/arm64/include/asm/tlbflush.h b/arch/arm64/include/asm/tlbflush.h
>> index eba1a98657f1..0d250ef4161c 100644
>> --- a/arch/arm64/include/asm/tlbflush.h
>> +++ b/arch/arm64/include/asm/tlbflush.h
>> @@ -112,8 +112,7 @@ static inline unsigned long get_trans_granule(void)
>>   	    level >= 0 && level <= 3) {					\
>>   		u64 ttl = level & 3;					\
>>   		ttl |= get_trans_granule() << 2;			\
>> -		arg &= ~TLBI_TTL_MASK;					\
>> -		arg |= FIELD_PREP(TLBI_TTL_MASK, ttl);			\
>> +		FIELD_MODIFY(TLBI_TTL_MASK, &arg, ttl);			\
> 
> This could equally be:
> 		arg = u64_replace_bits(arg, ttl, TLBI_TTL_MASK);
> 
> which already exists, so doesn't require a new macro to be introduced.
> 
Looks like the new macro FIELD_MODIFY() is accepted by Yury, maybe we
can keep to use FIELD_MODIFY() with this change for better readability?

  reply	other threads:[~2025-04-23 13:16 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-17 10:47 [PATCH v3 0/6] Add FIELD_MODIFY() helper Luo Jie
2025-04-17 10:47 ` [PATCH v3 1/6] bitfield: " Luo Jie
2025-04-18 17:11   ` Yury Norov
2025-04-23 13:05     ` Jie Luo
2025-04-17 10:47 ` [PATCH v3 2/6] coccinelle: misc: Add field_modify script Luo Jie
2025-04-23 11:01   ` [cocci] " Markus Elfring
2025-04-23 13:04     ` Jie Luo
2025-04-23 16:35       ` Markus Elfring
2025-05-19 13:44         ` Luo Jie
2025-05-19 15:39           ` Julia Lawall
2025-04-17 10:47 ` [PATCH v3 3/6] arm64: tlb: Convert the opencoded field modify Luo Jie
2025-04-17 18:11   ` Russell King (Oracle)
2025-04-23 13:15     ` Jie Luo [this message]
2025-04-24 15:24       ` [cocci] " Keller, Jacob E
2025-04-23 16:54     ` Keller, Jacob E
2025-04-17 10:47 ` [PATCH v3 4/6] arm64: nvhe: " Luo Jie
2025-04-17 11:23   ` Marc Zyngier
2025-04-18 15:14     ` Yury Norov
2025-04-18 15:34       ` Marc Zyngier
2025-04-23 17:48       ` Russell King (Oracle)
2025-04-23 18:27         ` Yury Norov
2025-04-23 19:11           ` Russell King (Oracle)
2025-04-23 19:40             ` Yury Norov
2025-04-17 10:47 ` [PATCH v3 5/6] arm64: kvm: " Luo Jie
2025-04-17 10:47 ` [PATCH v3 6/6] arm64: mm: " Luo Jie
2025-04-17 11:10 ` [PATCH v3 0/6] Add FIELD_MODIFY() helper Marc Zyngier
2025-04-17 17:22   ` Andrew Lunn
2025-04-17 17:45     ` Marc Zyngier
2025-04-18 15:08       ` Yury Norov
2025-04-18 15:35         ` Marc Zyngier
2025-04-18 17:04           ` Yury Norov
2025-04-23 13:19             ` Jie Luo
2025-04-23 17:44         ` Russell King (Oracle)
2025-04-23 18:44           ` Yury Norov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2b7ca78e-18f8-41bf-979d-8d502f6f8fe1@quicinc.com \
    --to=quic_luoj@quicinc.com \
    --cc=Julia.Lawall@inria.fr \
    --cc=andrew@lunn.ch \
    --cc=catalin.marinas@arm.com \
    --cc=cocci@inria.fr \
    --cc=joey.gouly@arm.com \
    --cc=kvmarm@lists.linux.dev \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=linux@rasmusvillemoes.dk \
    --cc=maz@kernel.org \
    --cc=nicolas.palix@imag.fr \
    --cc=oliver.upton@linux.dev \
    --cc=quic_kkumarcs@quicinc.com \
    --cc=quic_leiwei@quicinc.com \
    --cc=quic_linchen@quicinc.com \
    --cc=quic_pavir@quicinc.com \
    --cc=quic_suruchia@quicinc.com \
    --cc=suzuki.poulose@arm.com \
    --cc=will@kernel.org \
    --cc=yury.norov@gmail.com \
    --cc=yuzenghui@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®