mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Paolo Abeni <pabeni@redhat.com>
To: Justin Iurman <justin.iurman@uliege.be>, netdev@vger.kernel.org
Cc: davem@davemloft.net, dsahern@kernel.org, edumazet@google.com,
	kuba@kernel.org, horms@kernel.org, linux-kernel@vger.kernel.org,
	David Lebrun <dlebrun@google.com>
Subject: Re: [PATCH net-next v4 3/4] net: ipv6: seg6_iptunnel: mitigate 2-realloc issue
Date: Tue, 19 Nov 2024 14:26:44 +0100	[thread overview]
Message-ID: <2f3ccc2c-6cb1-46c5-a462-9489e1c4471b@redhat.com> (raw)
In-Reply-To: <5dfc336e-d7e0-4219-af1e-6284facbdd94@uliege.be>

On 11/19/24 14:07, Justin Iurman wrote:
> On 11/19/24 11:47, Paolo Abeni wrote:
>> Also the code would probably be more readable with:
>>
>> 	struct dst_entry *old_dst = skb_dst(skb);
>>
>> and using 'old_dst' instead of 'skb_dst(skb)'
> 
> Ack. How about "dst" instead of "old_dst" (since it's the current 
> dst_entry), and "cache_dst" instead of "dst"?

Fine by me. I guess such option should also give a smaller diff, which
would be a nice plus.

Thanks!

Paolo


  reply	other threads:[~2024-11-19 13:26 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-11-18 13:14 [PATCH net-next v4 0/4] Mitigate the two-reallocations issue for iptunnels Justin Iurman
2024-11-18 13:14 ` [PATCH net-next v4 1/4] include: net: add static inline dst_dev_overhead() to dst.h Justin Iurman
2024-11-18 13:15 ` [PATCH net-next v4 2/4] net: ipv6: ioam6_iptunnel: mitigate 2-realloc issue Justin Iurman
2024-11-19 10:42   ` Paolo Abeni
2024-11-19 12:59     ` Justin Iurman
2024-11-18 13:15 ` [PATCH net-next v4 3/4] net: ipv6: seg6_iptunnel: " Justin Iurman
2024-11-19 10:47   ` Paolo Abeni
2024-11-19 13:07     ` Justin Iurman
2024-11-19 13:26       ` Paolo Abeni [this message]
2024-11-18 13:15 ` [PATCH net-next v4 4/4] net: ipv6: rpl_iptunnel: " Justin Iurman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2f3ccc2c-6cb1-46c5-a462-9489e1c4471b@redhat.com \
    --to=pabeni@redhat.com \
    --cc=davem@davemloft.net \
    --cc=dlebrun@google.com \
    --cc=dsahern@kernel.org \
    --cc=edumazet@google.com \
    --cc=horms@kernel.org \
    --cc=justin.iurman@uliege.be \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®