From: Taniya Das <taniya.das@oss.qualcomm.com>
To: Krzysztof Kozlowski <krzk@kernel.org>,
Abel Vesa <abel.vesa@linaro.org>,
Pankaj Patil <pankaj.patil@oss.qualcomm.com>
Cc: sboyd@kernel.org, mturquette@baylibre.com, andersson@kernel.org,
robh@kernel.org, krzk+dt@kernel.org, conor+dt@kernel.org,
quic_rjendra@quicinc.com, linux-clk@vger.kernel.org,
linux-arm-msm@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 7/7] clk: qcom: gcc: Add support for Global Clock Controller
Date: Fri, 18 Jul 2025 23:07:23 +0530 [thread overview]
Message-ID: <2f5b5e6e-5041-453e-b3f7-b10b40bc6f57@oss.qualcomm.com> (raw)
In-Reply-To: <40534488-24f6-4958-b032-d45a177dfd80@kernel.org>
On 7/17/2025 3:38 PM, Krzysztof Kozlowski wrote:
> On 17/07/2025 11:57, Abel Vesa wrote:
>> On 25-07-16 20:50:17, Pankaj Patil wrote:
>>> From: Taniya Das <taniya.das@oss.qualcomm.com>
>>>
>>> Add support for Global clock controller for Glymur platform.
>>>
>>> Signed-off-by: Taniya Das <taniya.das@oss.qualcomm.com>
>>> Signed-off-by: Pankaj Patil <pankaj.patil@oss.qualcomm.com>
>>> ---
>>> drivers/clk/qcom/Kconfig | 10 +
>>> drivers/clk/qcom/Makefile | 1 +
>>> drivers/clk/qcom/gcc-glymur.c | 8623 +++++++++++++++++++++++++++++++++
>>> 3 files changed, 8634 insertions(+)
>>> create mode 100644 drivers/clk/qcom/gcc-glymur.c
>>>
>>> diff --git a/drivers/clk/qcom/Kconfig b/drivers/clk/qcom/Kconfig
>>> index 051301007aa6..1d9e8c6aeaed 100644
>>> --- a/drivers/clk/qcom/Kconfig
>>> +++ b/drivers/clk/qcom/Kconfig
>>> @@ -645,6 +645,16 @@ config SAR_GPUCC_2130P
>>> Say Y if you want to support graphics controller devices and
>>> functionality such as 3D graphics.
>>>
>>> +config SC_GCC_GLYMUR
>>
>> Wait, are we going back to this now?
>>
>> X Elite had CLK_X1E80100_GCC, so maybe this should be CLK_GLYMUR_GCC
>> then.
>
>
> Yeah, the SC is meaningless here, unless you call it CLK_SC8480XP_GCC,
> so the authors need to decide on one naming. Not mixtures..
>
>
Glymur follows the "SC" naming convention, and historically we've
adhered to the format: "SC/SM/SDX/SA_<Clock Controller>_<Target Name or
Chipset>". This structure has helped maintain consistency and clarity
across platforms.
The case of X1E80100 appears to be an exception—likely influenced by its
unique naming convention at the time.
That said, I’d prefer to stay aligned with the established convention
used for earlier chipsets to preserve continuity. I’d appreciate hearing
your thoughts on this as well.
--
Thanks,
Taniya Das
next prev parent reply other threads:[~2025-07-18 17:37 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-16 15:20 [PATCH 0/7] Add support for Clock controllers for Glymur Pankaj Patil
2025-07-16 15:20 ` [PATCH 1/7] dt-bindings: clock: qcom-rpmhcc: Add support for Glymur SoCs Pankaj Patil
2025-07-16 15:20 ` [PATCH 2/7] dt-bindings: clock: qcom: Add bindings documentation for the Glymur TCSR Pankaj Patil
2025-07-21 9:19 ` Krzysztof Kozlowski
2025-07-23 9:21 ` Taniya Das
2025-07-16 15:20 ` [PATCH 3/7] clk: qcom: Add TCSR clock driver for Glymur Pankaj Patil
2025-07-16 15:35 ` Dmitry Baryshkov
2025-07-18 17:06 ` Taniya Das
2025-07-16 15:20 ` [PATCH 4/7] clk: qcom: rpmh: Add support for Glymur rpmh clocks Pankaj Patil
2025-07-16 15:20 ` [PATCH 5/7] clk: qcom: clk-alpha-pll: Add support for Taycan EKO_T PLL Pankaj Patil
2025-07-16 15:36 ` Dmitry Baryshkov
2025-07-16 15:20 ` [PATCH 6/7] dt-bindings: clock: qcom: document the Glymur Global Clock Controller Pankaj Patil
2025-07-16 15:20 ` [PATCH 7/7] clk: qcom: gcc: Add support for " Pankaj Patil
2025-07-16 16:28 ` Krzysztof Kozlowski
2025-07-18 17:26 ` Taniya Das
2025-07-20 3:46 ` Bjorn Andersson
2025-07-20 12:18 ` Krzysztof Kozlowski
2025-07-22 3:28 ` Bjorn Andersson
2025-08-13 16:19 ` Greg KH
2025-08-14 22:51 ` Bjorn Andersson
2025-07-17 9:57 ` Abel Vesa
2025-07-17 10:08 ` Krzysztof Kozlowski
2025-07-18 17:37 ` Taniya Das [this message]
2025-07-20 4:00 ` Bjorn Andersson
2025-07-21 17:13 ` Taniya Das
2025-07-22 3:21 ` Bjorn Andersson
2025-07-16 16:12 ` [PATCH 0/7] Add support for Clock controllers for Glymur Krzysztof Kozlowski
2025-07-21 6:38 ` Pankaj Patil
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2f5b5e6e-5041-453e-b3f7-b10b40bc6f57@oss.qualcomm.com \
--to=taniya.das@oss.qualcomm.com \
--cc=abel.vesa@linaro.org \
--cc=andersson@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=krzk+dt@kernel.org \
--cc=krzk@kernel.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-clk@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mturquette@baylibre.com \
--cc=pankaj.patil@oss.qualcomm.com \
--cc=quic_rjendra@quicinc.com \
--cc=robh@kernel.org \
--cc=sboyd@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®