From: Andrew Davis <afd@ti.com>
To: Mark Brown <broonie@kernel.org>,
Shree Ramamoorthy <s-ramamoorthy@ti.com>
Cc: <aaro.koskinen@iki.fi>, <andreas@kemnade.info>,
<khilman@baylibre.com>, <rogerq@kernel.org>, <tony@atomide.com>,
<lgirdwood@gmail.com>, <linux-omap@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <m-leonard@ti.com>,
<praneeth@ti.com>
Subject: Re: [PATCH v1 2/4] regulator: tps65219: Update driver name
Date: Tue, 17 Dec 2024 15:16:44 -0600 [thread overview]
Message-ID: <2fdf8fd0-b764-4720-8f7b-71b5d63d2541@ti.com> (raw)
In-Reply-To: <23dd1912-31cf-4e99-8fb0-0fbd68eee8e2@sirena.org.uk>
On 12/17/24 3:01 PM, Mark Brown wrote:
> On Tue, Dec 17, 2024 at 02:45:24PM -0600, Shree Ramamoorthy wrote:
>
>> Follow the same naming convention in tps6594-regulator.c with
>> tpsxxx-regulator instead of tpsxxx-pmic.
>
>> static struct platform_driver tps65219_regulator_driver = {
>> .driver = {
>> - .name = "tps65219-pmic",
>> + .name = "tps65219-regulator",
>> .probe_type = PROBE_PREFER_ASYNCHRONOUS,
>
> This isn't just a naming convention thing AFACIT, the MFD registers the
> new name so the driver wouldn't previously have loaded. How did this
> ever work?
It matches based on the platform device .id_table[0] which does have
"tps65219-regulator" listed, the driver .name itself is only used
as a last fallback when there is no .id_table.
[0] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/base/platform.c#n1352
Andrew
next prev parent reply other threads:[~2024-12-17 21:17 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-17 20:45 [PATCH v1 0/4] TPS65219 Regulator Driver Cleanup Series Shree Ramamoorthy
2024-12-17 20:45 ` [PATCH v1 1/4] regulator: tps65219: Use dev_err_probe() instead of dev_err() Shree Ramamoorthy
2024-12-17 20:45 ` [PATCH v1 2/4] regulator: tps65219: Update driver name Shree Ramamoorthy
2024-12-17 21:01 ` Mark Brown
2024-12-17 21:16 ` Andrew Davis [this message]
2024-12-17 21:19 ` Mark Brown
2024-12-17 20:45 ` [PATCH v1 3/4] regulator: tps65219: Remove MODULE_ALIAS Shree Ramamoorthy
2024-12-17 20:45 ` [PATCH v1 4/4] regulator: tps65219: Remove debugging helper function Shree Ramamoorthy
2024-12-18 14:20 ` [PATCH v1 0/4] TPS65219 Regulator Driver Cleanup Series Mark Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2fdf8fd0-b764-4720-8f7b-71b5d63d2541@ti.com \
--to=afd@ti.com \
--cc=aaro.koskinen@iki.fi \
--cc=andreas@kemnade.info \
--cc=broonie@kernel.org \
--cc=khilman@baylibre.com \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-omap@vger.kernel.org \
--cc=m-leonard@ti.com \
--cc=praneeth@ti.com \
--cc=rogerq@kernel.org \
--cc=s-ramamoorthy@ti.com \
--cc=tony@atomide.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®