mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v1 0/4] TPS65219 Regulator Driver Cleanup Series
@ 2024-12-17 20:45 Shree Ramamoorthy
  2024-12-17 20:45 ` [PATCH v1 1/4] regulator: tps65219: Use dev_err_probe() instead of dev_err() Shree Ramamoorthy
                   ` (4 more replies)
  0 siblings, 5 replies; 9+ messages in thread
From: Shree Ramamoorthy @ 2024-12-17 20:45 UTC (permalink / raw)
  To: aaro.koskinen, andreas, khilman, rogerq, tony, lgirdwood,
	broonie, linux-omap, linux-kernel
  Cc: m-leonard, praneeth

This series is in preparation to add 2 PMIC devices to the TPS65219 driver.

The changes involve using dev_err_probe() for instances that have a chance 
of returning -EPORBE_DEFER, remove redundant code, and follow other PMIC 
regulator driver naming conventions. The intention is to remove unnecessary
noise from the new PMIC device patches added to this driver.

Shree Ramamoorthy (4):
  regulator: tps65219: Use dev_err_probe() instead of dev_err()
  regulator: tps65219: Update driver name
  regulator: tps65219: Remove MODULE_ALIAS
  regulator: tps65219: Remove debugging helper function

 drivers/regulator/tps65219-regulator.c | 39 ++++----------------------
 1 file changed, 5 insertions(+), 34 deletions(-)

-- 
2.34.1


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2024-12-18 14:20 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-12-17 20:45 [PATCH v1 0/4] TPS65219 Regulator Driver Cleanup Series Shree Ramamoorthy
2024-12-17 20:45 ` [PATCH v1 1/4] regulator: tps65219: Use dev_err_probe() instead of dev_err() Shree Ramamoorthy
2024-12-17 20:45 ` [PATCH v1 2/4] regulator: tps65219: Update driver name Shree Ramamoorthy
2024-12-17 21:01   ` Mark Brown
2024-12-17 21:16     ` Andrew Davis
2024-12-17 21:19       ` Mark Brown
2024-12-17 20:45 ` [PATCH v1 3/4] regulator: tps65219: Remove MODULE_ALIAS Shree Ramamoorthy
2024-12-17 20:45 ` [PATCH v1 4/4] regulator: tps65219: Remove debugging helper function Shree Ramamoorthy
2024-12-18 14:20 ` [PATCH v1 0/4] TPS65219 Regulator Driver Cleanup Series Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®