mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Bryan O'Donoghue <bryan.odonoghue@linaro.org>
To: Vladimir Zapolskiy <vladimir.zapolskiy@linaro.org>,
	Vikram Sharma <quic_vikramsa@quicinc.com>,
	rfoss@kernel.org, todor.too@gmail.com
Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org,
	kernel@quicinc.com
Subject: Re: [PATCH v3 0/2] media: qcom: camss: Re-structure camss_link_entities
Date: Mon, 25 Nov 2024 12:14:55 +0000	[thread overview]
Message-ID: <310ec20b-3fbd-4c0f-8705-cff96bb6e4d3@linaro.org> (raw)
In-Reply-To: <b27fe267-c722-4133-ad7c-bdb1ff573ee7@linaro.org>

On 25/11/2024 11:57, Vladimir Zapolskiy wrote:
> Hi Vikram,
> 
> On 11/25/24 12:34, Vikram Sharma wrote:
>> Refactor the camss_link_entities function by breaking it down into
>> three distinct functions. Each function will handle the linking of
>> a specific entity separately, enhancing readability.
>>
>> Changes in V3:
>> - Broke down the change in 2 patches. first one to functionally
>> decompose link error message. second to restrcture the link
>> function.
>> - Removed the declarion of camss_link_error from header file.
>> - Link to v2: https://lore.kernel.org/linux-arm- 
>> msm/20241112133846.2397017-1-quic_vikramsa@quicinc.com/
> 
> as I said last time I don't see the value of these changes.
> 
> Since the changes are non-functional, then hopefully there should be
> no issues with them, however I really miss the point of adding 65
> lines of code for a questionable reason and at the price of increased
> complexity.
> 
> Is there a good reason not to drop the series?
I think there is value in both functional decomposition and tidying up 
code - for example removing circuitous if/elses in favour of more 
discreet and easy to read functions, so I'm inclined to accept this series.

---
bod

      reply	other threads:[~2024-11-25 12:14 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-11-25 10:34 Vikram Sharma
2024-11-25 10:34 ` [PATCH v3 1/2] media: qcom: camss: reducing the repitious error message string Vikram Sharma
2024-11-25 12:10   ` Bryan O'Donoghue
2024-11-25 10:34 ` [PATCH v3 2/2] media: qcom: camss: Restructure camss_link_entities Vikram Sharma
2024-11-25 11:57 ` [PATCH v3 0/2] media: qcom: camss: Re-structure camss_link_entities Vladimir Zapolskiy
2024-11-25 12:14   ` Bryan O'Donoghue [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=310ec20b-3fbd-4c0f-8705-cff96bb6e4d3@linaro.org \
    --to=bryan.odonoghue@linaro.org \
    --cc=kernel@quicinc.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=quic_vikramsa@quicinc.com \
    --cc=rfoss@kernel.org \
    --cc=todor.too@gmail.com \
    --cc=vladimir.zapolskiy@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®