From: Vladimir Zapolskiy <vladimir.zapolskiy@linaro.org>
To: Vikram Sharma <quic_vikramsa@quicinc.com>,
rfoss@kernel.org, todor.too@gmail.com,
bryan.odonoghue@linaro.org
Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org,
kernel@quicinc.com
Subject: Re: [PATCH v3 0/2] media: qcom: camss: Re-structure camss_link_entities
Date: Mon, 25 Nov 2024 13:57:09 +0200 [thread overview]
Message-ID: <b27fe267-c722-4133-ad7c-bdb1ff573ee7@linaro.org> (raw)
In-Reply-To: <20241125103457.1970608-1-quic_vikramsa@quicinc.com>
Hi Vikram,
On 11/25/24 12:34, Vikram Sharma wrote:
> Refactor the camss_link_entities function by breaking it down into
> three distinct functions. Each function will handle the linking of
> a specific entity separately, enhancing readability.
>
> Changes in V3:
> - Broke down the change in 2 patches. first one to functionally
> decompose link error message. second to restrcture the link
> function.
> - Removed the declarion of camss_link_error from header file.
> - Link to v2: https://lore.kernel.org/linux-arm-msm/20241112133846.2397017-1-quic_vikramsa@quicinc.com/
as I said last time I don't see the value of these changes.
Since the changes are non-functional, then hopefully there should be
no issues with them, however I really miss the point of adding 65
lines of code for a questionable reason and at the price of increased
complexity.
Is there a good reason not to drop the series?
> Changes in V2:
> - Declared variables in reverse christmas tree order.
> - Functionally decomposed link error message.
> - Link to v1: https://lore.kernel.org/linux-arm-msm/20241111173845.1773553-1-quic_vikramsa@quicinc.com/
>
> To: Robert Foss <rfoss@kernel.org>
> To: Todor Tomov <todor.too@gmail.com>
> To: Bryan O'Donoghue <bryan.odonoghue@linaro.org>
> Cc: linux-media@vger.kernel.org
> Cc: linux-kernel@vger.kernel.org
>
> Signed-off-by: Vikram Sharma <quic_vikramsa@quicinc.com>
>
> Vikram Sharma (2):
> media: qcom: camss: reducing the repitious error message string
> media: qcom: camss: Restructure camss_link_entities
>
> drivers/media/platform/qcom/camss/camss.c | 195 ++++++++++++++--------
> 1 file changed, 130 insertions(+), 65 deletions(-)
>
--
Best wishes,
Vladimir
next prev parent reply other threads:[~2024-11-25 11:57 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-11-25 10:34 Vikram Sharma
2024-11-25 10:34 ` [PATCH v3 1/2] media: qcom: camss: reducing the repitious error message string Vikram Sharma
2024-11-25 12:10 ` Bryan O'Donoghue
2024-11-25 10:34 ` [PATCH v3 2/2] media: qcom: camss: Restructure camss_link_entities Vikram Sharma
2024-11-25 11:57 ` Vladimir Zapolskiy [this message]
2024-11-25 12:14 ` [PATCH v3 0/2] media: qcom: camss: Re-structure camss_link_entities Bryan O'Donoghue
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b27fe267-c722-4133-ad7c-bdb1ff573ee7@linaro.org \
--to=vladimir.zapolskiy@linaro.org \
--cc=bryan.odonoghue@linaro.org \
--cc=kernel@quicinc.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=quic_vikramsa@quicinc.com \
--cc=rfoss@kernel.org \
--cc=todor.too@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®