From: Arnd Bergmann <arnd@arndb.de>
To: Sinan Kaya <okaya@codeaurora.org>
Cc: Robin Murphy <robin.murphy@arm.com>,
linux-arm-kernel@lists.infradead.org, timur@codeaurora.org,
cov@codeaurora.org, nwatters@codeaurora.org,
Catalin Marinas <catalin.marinas@arm.com>,
Will Deacon <will.deacon@arm.com>,
Andrew Morton <akpm@linux-foundation.org>,
Max Filippov <jcmvbkbc@gmail.com>, Joe Perches <joe@perches.com>,
"Suthikulpanit, Suravee" <Suravee.Suthikulpanit@amd.com>,
Jisheng Zhang <jszhang@marvell.com>,
Dean Nelson <dnelson@redhat.com>,
"Suzuki K. Poulose" <suzuki.poulose@arm.com>,
Marek Szyprowski <m.szyprowski@samsung.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices
Date: Thu, 17 Mar 2016 17:14:34 +0100 [thread overview]
Message-ID: <3165610.Gdh8F6ejPI@wuerfel> (raw)
In-Reply-To: <56EAD63E.2010103@codeaurora.org>
On Thursday 17 March 2016 12:07:26 Sinan Kaya wrote:
> On 3/17/2016 11:57 AM, Robin Murphy wrote:
>
> Let me know which direction I should go.
>
> 1. Fix phys_to_dma and keep dma_to_phys as in the patch.
> 2. Remove both of the API from header file, move it to where it is needed. Rename them as swio_phys_to_dma etc.
Use 2.
It has been a long way to remove all virt_to_bus/bus_to_virt users
from the common architectures, we are not putting them back under
a different name.
Drivers already know the physical address because that is what they
put into dma_map_*() in the first place.
Arnd
next prev parent reply other threads:[~2016-03-17 16:15 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-03-17 15:50 Sinan Kaya
2016-03-17 15:57 ` Robin Murphy
2016-03-17 16:07 ` Sinan Kaya
2016-03-17 16:14 ` Arnd Bergmann [this message]
2016-03-17 16:36 ` Sinan Kaya
2016-03-17 17:01 ` Arnd Bergmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3165610.Gdh8F6ejPI@wuerfel \
--to=arnd@arndb.de \
--cc=Suravee.Suthikulpanit@amd.com \
--cc=akpm@linux-foundation.org \
--cc=catalin.marinas@arm.com \
--cc=cov@codeaurora.org \
--cc=dnelson@redhat.com \
--cc=jcmvbkbc@gmail.com \
--cc=joe@perches.com \
--cc=jszhang@marvell.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=m.szyprowski@samsung.com \
--cc=nwatters@codeaurora.org \
--cc=okaya@codeaurora.org \
--cc=robin.murphy@arm.com \
--cc=suzuki.poulose@arm.com \
--cc=timur@codeaurora.org \
--cc=will.deacon@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®