From: Jiri Slaby <jslaby@suse.cz>
To: Alan Stern <stern@rowland.harvard.edu>, Baole Ni <baolex.ni@intel.com>
Cc: rjw@rjwysocki.net, viresh.kumar@linaro.org,
jarkko.sakkinen@linux.intel.com, jgunthorpe@obsidianresearch.com,
hpa@zytor.com, x86@kernel.org, linux-pm@vger.kernel.org,
linux-kernel@vger.kernel.org, chuansheng.liu@intel.com,
peter@korsgaard.com, lee.jones@linaro.org
Subject: Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro
Date: Tue, 2 Aug 2016 19:05:48 +0200 [thread overview]
Message-ID: <335df7ab-6663-b14a-de33-7a485489c20e@suse.cz> (raw)
In-Reply-To: <Pine.LNX.4.44L0.1608020955530.1940-100000@iolanthe.rowland.org>
On 08/02/2016, 03:57 PM, Alan Stern wrote:
>> --- a/drivers/cpufreq/powernow-k7.c
>> +++ b/drivers/cpufreq/powernow-k7.c
>> @@ -683,7 +683,7 @@ static void __exit powernow_exit(void)
>> cpufreq_unregister_driver(&powernow_driver);
>> }
>>
>> -module_param(acpi_force, int, 0444);
>> +module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH);
>
> This is an excellent example. To me, 0444 is _much_ more readable and
> understandable than S_IRUSR | S_IRGRP | S_IROTH.
If anything, that should be S_IRUGO. However, I personally prefer
numbers over macros too.
thanks,
--
js
suse labs
prev parent reply other threads:[~2016-08-02 17:06 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-02 10:42 Baole Ni
2016-08-02 13:57 ` Alan Stern
2016-08-02 17:05 ` Jiri Slaby [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=335df7ab-6663-b14a-de33-7a485489c20e@suse.cz \
--to=jslaby@suse.cz \
--cc=baolex.ni@intel.com \
--cc=chuansheng.liu@intel.com \
--cc=hpa@zytor.com \
--cc=jarkko.sakkinen@linux.intel.com \
--cc=jgunthorpe@obsidianresearch.com \
--cc=lee.jones@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=peter@korsgaard.com \
--cc=rjw@rjwysocki.net \
--cc=stern@rowland.harvard.edu \
--cc=viresh.kumar@linaro.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®