From: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
To: Boris Brezillon <boris.brezillon@collabora.com>
Cc: robh@kernel.org, steven.price@arm.com,
maarten.lankhorst@linux.intel.com, mripard@kernel.org,
tzimmermann@suse.de, airlied@gmail.com, daniel@ffwll.ch,
dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
kernel@collabora.com, m.szyprowski@samsung.com,
krzysztof.kozlowski@linaro.org
Subject: Re: [PATCH v2 3/3] drm/panfrost: Synchronize and disable interrupts before powering off
Date: Tue, 28 Nov 2023 16:42:25 +0100 [thread overview]
Message-ID: <34b7ae7d-c4d3-4d94-a1e9-62d3d4fc6b9a@collabora.com> (raw)
In-Reply-To: <20231128163808.094a8afa@collabora.com>
Il 28/11/23 16:38, Boris Brezillon ha scritto:
> On Tue, 28 Nov 2023 16:10:43 +0100
> AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
> wrote:
>
>> Il 28/11/23 15:06, Boris Brezillon ha scritto:
>>> On Tue, 28 Nov 2023 13:45:10 +0100
>>> AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
>>> wrote:
>>>
>>>> To make sure that we don't unintentionally perform any unclocked and/or
>>>> unpowered R/W operation on GPU registers, before turning off clocks and
>>>> regulators we must make sure that no GPU, JOB or MMU ISR execution is
>>>> pending: doing that required to add a mechanism to synchronize the
>>>> interrupts on suspend.
>>>>
>>>> Add functions panfrost_{gpu,job,mmu}_suspend_irq() which will perform
>>>> interrupts masking and ISR execution synchronization, and then call
>>>> those in the panfrost_device_runtime_suspend() handler in the exact
>>>> sequence of job (may require mmu!) -> mmu -> gpu.
>>>>
>>>> As a side note, JOB and MMU suspend_irq functions needed some special
>>>> treatment: as their interrupt handlers will unmask interrupts, it was
>>>> necessary to add a bitmap for "is_suspending" which is used to address
>>>> the possible corner case of unintentional IRQ unmasking because of ISR
>>>> execution after a call to synchronize_irq().
>>>>
>>>> Of course, unmasking the interrupts is being done as part of the reset
>>>> happening during runtime_resume(): since we're anyway resuming all of
>>>> GPU, JOB, MMU, the only additional action is to zero out the newly
>>>> introduced `is_suspending` bitmap directly in the resume handler, as
>>>> to avoid adding panfrost_{job,mmu}_resume_irq() function just for
>>>> clearing own bits, especially because it currently makes way more sense
>>>> to just zero out the bitmap.
>>>>
>>>> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
>>>> ---
>>>> drivers/gpu/drm/panfrost/panfrost_device.c | 4 ++++
>>>> drivers/gpu/drm/panfrost/panfrost_device.h | 7 +++++++
>>>> drivers/gpu/drm/panfrost/panfrost_gpu.c | 7 +++++++
>>>> drivers/gpu/drm/panfrost/panfrost_gpu.h | 1 +
>>>> drivers/gpu/drm/panfrost/panfrost_job.c | 18 +++++++++++++++---
>>>> drivers/gpu/drm/panfrost/panfrost_job.h | 1 +
>>>> drivers/gpu/drm/panfrost/panfrost_mmu.c | 17 ++++++++++++++---
>>>> drivers/gpu/drm/panfrost/panfrost_mmu.h | 1 +
>>>> 8 files changed, 50 insertions(+), 6 deletions(-)
>>>>
>>>> diff --git a/drivers/gpu/drm/panfrost/panfrost_device.c b/drivers/gpu/drm/panfrost/panfrost_device.c
>>>> index c90ad5ee34e7..ed34aa55a7da 100644
>>>> --- a/drivers/gpu/drm/panfrost/panfrost_device.c
>>>> +++ b/drivers/gpu/drm/panfrost/panfrost_device.c
>>>> @@ -407,6 +407,7 @@ static int panfrost_device_runtime_resume(struct device *dev)
>>>> {
>>>> struct panfrost_device *pfdev = dev_get_drvdata(dev);
>>>>
>>>> + bitmap_zero(pfdev->is_suspending, PANFROST_COMP_BIT_MAX);
>>>
>>> I would let each sub-block clear their bit in the reset path, since
>>> that's where the IRQs are effectively unmasked.
>>>
>>
>>
>> Honestly I wouldn't like seeing that: the reason is that this is something that
>> is done *for* suspend/resume and only for that, while reset may be called out of
>> the suspend/resume handlers.
>>
>> I find clearing the suspend bits in the HW reset path a bit confusing, especially
>> when it is possible to avoid doing it there...
>
> Well, I do think it's preferable to keep the irq_is_no_longer_suspended
> state update where the interrupt is effectively unmasked. Note that
> when you do a reset, the IRQ is silently suspended just after the
> reset happens, because the xxx_INT_MASKs are restored to their default
> value, so I do consider that clearing this bit in the reset path makes
> sense.
>
Okay then, I can move it, no problem.
>>
>>>> panfrost_device_reset(pfdev);
>>>> panfrost_devfreq_resume(pfdev);
>>>>
>>>> @@ -421,6 +422,9 @@ static int panfrost_device_runtime_suspend(struct device *dev)
>>>> return -EBUSY;
>>>>
>>>> panfrost_devfreq_suspend(pfdev);
>>>> + panfrost_job_suspend_irq(pfdev);
>>>> + panfrost_mmu_suspend_irq(pfdev);
>>>> + panfrost_gpu_suspend_irq(pfdev);
>>>> panfrost_gpu_power_off(pfdev);
>>>>
>>>> return 0;
>>>> diff --git a/drivers/gpu/drm/panfrost/panfrost_device.h b/drivers/gpu/drm/panfrost/panfrost_device.h
>>>> index 54a8aad54259..29f89f2d3679 100644
>>>> --- a/drivers/gpu/drm/panfrost/panfrost_device.h
>>>> +++ b/drivers/gpu/drm/panfrost/panfrost_device.h
>>>> @@ -25,6 +25,12 @@ struct panfrost_perfcnt;
>>>> #define NUM_JOB_SLOTS 3
>>>> #define MAX_PM_DOMAINS 5
>>>>
>>>> +enum panfrost_drv_comp_bits {
>>>> + PANFROST_COMP_BIT_MMU,
>>>> + PANFROST_COMP_BIT_JOB,
>>>> + PANFROST_COMP_BIT_MAX
>>>> +};
>>>> +
>>>> /**
>>>> * enum panfrost_gpu_pm - Supported kernel power management features
>>>> * @GPU_PM_CLK_DIS: Allow disabling clocks during system suspend
>>>> @@ -109,6 +115,7 @@ struct panfrost_device {
>>>>
>>>> struct panfrost_features features;
>>>> const struct panfrost_compatible *comp;
>>>> + DECLARE_BITMAP(is_suspending, PANFROST_COMP_BIT_MAX);
>>>
>>> nit: Maybe s/is_suspending/suspended_irqs/, given the state remains
>>> until the device is resumed.
>>
>> If we keep the `is_suspending` name, we can use this one more generically in
>> case we ever need to, what do you think?
>
> I'm lost. Why would we want to reserve a name for something we don't
> know about? My comment was mostly relating to the fact this bitmap
> doesn't reflect the is_suspending state, but rather is_suspended,
> because it remains set until the device is resumed. And we actually want
> it to reflect the is_suspended state, so we can catch interrupts that
> are not for us without reading regs in the hard irq handler, when the
> GPU is suspended.
`is_suspended` (fun story: that's the first name I gave it) looks good to me,
the doubt I raised was about calling it `suspended_irqs` instead, as I would
prefer to keep names "more generic", but that's just personal preference at
this point anyway.
Cheers,
Angelo
next prev parent reply other threads:[~2023-11-28 15:42 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <CGME20231128124521eucas1p203694ed4721b9ffcde6f7f1d1933d56a@eucas1p2.samsung.com>
2023-11-28 12:45 ` [PATCH v2 0/3] drm/panfrost: Fix poweroff and sync IRQs for suspend AngeloGioacchino Del Regno
2023-11-28 12:45 ` [PATCH v2 1/3] drm/panfrost: Ignore core_mask for poweroff and disable PWRTRANS irq AngeloGioacchino Del Regno
2023-11-28 13:27 ` Boris Brezillon
2023-11-28 12:45 ` [PATCH v2 2/3] drm/panfrost: Add gpu_irq, mmu_irq to struct panfrost_device AngeloGioacchino Del Regno
2023-11-28 13:31 ` Boris Brezillon
2023-11-28 12:45 ` [PATCH v2 3/3] drm/panfrost: Synchronize and disable interrupts before powering off AngeloGioacchino Del Regno
2023-11-28 13:57 ` Boris Brezillon
2023-11-28 15:10 ` AngeloGioacchino Del Regno
2023-11-28 15:53 ` Boris Brezillon
2023-11-28 16:10 ` AngeloGioacchino Del Regno
2023-11-28 16:41 ` Boris Brezillon
2023-11-28 14:06 ` Boris Brezillon
2023-11-28 15:10 ` AngeloGioacchino Del Regno
2023-11-28 15:38 ` Boris Brezillon
2023-11-28 15:42 ` AngeloGioacchino Del Regno [this message]
2023-11-28 15:58 ` Boris Brezillon
2023-11-29 17:31 ` [PATCH v2 0/3] drm/panfrost: Fix poweroff and sync IRQs for suspend Marek Szyprowski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=34b7ae7d-c4d3-4d94-a1e9-62d3d4fc6b9a@collabora.com \
--to=angelogioacchino.delregno@collabora.com \
--cc=airlied@gmail.com \
--cc=boris.brezillon@collabora.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=kernel@collabora.com \
--cc=krzysztof.kozlowski@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=m.szyprowski@samsung.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=robh@kernel.org \
--cc=steven.price@arm.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®