From: Jose Abreu <Jose.Abreu@synopsys.com>
To: Takashi Iwai <tiwai@suse.de>, Mark Brown <broonie@kernel.org>
Cc: Jose Abreu <Jose.Abreu@synopsys.com>,
Lubomir Rintel <lkundrak@v3.sk>, <alsa-devel@alsa-project.org>,
<linux-kernel@vger.kernel.org>, Arnd Bergmann <arnd@arndb.de>
Subject: Re: [alsa-devel] [PATCH] ASoC: dwc: disallow building designware_pcm as a module
Date: Fri, 21 Apr 2017 11:34:00 +0100 [thread overview]
Message-ID: <376c5933-9321-5399-74c7-6fd4943fab3d@synopsys.com> (raw)
In-Reply-To: <s5h37d2su8h.wl-tiwai@suse.de>
Hi,
On 20-04-2017 21:24, Takashi Iwai wrote:
> So, I think Lubomir's change is right. But the patch subject and
> description should be rephrased.
>
> One thing I don't like is the rename of the file. But in this
> particular case, it's unavoidable unless we rename the module name.
>
Maybe rename to "dwc-i2s.c" and "dwc-pcm.c" (as the folder is
called "dwc") and let the module still be called "designware-i2s"?
> BTW, we should drop the superfluous EXPORT_SYMBOL*(), too.
>
>
>
Lubomir, could you please remove the EXPORT_SYMBOL, change the
commit message and resend?
Best regards,
Jose Miguel Abreu
next prev parent reply other threads:[~2017-04-21 10:34 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-04-18 10:59 Lubomir Rintel
2017-04-18 15:18 ` Mark Brown
2017-04-18 16:13 ` Lubomir Rintel
2017-04-18 17:15 ` Mark Brown
2017-04-19 16:12 ` Jose Abreu
2017-04-19 16:14 ` Lubomir Rintel
2017-04-19 16:48 ` Jose Abreu
2017-04-20 19:46 ` Mark Brown
2017-04-20 20:24 ` [alsa-devel] " Takashi Iwai
2017-04-20 20:25 ` Mark Brown
2017-04-21 10:34 ` Jose Abreu [this message]
2017-04-21 10:39 ` Takashi Iwai
2017-04-21 10:49 ` Mark Brown
2017-04-27 18:49 ` Jose Abreu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=376c5933-9321-5399-74c7-6fd4943fab3d@synopsys.com \
--to=jose.abreu@synopsys.com \
--cc=alsa-devel@alsa-project.org \
--cc=arnd@arndb.de \
--cc=broonie@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lkundrak@v3.sk \
--cc=tiwai@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®