mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v3 0/9] Add callback for cooling list update to speed-up IPA
@ 2023-12-20 23:17 Lukasz Luba
  2023-12-20 23:17 ` [PATCH v3 1/9] thermal: core: Add governor callback for thermal zone change Lukasz Luba
                   ` (9 more replies)
  0 siblings, 10 replies; 12+ messages in thread
From: Lukasz Luba @ 2023-12-20 23:17 UTC (permalink / raw)
  To: linux-kernel, rafael; +Cc: linux-pm, daniel.lezcano, rui.zhang, lukasz.luba

Hi all,

The patch set adds a new callback for thermal governors and implementation for
Intelligent Power Allocator.

The goal is to move some heavy operations like the memory allocations and heavy
computations (multiplications) out of throttle() callback hot path.

The new callback is generic enough to handle other important update events.
It re-uses existing thermal_notify_event definitions.

In addition there are some small clean-ups for IPA code.

The patch set is based on current pm/bleeding-edge branch (20 Dec).

changes:
v3:
- changed helper name to thermal_governor_update_tz() with also
  "reason" argument (Rafael)
- added thermal_governor_update_tz() to thermal_core.h for use from sysfs
  functions 
- changed names of the events (THERMAL_TZ_BIND_CDEV) (Rafael)
- patch 2/9 changed header and comment for function (Rafael)
- patch 3/9: used unsigned types for num_actors, buffer_size (Rafael)
- changed trace functions and added new patch 4/9 to be prepare tracing for
  different internal IPA array; it also drops dynamic array inside trace event
- used new structure power_actor and changed the code in patch 5/9 (Rafael)
- keept the local num_actors variable (Rafael)
- patch 6/9 skipped redundant parens and changed the header desc. (Rafael)
- patch 7/9 changed header and used instance->tz->lock (Rafael)
- patch 8/9 removed handle_weight_update() and renamed new event to
  THERMAL_INSTANCE_WEIGHT_CHANGE (Rafael)
- patch 9/9 aliged to use THERMAL_INSTANCE_WEIGHT_CHANGE is switch (Rafael)
  
v2 can be found here [1]

Regards,
Lukasz

[1] https://lore.kernel.org/lkml/20231212134844.1213381-1-lukasz.luba@arm.com/

Lukasz Luba (9):
  thermal: core: Add governor callback for thermal zone change
  thermal: gov_power_allocator: Refactor check_power_actors()
  thermal: gov_power_allocator: Refactor checks in divvy_up_power()
  thermal: gov_power_allocator: Change trace functions
  thermal: gov_power_allocator: Move memory allocation out of throttle()
  thermal: gov_power_allocator: Simplify checks for valid power actor
  thermal/sysfs: Update instance->weight under tz lock
  thermal/sysfs: Update governors when the 'weight' has changed
  thermal: gov_power_allocator: Support new update callback of weights

 drivers/thermal/gov_power_allocator.c | 269 ++++++++++++++++----------
 drivers/thermal/thermal_core.c        |  14 ++
 drivers/thermal/thermal_core.h        |   2 +
 drivers/thermal/thermal_sysfs.c       |   7 +
 drivers/thermal/thermal_trace_ipa.h   |  50 +++--
 include/linux/thermal.h               |   7 +
 6 files changed, 226 insertions(+), 123 deletions(-)

-- 
2.25.1


^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2024-01-02  9:38 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-12-20 23:17 [PATCH v3 0/9] Add callback for cooling list update to speed-up IPA Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 1/9] thermal: core: Add governor callback for thermal zone change Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 2/9] thermal: gov_power_allocator: Refactor check_power_actors() Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 3/9] thermal: gov_power_allocator: Refactor checks in divvy_up_power() Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 4/9] thermal: gov_power_allocator: Change trace functions Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 5/9] thermal: gov_power_allocator: Move memory allocation out of throttle() Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 6/9] thermal: gov_power_allocator: Simplify checks for valid power actor Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 7/9] thermal/sysfs: Update instance->weight under tz lock Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 8/9] thermal/sysfs: Update governors when the 'weight' has changed Lukasz Luba
2023-12-20 23:17 ` [PATCH v3 9/9] thermal: gov_power_allocator: Support new update callback of weights Lukasz Luba
2023-12-29 17:15 ` [PATCH v3 0/9] Add callback for cooling list update to speed-up IPA Rafael J. Wysocki
2024-01-02  9:39   ` Lukasz Luba

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®