* SEVERE Problems in 2.5.12 at uid0 access
@ 2002-05-01 11:14 system_lists
2002-05-01 17:06 ` Bob_Tracy
0 siblings, 1 reply; 8+ messages in thread
From: system_lists @ 2002-05-01 11:14 UTC (permalink / raw)
To: linux-kernel
server01:/ # cd /var/log
server01:/var/log# ls -laF
<snip>
drwxr-s--- 2 mail adm 104 Mar 12 23:29 exim/
<snip>
server01:/var/log# ls -laF exim
ls: exim/.: Permission denied
ls: exim/..: Permission denied
ls: exim/rejectlog: Permission denied
ls: exim/mainlog: Permission denied
total 0
server01:/var/log# whoami
root
server01:/var/log# id
uid=0(root) gid=0(root) groups=0(root)
server01:/var/log#
What hell is that? could be a ReiseFs problem (/var is a ReiserFs partition)
Ok, ill try on a ext3 partition:
server01:/var/log# cd /boot
server01:/boot# mkdir a
server01:/boot# ls -laF
total 2368
<snip>
drwxr-xr-x 2 root root 4096 May 1 12:08 a/
<snip>
server01:/boot# chown mail.adm a
server01:/boot# chmod 750 a
server01:/boot# ls -laF
total 2368
<snip>
drwxr-x--- 2 mail adm 4096 May 1 12:08 a/
<snip>
server01:/boot# ls -laF a
ls: a/.: Permission denied
ls: a/..: Permission denied
total 0
server01:/boot# id
uid=0(root) gid=0(root) groups=0(root)
server01:/boot#
???? WELL?????
reboting to previous kernel version (2.5.8-pre2+1_6_reiserfs patchs)
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: SEVERE Problems in 2.5.12 at uid0 access
2002-05-01 11:14 SEVERE Problems in 2.5.12 at uid0 access system_lists
@ 2002-05-01 17:06 ` Bob_Tracy
2002-05-01 17:56 ` Pierre Rousselet
` (2 more replies)
0 siblings, 3 replies; 8+ messages in thread
From: Bob_Tracy @ 2002-05-01 17:06 UTC (permalink / raw)
To: system_lists; +Cc: linux-kernel
system_lists@nullzone.org wrote:
> server01:/var/log# ls -laF
> <snip>
> drwxr-s--- 2 mail adm 104 Mar 12 23:29 exim/
> <snip>
>
> server01:/var/log# ls -laF exim
> ls: exim/.: Permission denied
> ls: exim/..: Permission denied
> ls: exim/rejectlog: Permission denied
> ls: exim/mainlog: Permission denied
> total 0
> server01:/var/log# whoami
> root
> server01:/var/log# id
> uid=0(root) gid=0(root) groups=0(root)
> server01:/var/log#
Confirmed on a 2.5.11 system as well. Talk about your basic heart
attack! I'd just installed Postfix and found that I couldn't access
any of the directories under /var/spool/postfix. Fortunately (?),
I've got older kernels to fall back on, and that's one of the hazards
of running on the bleeding edge I reckon.
Oh yeah... ext2 filesystem. I think this bug is at least mostly
independent of the filesystem type.
--
-----------------------------------------------------------------------
Bob Tracy WTO + WIPO = DMCA? http://www.anti-dmca.org
rct@frus.com
-----------------------------------------------------------------------
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: SEVERE Problems in 2.5.12 at uid0 access
2002-05-01 17:06 ` Bob_Tracy
@ 2002-05-01 17:56 ` Pierre Rousselet
2002-05-01 18:04 ` Bob_Tracy
2002-05-01 18:13 ` Skip Ford
2002-05-01 18:18 ` Alexander Viro
2 siblings, 1 reply; 8+ messages in thread
From: Pierre Rousselet @ 2002-05-01 17:56 UTC (permalink / raw)
To: Bob_Tracy; +Cc: system_lists, linux-kernel
Bob_Tracy wrote:
> Confirmed on a 2.5.11 system as well. Talk about your basic heart
> attack! I'd just installed Postfix and found that I couldn't access
> any of the directories under /var/spool/postfix. Fortunately (?),
> I've got older kernels to fall back on, and that's one of the hazards
> of running on the bleeding edge I reckon.
>
> Oh yeah... ext2 filesystem. I think this bug is at least mostly
> independent of the filesystem type.
The same here with 2.5.12 and ext2, have you run fsck on this fs ?
Pierre
------------------------------------------------
Pierre Rousselet <pierre.rousselet@wanadoo.fr>
------------------------------------------------
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: SEVERE Problems in 2.5.12 at uid0 access
2002-05-01 17:56 ` Pierre Rousselet
@ 2002-05-01 18:04 ` Bob_Tracy
0 siblings, 0 replies; 8+ messages in thread
From: Bob_Tracy @ 2002-05-01 18:04 UTC (permalink / raw)
To: Pierre Rousselet; +Cc: system_lists, linux-kernel
Pierre Rousselet wrote:
> Bob_Tracy wrote:
> > Confirmed on a 2.5.11 system as well. Talk about your basic heart
> > attack! I'd just installed Postfix and found that I couldn't access
> > any of the directories under /var/spool/postfix. Fortunately (?),
> > I've got older kernels to fall back on, and that's one of the hazards
> > of running on the bleeding edge I reckon.
> >
> > Oh yeah... ext2 filesystem. I think this bug is at least mostly
> > independent of the filesystem type.
>
> The same here with 2.5.12 and ext2, have you run fsck on this fs ?
Yes, it's clean. Changing the owner of the inaccessible directory to
root allows you to "cd" into it and everything seems normal.
Alternatively, you can simply boot up on an older kernel and that takes
care of the problem too.
--
-----------------------------------------------------------------------
Bob Tracy WTO + WIPO = DMCA? http://www.anti-dmca.org
rct@frus.com
-----------------------------------------------------------------------
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: SEVERE Problems in 2.5.12 at uid0 access
2002-05-01 17:06 ` Bob_Tracy
2002-05-01 17:56 ` Pierre Rousselet
@ 2002-05-01 18:13 ` Skip Ford
2002-05-01 18:18 ` Alexander Viro
2 siblings, 0 replies; 8+ messages in thread
From: Skip Ford @ 2002-05-01 18:13 UTC (permalink / raw)
To: Bob_Tracy; +Cc: system_lists, linux-kernel
Bob_Tracy wrote:
> system_lists@nullzone.org wrote:
> > server01:/var/log# ls -laF
> > <snip>
> > drwxr-s--- 2 mail adm 104 Mar 12 23:29 exim/
> > <snip>
> >
> > server01:/var/log# ls -laF exim
> > ls: exim/.: Permission denied
>
> Confirmed on a 2.5.11 system as well. Talk about your basic heart
> attack! I'd just installed Postfix and found that I couldn't access
> any of the directories under /var/spool/postfix. Fortunately (?),
> I've got older kernels to fall back on, and that's one of the hazards
> of running on the bleeding edge I reckon.
Al Viro posted a patch to fix this.
diff -urN C12-0/fs/namei.c C12-current/fs/namei.c
--- C12-0/fs/namei.c Tue Apr 30 20:23:38 2002
+++ C12-current/fs/namei.c Tue Apr 30 23:37:15 2002
@@ -324,6 +324,12 @@
if (mode & MAY_EXEC)
return 0;
+ if ((inode->i_mode & S_IXUGO) && capable(CAP_DAC_OVERRIDE))
+ return 0;
+
+ if (S_ISDIR(inode->i_mode) && capable(CAP_DAC_READ_SEARCH))
+ return 0;
+
return -EACCES;
}
--
Skip
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: SEVERE Problems in 2.5.12 at uid0 access
2002-05-01 17:06 ` Bob_Tracy
2002-05-01 17:56 ` Pierre Rousselet
2002-05-01 18:13 ` Skip Ford
@ 2002-05-01 18:18 ` Alexander Viro
2002-05-02 21:39 ` Paul Larson
2 siblings, 1 reply; 8+ messages in thread
From: Alexander Viro @ 2002-05-01 18:18 UTC (permalink / raw)
To: Bob_Tracy; +Cc: system_lists, linux-kernel
On Wed, 1 May 2002, Bob_Tracy wrote:
> Confirmed on a 2.5.11 system as well. Talk about your basic heart
> attack! I'd just installed Postfix and found that I couldn't access
> any of the directories under /var/spool/postfix. Fortunately (?),
> I've got older kernels to fall back on, and that's one of the hazards
> of running on the bleeding edge I reckon.
>
> Oh yeah... ext2 filesystem. I think this bug is at least mostly
> independent of the filesystem type.
Yes, it is. Look for the patch I've posted yesterday (subject was
something like "[PATCH] missing checks", IIRC).
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: SEVERE Problems in 2.5.12 at uid0 access
2002-05-01 18:18 ` Alexander Viro
@ 2002-05-02 21:39 ` Paul Larson
0 siblings, 0 replies; 8+ messages in thread
From: Paul Larson @ 2002-05-02 21:39 UTC (permalink / raw)
To: Alexander Viro; +Cc: Bob_Tracy, system_lists, linux-kernel
On Wed, 2002-05-01 at 13:18, Alexander Viro wrote:
> Yes, it is. Look for the patch I've posted yesterday (subject was
> something like "[PATCH] missing checks", IIRC).
Before I found this message I was also trying to hunt down this problem
after noticing that 2.5.12 failed unlink08 from LTP. The thing I think
broke it though was a seemlingly minor change to the handling of the
return value from exec_permission_lite in link_path_walk(). In 2.5.11
it rechecked with permission() if it got an error back from
exec_permission_lite(), but in 2.5.12 it only does this if err ==
-EAGAIN. This patch also seems to fix the problem, and simply reverts
it back to the original way it was handled rather than adding more code
to exec_permission_lite(). I'll let you decide which is the best way.
Thanks,
Paul Larson
--- linux/fs/namei.c Thu May 2 18:36:01 2002
+++ linux-fix/fs/namei.c Thu May 2 18:36:17 2002
@@ -573,7 +573,7 @@
unsigned int c;
err = exec_permission_lite(inode);
- if (err == -EAGAIN) {
+ if (err) {
unlock_nd(nd);
err = permission(inode, MAY_EXEC);
lock_nd(nd);
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: SEVERE Problems in 2.5.12 at uid0 access
[not found] <Pine.GSO.4.21.0205011417230.12640-100000@weyl.math.psu.edu >
@ 2002-05-01 18:57 ` system_lists
0 siblings, 0 replies; 8+ messages in thread
From: system_lists @ 2002-05-01 18:57 UTC (permalink / raw)
To: linux-kernel
Thanks to all (Viro, Skip, Bob and Pierre).
At 14:18 01/05/2002 -0400, Alexander Viro wrote:
>On Wed, 1 May 2002, Bob_Tracy wrote:
>
> > Confirmed on a 2.5.11 system as well. Talk about your basic heart
> > attack! I'd just installed Postfix and found that I couldn't access
> > any of the directories under /var/spool/postfix. Fortunately (?),
> > I've got older kernels to fall back on, and that's one of the hazards
> > of running on the bleeding edge I reckon.
> >
> > Oh yeah... ext2 filesystem. I think this bug is at least mostly
> > independent of the filesystem type.
>
>Yes, it is. Look for the patch I've posted yesterday (subject was
>something like "[PATCH] missing checks", IIRC).
^ permalink raw reply [flat|nested] 8+ messages in thread
end of thread, other threads:[~2002-05-02 21:45 UTC | newest]
Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2002-05-01 11:14 SEVERE Problems in 2.5.12 at uid0 access system_lists
2002-05-01 17:06 ` Bob_Tracy
2002-05-01 17:56 ` Pierre Rousselet
2002-05-01 18:04 ` Bob_Tracy
2002-05-01 18:13 ` Skip Ford
2002-05-01 18:18 ` Alexander Viro
2002-05-02 21:39 ` Paul Larson
[not found] <Pine.GSO.4.21.0205011417230.12640-100000@weyl.math.psu.edu >
2002-05-01 18:57 ` system_lists
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®