From: Reinette Chatre <reinette.chatre@intel.com>
To: Chen Yu <yu.c.chen@intel.com>, <tony.luck@intel.com>
Cc: <tglx@kernel.org>, <bp@alien8.de>, <mingo@redhat.com>,
<dave.hansen@linux.intel.com>, <hpa@zytor.com>,
<fenghuay@nvidia.com>, <babu.moger@amd.com>,
<hongyu.ning@intel.com>, <chen.yu@linux.dev>, <x86@kernel.org>,
<linux-kernel@vger.kernel.org>,
Hongyu Ning <hongyu.ning@linux.intel.com>
Subject: Re: [PATCH v8 7/9] fs/resctrl: Do not invoke smp_processor_id() in preemptible context
Date: Mon, 28 Sep 2026 14:48:12 -0700 [thread overview]
Message-ID: <432f616b-314f-4b46-bfa0-28759a493cae@intel.com> (raw)
In-Reply-To: <6e0ff955200ead6a2ac689d492a5e5c73ebc3552.1789705667.git.yu.c.chen@intel.com>
Hi Chenyu,
On 9/17/26 9:50 PM, Chen Yu wrote:
> From: Tony Luck <tony.luck@intel.com>
>
> An event flagged with mon_evt::any_cpu is read directly in preemptible task
> context instead of being dispatched to a CPU of the monitoring domain. Only
> Intel AET events set this flag, so __mon_event_count() rejects an any_cpu L3
> event with WARN_ON_ONCE(). The L3 read paths can therefore call
> smp_processor_id() unconditionally to check that the current CPU belongs to the
> domain being read.
>
> MMIO-based LLC occupancy counters can be read from any CPU, so the L3 read
> paths have to tolerate an any_cpu event. Move that check into a helper which
> returns early for any_cpu events, avoiding smp_processor_id() in preemptible
> context, and report a wrong CPU via rmid_read::err.
"report a wrong CPU via rmid_read::err" is obvious from the patch.
>
> Signed-off-by: Tony Luck <tony.luck@intel.com>
> Signed-off-by: Chen Yu <yu.c.chen@intel.com>
> Tested-by: Hongyu Ning <hongyu.ning@linux.intel.com>
> ---
> fs/resctrl/monitor.c | 48 +++++++++++++++++++++++++++++++-------------
> 1 file changed, 34 insertions(+), 14 deletions(-)
>
> diff --git a/fs/resctrl/monitor.c b/fs/resctrl/monitor.c
> index 73413cb128ea..3e05b0271c58 100644
> --- a/fs/resctrl/monitor.c
> +++ b/fs/resctrl/monitor.c
> @@ -422,9 +422,37 @@ static void mbm_cntr_free(struct rdt_l3_mon_domain *d, int cntr_id)
> memset(&d->cntr_cfg[cntr_id], 0, sizeof(*d->cntr_cfg));
> }
>
> +/**
> + * cpu_on_correct_domain() - Check if current CPU is in the correct
> + * domain for the event.
The domain is not always relevant. When considering "Return: true if the
current CPU can read this event" ... could something like "cpu_can_read_event()"
be more descriptive?
> + * @rr: The rmid_read structure containing event and domain information.
> + *
> + * Context: Preemptible process context when @rr->evt->any_cpu is set.
> + * Non-migratable process context (via smp_call_on_cpu()) or
> + * non-preemptible context (via smp_call_function_any()) when
> + * the event must be read on a specific CPU.
> + * Return: true if the current CPU can read this event, false otherwise.
> + */
> +static bool cpu_on_correct_domain(struct rmid_read *rr)
> +{
> + int cpu;
> +
> + /* Any CPU is OK for this event */
> + if (rr->evt->any_cpu)
> + return true;
> +
> + cpu = smp_processor_id();
> +
> + /* Single domain. Must be on a CPU in that domain. */
> + if (rr->hdr)
> + return cpumask_test_cpu(cpu, &rr->hdr->cpu_mask);
> +
> + /* Summing domains that share a cache, must be on a CPU for that cache. */
> + return cpumask_test_cpu(cpu, &rr->ci->shared_cpu_map);
> +}
> +
> static int __l3_mon_event_count(struct rdtgroup *rdtgrp, struct rmid_read *rr)
> {
> - int cpu = smp_processor_id();
> u32 closid = rdtgrp->closid;
> u32 rmid = rdtgrp->mon.rmid;
> struct rdt_l3_mon_domain *d;
> @@ -457,11 +485,6 @@ static int __l3_mon_event_count(struct rdtgroup *rdtgrp, struct rmid_read *rr)
> return 0;
> }
>
> - /* Reading a single domain, must be on a CPU in that domain. */
> - if (!cpumask_test_cpu(cpu, &d->hdr.cpu_mask)) {
> - rr->err = -EIO;
> - return -EINVAL;
> - }
> if (rr->is_mbm_cntr)
> rr->err = resctrl_arch_cntr_read(rr->r, d, closid, rmid, cntr_id,
> rr->evt->evtid, &tval);
> @@ -479,7 +502,6 @@ static int __l3_mon_event_count(struct rdtgroup *rdtgrp, struct rmid_read *rr)
>
> static int __l3_mon_event_count_sum(struct rdtgroup *rdtgrp, struct rmid_read *rr)
> {
> - int cpu = smp_processor_id();
> u32 closid = rdtgrp->closid;
> u32 rmid = rdtgrp->mon.rmid;
> struct rdt_l3_mon_domain *d;
> @@ -497,12 +519,6 @@ static int __l3_mon_event_count_sum(struct rdtgroup *rdtgrp, struct rmid_read *r
> return -EINVAL;
> }
>
> - /* Summing domains that share a cache, must be on a CPU for that cache. */
> - if (!cpumask_test_cpu(cpu, &rr->ci->shared_cpu_map)) {
> - rr->err = -EIO;
> - return -EINVAL;
> - }
> -
> /*
> * Legacy files must report the sum of an event across all
> * domains that share the same L3 cache instance.
> @@ -538,7 +554,11 @@ static int __mon_event_count(struct rdtgroup *rdtgrp, struct rmid_read *rr)
> {
> switch (rr->r->rid) {
> case RDT_RESOURCE_L3:
> - WARN_ON_ONCE(rr->evt->any_cpu);
> + if (!cpu_on_correct_domain(rr)) {
> + rr->err = -EIO;
> + return -EINVAL;
> + }
> +
> if (rr->hdr)
> return __l3_mon_event_count(rdtgrp, rr);
> else
Reinette
next prev parent reply other threads:[~2026-09-28 21:48 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-18 4:46 [PATCH v8 0/9] Introduce MMIO-based CMT access for Enhanced RDT Chen Yu
2026-09-18 4:48 ` [PATCH v8 1/9] x86/topology: Export topo_lookup_cpuid() for resctrl use Chen Yu
2026-09-18 4:48 ` [PATCH v8 2/9] x86/resctrl: Require 64-bit x86 for resctrl support Chen Yu
2026-09-28 21:21 ` Reinette Chatre
2026-09-18 4:49 ` [PATCH v8 3/9] x86/resctrl: Parse ACPI ERDT table and save CACD cpumask for RMDD domains Chen Yu
2026-09-28 21:37 ` Reinette Chatre
2026-09-18 4:50 ` [PATCH v8 4/9] x86/resctrl: Attach ACPI ERDT information to L3 mon domain on CPU online Chen Yu
2026-09-28 21:44 ` Reinette Chatre
2026-09-18 4:50 ` [PATCH v8 5/9] x86/resctrl: Parse ACPI CMRC table Chen Yu
2026-09-28 21:46 ` Reinette Chatre
2026-09-18 4:50 ` [PATCH v8 6/9] x86/resctrl: Refactor the monitor read function Chen Yu
2026-09-18 4:50 ` [PATCH v8 7/9] fs/resctrl: Do not invoke smp_processor_id() in preemptible context Chen Yu
2026-09-28 21:48 ` Reinette Chatre [this message]
2026-09-18 4:51 ` [PATCH v8 8/9] x86/resctrl: Introduce erdt_cpu_has() and erdt_support() Chen Yu
2026-09-28 21:49 ` Reinette Chatre
2026-09-18 4:51 ` [PATCH v8 9/9] x86/resctrl: Add MMIO-based LLC occupancy monitoring support Chen Yu
2026-09-28 21:54 ` Reinette Chatre
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=432f616b-314f-4b46-bfa0-28759a493cae@intel.com \
--to=reinette.chatre@intel.com \
--cc=babu.moger@amd.com \
--cc=bp@alien8.de \
--cc=chen.yu@linux.dev \
--cc=dave.hansen@linux.intel.com \
--cc=fenghuay@nvidia.com \
--cc=hongyu.ning@intel.com \
--cc=hongyu.ning@linux.intel.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=tglx@kernel.org \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
--cc=yu.c.chen@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®