From: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>
To: Mukesh Ojha <mukesh.ojha@oss.qualcomm.com>
Cc: Bjorn Andersson <andersson@kernel.org>,
Mathieu Poirier <mathieu.poirier@linaro.org>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Manivannan Sadhasivam <mani@kernel.org>,
Konrad Dybcio <konradybcio@kernel.org>,
linux-arm-msm@vger.kernel.org, linux-remoteproc@vger.kernel.org,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v8 11/14] firmware: qcom_scm: Add qcom_scm_pas_get_rsc_table() to get resource table
Date: Wed, 3 Dec 2025 13:36:32 +0100 [thread overview]
Message-ID: <4376b7cf-7088-412b-8596-bdec5bdc273d@oss.qualcomm.com> (raw)
In-Reply-To: <20251124152538.wt3kzztqmpr76hsx@hu-mojha-hyd.qualcomm.com>
On 11/24/25 4:25 PM, Mukesh Ojha wrote:
> On Mon, Nov 24, 2025 at 12:48:31PM +0100, Konrad Dybcio wrote:
>> On 11/21/25 12:01 PM, Mukesh Ojha wrote:
>>> Qualcomm remote processor may rely on Static and Dynamic resources for
>>> it to be functional. Static resources are fixed like for example,
>>> memory-mapped addresses required by the subsystem and dynamic
>>> resources, such as shared memory in DDR etc., are determined at
>>> runtime during the boot process.
>>>
>>> For most of the Qualcomm SoCs, when run with Gunyah or older QHEE
>>> hypervisor, all the resources whether it is static or dynamic, is
>>> managed by the hypervisor. Dynamic resources if it is present for a
>>> remote processor will always be coming from secure world via SMC call
>>> while static resources may be present in remote processor firmware
>>> binary or it may be coming qcom_scm_pas_get_rsc_table() SMC call along
>>> with dynamic resources.
>>>
>>> Some of the remote processor drivers, such as video, GPU, IPA, etc., do
>>> not check whether resources are present in their remote processor
>>> firmware binary. In such cases, the caller of this function should set
>>> input_rt and input_rt_size as NULL and zero respectively. Remoteproc
>>> framework has method to check whether firmware binary contain resources
>>> or not and they should be pass resource table pointer to input_rt and
>>> resource table size to input_rt_size and this will be forwarded to
>>> TrustZone for authentication. TrustZone will then append the dynamic
>>> resources and return the complete resource table in output_rt
>>>
>>> More about documentation on resource table format can be found in
>>> include/linux/remoteproc.h
>>>
>>> Signed-off-by: Mukesh Ojha <mukesh.ojha@oss.qualcomm.com>
>>> ---
>>
>> [...]
>>
>>> +int qcom_scm_pas_get_rsc_table(struct qcom_scm_pas_context *ctx, void *input_rt,
>>> + size_t input_rt_size, void **output_rt,
>>> + size_t *output_rt_size)
>>> +{
>>> + unsigned int retry_num = 5;
>>> + int ret;
>>> +
>>> + do {
>>> + *output_rt = kzalloc(*output_rt_size, GFP_KERNEL);
>>> + if (!*output_rt)
>>> + return -ENOMEM;
>>> +
>>> + ret = __qcom_scm_pas_get_rsc_table(ctx->pas_id, input_rt,
>>> + input_rt_size, output_rt,
>>> + output_rt_size);
>>> + if (ret)
>>> + kfree(*output_rt);
>>> +
>>> + } while (ret == -EAGAIN && --retry_num);
>>
>> Will firmware return -EAGAIN as a result, or is this to handle the
>> "buffer too small case"?
>
> The latter one where a re-attempt could pass..
>
>>
>> I think the latter should use a different errno (EOVERFLOW?) and print
>> a message since we decided that it's the caller that suggests a suitable
>> output buffer size
>
> Agree with error code..
>
> This is kept on the caller side keeping future in mind. where we can have
> resource table coming from the client and it needs to go to TZ for
> authentication.
>
> Are you suggesting to move this retry on the caller side ?
I think we got confused in the review of the previous iterations and made
qcom_scm_pas_get_rsc_table() retry 5 times (on the basis that "some" error
could happen in firmware), but if it's specifically "buf too small", we should
only need to call it utmost twice - once to get the required larger size (or
succeed and exit) and another one with a now-correctly sized buffer.
Looking at it again, do we really need to be so stringent about the maximum
resource table size? Can we just push the currently defined SZ_16K inside
qcom_scm_pas_get_rsc_table() as a constant and bump it up as necessary in
the future?
> Just for information, once video patches becomes ready, we may bring this
> qcom_mdt_pas_map_devmem_rscs()[1] helper for video or any other client
> should be do this here as well ?
>
> I wanted to optimize this path, where caller is making a guess and
> gets the updated output size in return.
We always end up allocating in __qcom_scm_pas_get_rsc_table() so I think
guessing a number like SZ_16K which is plenty for a effectively small u64[]
in this file is ok too. Perhaps we could even shrink it down a bit..
> [1]
> https://lore.kernel.org/lkml/20250819165447.4149674-9-mukesh.ojha@oss.qualcomm.com/#t
>
>>
>> In case it doesn't make sense for the caller to share their expectations,
>> the buffer could be allocated (and perhaps resized if necessary) internally
>> with some validation (i.e. a rsctable likely won't be 5 GiB)
>
> Are you saying output_size as well should be checked and it should not be
> greater than something like UINT_MAX or something.. ?
>
> + *output_rt_size = res.result[2];
Yeah we should probably make sure this doesn't exceed a large-but-not-
entirely-unreasonable value
Konrad
next prev parent reply other threads:[~2025-12-03 12:36 UTC|newest]
Thread overview: 56+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-21 11:01 [PATCH v8 00/14] Peripheral Image Loader support for Qualcomm SoCs running Linux host at EL2 Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 01/14] dt-bindings: remoteproc: qcom,pas: Add iommus property Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 02/14] firmware: qcom_scm: Remove redundant piece of code Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 03/14] firmware: qcom_scm: Rename peripheral as pas_id Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 04/14] firmware: qcom_scm: Introduce PAS context initialization helper function Mukesh Ojha
2025-12-05 22:45 ` Bjorn Andersson
2025-11-21 11:01 ` [PATCH v8 05/14] remoteproc: pas: Replace metadata context with PAS context structure Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 06/14] soc: qcom: mdtloader: Add PAS context aware qcom_mdt_pas_load() function Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 07/14] soc: qcom: mdtloader: Remove qcom_mdt_pas_init() from exported symbols Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 08/14] firmware: qcom_scm: Add a prep version of auth_and_reset function Mukesh Ojha
2025-12-05 22:50 ` Bjorn Andersson
2025-11-21 11:01 ` [PATCH v8 09/14] firmware: qcom_scm: Refactor qcom_scm_pas_init_image() Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 10/14] firmware: qcom_scm: Add SHM bridge handling for PAS when running without QHEE Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 11/14] firmware: qcom_scm: Add qcom_scm_pas_get_rsc_table() to get resource table Mukesh Ojha
2025-11-24 11:48 ` Konrad Dybcio
2025-11-24 15:25 ` Mukesh Ojha
2025-12-03 12:36 ` Konrad Dybcio [this message]
2025-12-04 12:28 ` Mukesh Ojha
2025-12-05 13:15 ` Konrad Dybcio
2025-12-05 22:17 ` Bjorn Andersson
2025-12-08 17:01 ` Mukesh Ojha
2025-12-17 13:09 ` Konrad Dybcio
2025-12-05 22:21 ` Bjorn Andersson
2025-12-08 14:25 ` Mukesh Ojha
2025-12-05 22:40 ` Bjorn Andersson
2025-12-08 16:49 ` Mukesh Ojha
2025-12-09 10:45 ` Mukesh Ojha
2025-12-18 14:37 ` Bjorn Andersson
2025-11-21 11:01 ` [PATCH v8 12/14] remoteproc: pas: Extend parse_fw callback to fetch resources via SMC call Mukesh Ojha
2025-11-24 11:20 ` Konrad Dybcio
2025-11-21 11:01 ` [PATCH v8 13/14] remoteproc: qcom: pas: Enable Secure PAS support with IOMMU managed by Linux Mukesh Ojha
2025-11-24 11:31 ` Konrad Dybcio
2025-11-24 12:03 ` Mukesh Ojha
2025-11-26 16:40 ` Bjorn Andersson
2025-11-27 7:23 ` Mukesh Ojha
2025-11-21 11:01 ` [PATCH v8 14/14] arm64: dts: qcom: Add EL2 overlay for Lemans Mukesh Ojha
2025-12-05 23:00 ` Bjorn Andersson
2025-12-08 14:21 ` Mukesh Ojha
2025-11-21 11:27 ` [PATCH v8 00/14] Peripheral Image Loader support for Qualcomm SoCs running Linux host at EL2 Bryan O'Donoghue
2025-11-21 11:37 ` Mukesh Ojha
2025-11-21 15:08 ` Konrad Dybcio
2025-11-24 6:45 ` Mukesh Ojha
2025-11-24 11:33 ` Konrad Dybcio
2025-11-24 15:53 ` Mukesh Ojha
2025-11-27 10:25 ` Bryan O'Donoghue
2025-12-02 8:36 ` Mukesh Ojha
2025-12-02 10:13 ` Vikash Garodia
2025-12-02 21:24 ` Bjorn Andersson
2025-12-03 5:18 ` Vikash Garodia
2025-12-05 21:18 ` Dmitry Baryshkov
2025-12-17 10:08 ` Vikash Garodia
2025-12-17 11:43 ` Konrad Dybcio
2025-12-18 4:32 ` Bryan O'Donoghue
2025-12-18 14:07 ` Konrad Dybcio
2025-12-18 14:45 ` Bjorn Andersson
2025-12-05 21:45 ` Bjorn Andersson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4376b7cf-7088-412b-8596-bdec5bdc273d@oss.qualcomm.com \
--to=konrad.dybcio@oss.qualcomm.com \
--cc=andersson@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=konradybcio@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=mani@kernel.org \
--cc=mathieu.poirier@linaro.org \
--cc=mukesh.ojha@oss.qualcomm.com \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®