mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Bart Van Assche <bvanassche@acm.org>
To: Daniil Lunev <dlunev@chromium.org>
Cc: Adrian Hunter <adrian.hunter@intel.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Alim Akhtar <alim.akhtar@samsung.com>,
	Avri Altman <avri.altman@wdc.com>, Bean Huo <beanhuo@micron.com>,
	"James E.J. Bottomley" <jejb@linux.ibm.com>,
	Keoseong Park <keosung.park@samsung.com>,
	"Martin K. Petersen" <martin.petersen@oracle.com>,
	Mauro Carvalho Chehab <mchehab+huawei@kernel.org>,
	Sohaib Mohamed <sohaib.amhmd@gmail.com>,
	linux-kernel@vger.kernel.org, linux-scsi@vger.kernel.org
Subject: Re: [PATCH v5] ufs: core: print UFSHCD capabilities in controller's sysfs node
Date: Tue, 2 Aug 2022 10:32:20 -0700	[thread overview]
Message-ID: <438a9c4c-e601-ec22-0d05-5cec697d06a1@acm.org> (raw)
In-Reply-To: <CAONX=-fpMBSgMzdY9AnV3iJftv2+0UTiruMiR+Dt_dfwKEd6gA@mail.gmail.com>

On 8/1/22 21:12, Daniil Lunev wrote:
>> Calling this the effective capabilities of the controller-device pair
>> sounds good to me. But please do not refer to hba->caps. I'd like to
>> rework hba->caps such that it only includes controller capabilities and
>> no information related to the WriteBooster. Additionally, several UFS
>> device capabilities that may be exported in the future are not
>> represented in hba->caps.
 >
> So can you clarify where specifically do you want me to mention that?
> Should I name the directory "effective_capabilities" or the commit
> message?

I'm fine with the name "capabilities" since "effective_capabilities" is 
a bit long.

How about adding the above explanation in the source code close to the 
definition of the capabilities group since it is more likely that it 
will be noticed there by software developers compared to Documentation/ABI/?

Thanks,

Bart.

      reply	other threads:[~2022-08-02 17:32 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-08-02  0:37 Daniil Lunev
2022-08-02  2:38 ` Bart Van Assche
2022-08-02  3:20   ` Daniil Lunev
2022-08-02  4:02     ` Bart Van Assche
2022-08-02  4:12       ` Daniil Lunev
2022-08-02 17:32         ` Bart Van Assche [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=438a9c4c-e601-ec22-0d05-5cec697d06a1@acm.org \
    --to=bvanassche@acm.org \
    --cc=adrian.hunter@intel.com \
    --cc=alim.akhtar@samsung.com \
    --cc=avri.altman@wdc.com \
    --cc=beanhuo@micron.com \
    --cc=dlunev@chromium.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jejb@linux.ibm.com \
    --cc=keosung.park@samsung.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=mchehab+huawei@kernel.org \
    --cc=sohaib.amhmd@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®