* [PATCH] release_task: replace open-coded ptrace_unlink()
@ 2006-02-16 18:49 Oleg Nesterov
0 siblings, 0 replies; only message in thread
From: Oleg Nesterov @ 2006-02-16 18:49 UTC (permalink / raw)
To: Andrew Morton; +Cc: linux-kernel
Use ptrace_unlink() instead of open-coding.
No changes in kernel/exit.o
Signed-off-by: Oleg Nesterov <oleg@tv-sign.ru>
--- 2.6.16-rc3/kernel/exit.c~ 2006-02-17 00:03:30.000000000 +0300
+++ 2.6.16-rc3/kernel/exit.c 2006-02-17 00:05:25.000000000 +0300
@@ -66,13 +66,12 @@ void release_task(struct task_struct * p
task_t *leader;
struct dentry *proc_dentry;
-repeat:
+repeat:
atomic_dec(&p->user->processes);
spin_lock(&p->proc_lock);
proc_dentry = proc_pid_unhash(p);
write_lock_irq(&tasklist_lock);
- if (unlikely(p->ptrace))
- __ptrace_unlink(p);
+ ptrace_unlink(p);
BUG_ON(!list_empty(&p->ptrace_list) || !list_empty(&p->ptrace_children));
__exit_signal(p);
/*
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2006-02-16 17:32 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-02-16 18:49 [PATCH] release_task: replace open-coded ptrace_unlink() Oleg Nesterov
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®