From: Stefan Richter <stefanr@s5r6.in-berlin.de>
To: Andrew Morton <akpm@osdl.org>
Cc: Andreas Schwab <schwab@suse.de>,
scjody@modernduck.com, bcollins@ubuntu.com, mjt@tls.msk.ru,
linux-kernel@vger.kernel.org, chrisw@sous-sol.org,
linux1394-devel@lists.sourceforge.net
Subject: Re: [stable] [PATCH] sbp2: fix check of return value of hpsb_allocate_and_register_addrspace
Date: Sat, 03 Jun 2006 12:42:28 +0200 [thread overview]
Message-ID: <44816794.7060601@s5r6.in-berlin.de> (raw)
In-Reply-To: <20060603024305.dd0404d0.akpm@osdl.org>
Andrew Morton wrote:
> On Sat, 03 Jun 2006 11:31:27 +0200
> Andreas Schwab <schwab@suse.de> wrote:
>>Michael Tokarev <mjt@tls.msk.ru> writes:
>>>>>* Stefan Richter (stefanr@s5r6.in-berlin.de) wrote:
>>>>>>- if (!scsi_id->status_fifo_addr) {
>>>>>>+ if (scsi_id->status_fifo_addr == ~0ULL) {
>>>
>>>Umm. Can this ~0ULL constant be #define'd to something?
>>>It's way too simple to mis-read it as NULL (or ~NULL whatever).
>>
>>How about writing it as -1?
>
> That's preferable.
>
> It doesn't actually cause a problem, but status_fifo_addr is defined as
> u64, which is not `unsigned long long'. On powerpc, for example, u64 is
> implemented as unsigned long. -1 just works.
I have a patch ready which replaces the magic value by a sensibly named
preprocessor constant. Will be posted within the hour. Thanks for the
comments.
--
Stefan Richter
-=====-=-==- -==- ---==
http://arcgraph.de/sr/
next prev parent reply other threads:[~2006-06-03 10:44 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-06-03 0:00 Stefan Richter
2006-06-03 1:35 ` [stable] " Chris Wright
2006-06-03 8:37 ` Stefan Richter
2006-06-03 9:12 ` Michael Tokarev
2006-06-03 9:31 ` Andreas Schwab
2006-06-03 9:43 ` Andrew Morton
2006-06-03 10:42 ` Stefan Richter [this message]
2006-06-03 11:05 ` [PATCH 1/2] sbp2: fix deregistration of status fifo address space Stefan Richter
2006-06-03 11:08 ` [PATCH 2/2] ieee1394: add preprocessor constant for invalid csr address Stefan Richter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=44816794.7060601@s5r6.in-berlin.de \
--to=stefanr@s5r6.in-berlin.de \
--cc=akpm@osdl.org \
--cc=bcollins@ubuntu.com \
--cc=chrisw@sous-sol.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux1394-devel@lists.sourceforge.net \
--cc=mjt@tls.msk.ru \
--cc=schwab@suse.de \
--cc=scjody@modernduck.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®