* [PATCH] [MM] fixes kerneldoc errors in usbcore-auto(susp/res)-patch
@ 2006-09-12 12:00 Henne
2006-09-12 14:45 ` Alan Stern
0 siblings, 1 reply; 2+ messages in thread
From: Henne @ 2006-09-12 12:00 UTC (permalink / raw)
To: Andrew Morton; +Cc: stern, Greg KH, linux-kernel
From: Henrik Kretzschmar <henne@nachtwindheim.de>
Fixes kerneldoc errors on usb/core/driver.c, which occured in 2.6.18-rc6-mm2
gregkh-usb-usbcore-add-autosuspend-autoresume-infrastructure.patch
Signed-off-by: Henrik Kretzschmar <henne@nachtwindheim.de>
---
--- linux-2.6.18-rc6-mm2/drivers/usb/core/driver.c 2006-09-12 13:31:56.000000000 +0200
+++ devel/drivers/usb/core/driver.c 2006-09-12 13:33:12.000000000 +0200
@@ -1102,8 +1102,8 @@
/**
* usb_autosuspend_device - delayed autosuspend of a USB device and its interfaces
- * @udev - the usb_device to autosuspend
- * @dec_usage_cnt - flag to decrement @udev's PM-usage counter
+ * @udev: the usb_device to autosuspend
+ * @dec_usage_cnt: flag to decrement @udev's PM-usage counter
*
* This routine should be called when a core subsystem is finished using
* @udev and wants to allow it to autosuspend. Examples would be when
@@ -1139,8 +1139,8 @@
/**
* usb_autoresume_device - immediately autoresume a USB device and its interfaces
- * @udev - the usb_device to autoresume
- * @inc_usage_cnt - flag to increment @udev's PM-usage counter
+ * @udev: the usb_device to autoresume
+ * @inc_usage_cnt: flag to increment @udev's PM-usage counter
*
* This routine should be called when a core subsystem wants to use @udev
* and needs to guarantee that it is not suspended. In addition, the
@@ -1180,7 +1180,7 @@
/**
* usb_autopm_put_interface - decrement a USB interface's PM-usage counter
- * @intf - the usb_interface whose counter should be decremented
+ * @intf: the usb_interface whose counter should be decremented
*
* This routine should be called by an interface driver when it is
* finished using @intf and wants to allow it to autosuspend. A typical
@@ -1227,7 +1227,7 @@
/**
* usb_autopm_get_interface - increment a USB interface's PM-usage counter
- * @intf - the usb_interface whose counter should be incremented
+ * @intf: the usb_interface whose counter should be incremented
*
* This routine should be called by an interface driver when it wants to
* use @intf and needs to guarantee that it is not suspended. In addition,
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] [MM] fixes kerneldoc errors in usbcore-auto(susp/res)-patch
2006-09-12 12:00 [PATCH] [MM] fixes kerneldoc errors in usbcore-auto(susp/res)-patch Henne
@ 2006-09-12 14:45 ` Alan Stern
0 siblings, 0 replies; 2+ messages in thread
From: Alan Stern @ 2006-09-12 14:45 UTC (permalink / raw)
To: Henne; +Cc: Andrew Morton, Greg KH, linux-kernel
On Tue, 12 Sep 2006, Henne wrote:
> From: Henrik Kretzschmar <henne@nachtwindheim.de>
>
> Fixes kerneldoc errors on usb/core/driver.c, which occured in 2.6.18-rc6-mm2
> gregkh-usb-usbcore-add-autosuspend-autoresume-infrastructure.patch
> Signed-off-by: Henrik Kretzschmar <henne@nachtwindheim.de>
Acked-by: Alan Stern <stern@rowland.harvard.edu>
>
> ---
>
> --- linux-2.6.18-rc6-mm2/drivers/usb/core/driver.c 2006-09-12 13:31:56.000000000 +0200
> +++ devel/drivers/usb/core/driver.c 2006-09-12 13:33:12.000000000 +0200
> @@ -1102,8 +1102,8 @@
>
> /**
> * usb_autosuspend_device - delayed autosuspend of a USB device and its interfaces
> - * @udev - the usb_device to autosuspend
> - * @dec_usage_cnt - flag to decrement @udev's PM-usage counter
> + * @udev: the usb_device to autosuspend
> + * @dec_usage_cnt: flag to decrement @udev's PM-usage counter
> *
> * This routine should be called when a core subsystem is finished using
> * @udev and wants to allow it to autosuspend. Examples would be when
> @@ -1139,8 +1139,8 @@
>
> /**
> * usb_autoresume_device - immediately autoresume a USB device and its interfaces
> - * @udev - the usb_device to autoresume
> - * @inc_usage_cnt - flag to increment @udev's PM-usage counter
> + * @udev: the usb_device to autoresume
> + * @inc_usage_cnt: flag to increment @udev's PM-usage counter
> *
> * This routine should be called when a core subsystem wants to use @udev
> * and needs to guarantee that it is not suspended. In addition, the
> @@ -1180,7 +1180,7 @@
>
> /**
> * usb_autopm_put_interface - decrement a USB interface's PM-usage counter
> - * @intf - the usb_interface whose counter should be decremented
> + * @intf: the usb_interface whose counter should be decremented
> *
> * This routine should be called by an interface driver when it is
> * finished using @intf and wants to allow it to autosuspend. A typical
> @@ -1227,7 +1227,7 @@
>
> /**
> * usb_autopm_get_interface - increment a USB interface's PM-usage counter
> - * @intf - the usb_interface whose counter should be incremented
> + * @intf: the usb_interface whose counter should be incremented
> *
> * This routine should be called by an interface driver when it wants to
> * use @intf and needs to guarantee that it is not suspended. In addition,
>
>
>
>
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2006-09-12 14:45 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-09-12 12:00 [PATCH] [MM] fixes kerneldoc errors in usbcore-auto(susp/res)-patch Henne
2006-09-12 14:45 ` Alan Stern
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®