From: "André Przywara" <andre.przywara@arm.com>
To: Leo Yan <leo.yan@linaro.org>,
Arnaldo Carvalho de Melo <acme@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@redhat.com>,
Mark Rutland <mark.rutland@arm.com>,
Alexander Shishkin <alexander.shishkin@linux.intel.com>,
Jiri Olsa <jolsa@redhat.com>, Namhyung Kim <namhyung@kernel.org>,
Wei Li <liwei391@huawei.com>, James Clark <james.clark@arm.com>,
Al Grant <Al.Grant@arm.com>, Dave Martin <Dave.Martin@arm.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 17/20] perf arm-spe: Refactor operation packet handling
Date: Mon, 26 Oct 2020 18:17:10 +0000 [thread overview]
Message-ID: <4908efac-0cb4-b2db-69d2-f81cbe14c021@arm.com> (raw)
In-Reply-To: <20201022145816.14069-18-leo.yan@linaro.org>
On 22/10/2020 15:58, Leo Yan wrote:
Hi,
> Defines macros for operation packet header and formats (support sub
> classes for 'other', 'branch', 'load and store', etc). Uses these
> macros for operation packet decoding and dumping.
>
> Signed-off-by: Leo Yan <leo.yan@linaro.org>
> ---
> .../arm-spe-decoder/arm-spe-pkt-decoder.c | 34 +++++++++++--------
> .../arm-spe-decoder/arm-spe-pkt-decoder.h | 26 ++++++++++++++
> 2 files changed, 45 insertions(+), 15 deletions(-)
>
> diff --git a/tools/perf/util/arm-spe-decoder/arm-spe-pkt-decoder.c b/tools/perf/util/arm-spe-decoder/arm-spe-pkt-decoder.c
> index 19d05d9734ab..59b538563d31 100644
> --- a/tools/perf/util/arm-spe-decoder/arm-spe-pkt-decoder.c
> +++ b/tools/perf/util/arm-spe-decoder/arm-spe-pkt-decoder.c
> @@ -144,7 +144,7 @@ static int arm_spe_get_op_type(const unsigned char *buf, size_t len,
> struct arm_spe_pkt *packet)
> {
> packet->type = ARM_SPE_OP_TYPE;
> - packet->index = buf[0] & 0x3;
> + packet->index = SPE_OP_PKT_HDR_CLASS(buf[0]);
> return arm_spe_get_payload(buf, len, 0, packet);
> }
>
> @@ -339,37 +339,39 @@ static int arm_spe_pkt_desc_event(const struct arm_spe_pkt *packet,
> static int arm_spe_pkt_desc_op_type(const struct arm_spe_pkt *packet,
> char *buf, size_t buf_len)
> {
> - int ret, idx = packet->index;
> + int ret, class = packet->index;
> unsigned long long payload = packet->payload;
> size_t blen = buf_len;
>
> - switch (idx) {
> - case 0:
> + switch (class) {
> + case SPE_OP_PKT_HDR_CLASS_OTHER:
> return arm_spe_pkt_snprintf(&buf, &blen,
> - payload & 0x1 ? "COND-SELECT" : "INSN-OTHER");
> - case 1:
> + payload & SPE_OP_PKT_COND ? "COND-SELECT" : "INSN-OTHER");
> + case SPE_OP_PKT_HDR_CLASS_LD_ST_ATOMIC:
> ret = arm_spe_pkt_snprintf(&buf, &blen,
> - payload & 0x1 ? "ST" : "LD");
> + payload & SPE_OP_PKT_ST ? "ST" : "LD");
> if (ret < 0)
> return ret;
>
> - if (payload & 0x2) {
> - if (payload & 0x4) {
> + if (SPE_OP_PKT_LDST_SUBCLASS_ATOMIC_GET(payload) ==
> + SPE_OP_PKT_LDST_SUBCLASS_ATOMIC) {
This looks somewhat hard to read, and those symbols are only used once?
So what about combining this down in the header so that you can use:
if (SPE_OP_PKT_IS_LDST_ATOMIC(payload)) {
> + if (payload & SPE_OP_PKT_AT) {
> ret = arm_spe_pkt_snprintf(&buf, &blen, " AT");
> if (ret < 0)
> return ret;
> }
> - if (payload & 0x8) {
> + if (payload & SPE_OP_PKT_EXCL) {
> ret = arm_spe_pkt_snprintf(&buf, &blen, " EXCL");
> if (ret < 0)
> return ret;
> }
> - if (payload & 0x10) {
> + if (payload & SPE_OP_PKT_AR) {
> ret = arm_spe_pkt_snprintf(&buf, &blen, " AR");
> if (ret < 0)
> return ret;
> }
> - } else if (payload & 0x4) {
> + } else if (SPE_OP_PKT_LDST_SUBCLASS_GET(payload) ==
> + SPE_OP_PKT_LDST_SUBCLASS_SIMD_FP) {
> ret = arm_spe_pkt_snprintf(&buf, &blen, " SIMD-FP");
> if (ret < 0)
> return ret;
> @@ -377,17 +379,19 @@ static int arm_spe_pkt_desc_op_type(const struct arm_spe_pkt *packet,
>
> return buf_len - blen;
>
> - case 2:
> + case SPE_OP_PKT_HDR_CLASS_BR_ERET:
> ret = arm_spe_pkt_snprintf(&buf, &blen, "B");
> if (ret < 0)
> return ret;
>
> - if (payload & 0x1) {
> + if (payload & SPE_OP_PKT_COND) {
> ret = arm_spe_pkt_snprintf(&buf, &blen, " COND");
> if (ret < 0)
> return ret;
> }
> - if (payload & 0x2) {
> +
> + if (SPE_OP_PKT_BRANCH_SUBCLASS_GET(payload) ==
> + SPE_OP_PKT_BRANCH_SUBCLASS_INDIRECT) {
Same here, it's the only user of both symbols, so maybe:
if (SPE_OP_PKT_IS_INDIRECT_BRANCH(payload)) {
Cheers,
Andre
> ret = arm_spe_pkt_snprintf(&buf, &blen, " IND");
> if (ret < 0)
> return ret;
> diff --git a/tools/perf/util/arm-spe-decoder/arm-spe-pkt-decoder.h b/tools/perf/util/arm-spe-decoder/arm-spe-pkt-decoder.h
> index 12c344454cf1..31dbb8c0fde3 100644
> --- a/tools/perf/util/arm-spe-decoder/arm-spe-pkt-decoder.h
> +++ b/tools/perf/util/arm-spe-decoder/arm-spe-pkt-decoder.h
> @@ -110,6 +110,32 @@ enum arm_spe_events {
> EV_EMPTY_PREDICATE = 18,
> };
>
> +/* Operation packet header */
> +#define SPE_OP_PKT_HDR_CLASS(h) ((h) & GENMASK_ULL(1, 0))
> +#define SPE_OP_PKT_HDR_CLASS_OTHER 0x0
> +#define SPE_OP_PKT_HDR_CLASS_LD_ST_ATOMIC 0x1
> +#define SPE_OP_PKT_HDR_CLASS_BR_ERET 0x2
> +
> +#define SPE_OP_PKT_COND BIT(0)
> +
> +#define SPE_OP_PKT_LDST_SUBCLASS_GET(v) ((v) & GENMASK_ULL(7, 1))
> +#define SPE_OP_PKT_LDST_SUBCLASS_GP_REG 0x0
> +#define SPE_OP_PKT_LDST_SUBCLASS_SIMD_FP 0x4
> +#define SPE_OP_PKT_LDST_SUBCLASS_UNSPEC_REG 0x10
> +#define SPE_OP_PKT_LDST_SUBCLASS_NV_SYSREG 0x30
> +
> +#define SPE_OP_PKT_LDST_SUBCLASS_ATOMIC_GET(v) ((v) & (GENMASK_ULL(7, 5) | GENMASK_ULL(1, 1)))
> +#define SPE_OP_PKT_LDST_SUBCLASS_ATOMIC 0x2
> +
> +#define SPE_OP_PKT_AR BIT(4)
> +#define SPE_OP_PKT_EXCL BIT(3)
> +#define SPE_OP_PKT_AT BIT(2)
> +#define SPE_OP_PKT_ST BIT(0)
> +
> +#define SPE_OP_PKT_BRANCH_SUBCLASS_GET(v) ((v) & GENMASK_ULL(7, 1))
> +#define SPE_OP_PKT_BRANCH_SUBCLASS_DIRECT 0x0
> +#define SPE_OP_PKT_BRANCH_SUBCLASS_INDIRECT 0x2
> +
> const char *arm_spe_pkt_name(enum arm_spe_pkt_type);
>
> int arm_spe_get_packet(const unsigned char *buf, size_t len,
>
next prev parent reply other threads:[~2020-10-26 18:18 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-10-22 14:57 [PATCH v3 00/20] perf arm-spe: Refactor decoding & dumping flow Leo Yan
2020-10-22 14:57 ` [PATCH v3 01/20] perf arm-spe: Include bitops.h for BIT() macro Leo Yan
2020-10-22 14:57 ` [PATCH v3 02/20] perf arm-spe: Fix a typo in comment Leo Yan
2020-10-22 14:57 ` [PATCH v3 03/20] perf arm-spe: Refactor payload size calculation Leo Yan
2020-10-23 17:08 ` André Przywara
2020-10-26 1:41 ` Leo Yan
2020-10-22 14:58 ` [PATCH v3 04/20] perf arm-spe: Refactor arm_spe_get_events() Leo Yan
2020-10-23 17:09 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 05/20] perf arm-spe: Fix packet length handling Leo Yan
2020-10-22 14:58 ` [PATCH v3 06/20] perf arm-spe: Refactor printing string to buffer Leo Yan
2020-10-22 14:58 ` [PATCH v3 07/20] perf arm-spe: Refactor packet header parsing Leo Yan
2020-10-23 17:09 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 08/20] perf arm-spe: Add new function arm_spe_pkt_desc_addr() Leo Yan
2020-10-23 17:09 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 09/20] perf arm-spe: Refactor address packet handling Leo Yan
2020-10-23 17:53 ` André Przywara
2020-10-26 6:30 ` Leo Yan
2020-10-22 14:58 ` [PATCH v3 10/20] perf arm-spe: Refactor context " Leo Yan
2020-10-22 14:58 ` [PATCH v3 11/20] perf arm-spe: Add new function arm_spe_pkt_desc_counter() Leo Yan
2020-10-23 17:10 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 12/20] perf arm-spe: Refactor counter packet handling Leo Yan
2020-10-24 0:31 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 13/20] perf arm-spe: Add new function arm_spe_pkt_desc_event() Leo Yan
2020-10-24 0:32 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 14/20] perf arm-spe: Refactor event type handling Leo Yan
2020-10-24 0:32 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 15/20] perf arm-spe: Remove size condition checking for events Leo Yan
2020-10-23 17:10 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 16/20] perf arm-spe: Add new function arm_spe_pkt_desc_op_type() Leo Yan
2020-10-23 17:10 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 17/20] perf arm-spe: Refactor operation packet handling Leo Yan
2020-10-26 18:17 ` André Przywara [this message]
2020-10-22 14:58 ` [PATCH v3 18/20] perf arm-spe: Add more sub classes for operation packet Leo Yan
2020-10-24 0:32 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 19/20] perf arm_spe: Decode memory tagging properties Leo Yan
2020-10-24 0:32 ` André Przywara
2020-10-22 14:58 ` [PATCH v3 20/20] perf arm-spe: Add support for ARMv8.3-SPE Leo Yan
2020-10-26 18:17 ` André Przywara
2020-10-27 3:13 ` Leo Yan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4908efac-0cb4-b2db-69d2-f81cbe14c021@arm.com \
--to=andre.przywara@arm.com \
--cc=Al.Grant@arm.com \
--cc=Dave.Martin@arm.com \
--cc=acme@kernel.org \
--cc=alexander.shishkin@linux.intel.com \
--cc=james.clark@arm.com \
--cc=jolsa@redhat.com \
--cc=leo.yan@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=liwei391@huawei.com \
--cc=mark.rutland@arm.com \
--cc=mingo@redhat.com \
--cc=namhyung@kernel.org \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome