* [PATCH] SYSFS: use standard magic.h for sysfs
@ 2009-01-14 7:45 Qinghuang Feng
0 siblings, 0 replies; only message in thread
From: Qinghuang Feng @ 2009-01-14 7:45 UTC (permalink / raw)
To: gregkh; +Cc: linux-kernel
SYSFS_MAGIC has been added into magic.h, so only use that definition
in magic.h to avoid potential consistency problem.
Signed-off-by: Qinghuang Feng <qhfeng.kernel@gmail.com>
---
diff --git a/fs/sysfs/mount.c b/fs/sysfs/mount.c
index ab343e3..8133ca3 100644
--- a/fs/sysfs/mount.c
+++ b/fs/sysfs/mount.c
@@ -17,11 +17,10 @@
#include <linux/pagemap.h>
#include <linux/init.h>
#include <linux/module.h>
+#include <linux/magic.h>
#include "sysfs.h"
-/* Random magic number */
-#define SYSFS_MAGIC 0x62656572
static struct vfsmount *sysfs_mount;
struct super_block * sysfs_sb = NULL;
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2009-01-14 7:45 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-01-14 7:45 [PATCH] SYSFS: use standard magic.h for sysfs Qinghuang Feng
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome