mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Stefan Richter <stefanr@s5r6.in-berlin.de>
To: Matthias Schwarzott <zzam@gentoo.org>
Cc: linux-hotplug@vger.kernel.org,
	Christian Kujau <lists@nerdbynature.de>,
	linux-kernel@vger.kernel.org,
	linux1394-devel@lists.sourceforge.net, netdev@vger.kernel.org
Subject: Re: [PATCH] ieee1394: eth1394: use "firewire%d" instead of "eth%d" as interface name
Date: Mon, 25 May 2009 12:43:37 +0200	[thread overview]
Message-ID: <4A1A7659.6060201@s5r6.in-berlin.de> (raw)
In-Reply-To: <200905251033.09272.zzam@gentoo.org>

Matthias Schwarzott wrote:
> On Sonntag, 24. Mai 2009, Stefan Richter wrote:
>> Besides, if we can we should avoid fw%d because this will clash with
>> udev rules which match KERNEL=="fw*", as in
>> udev/rules/redhat/40-redhat.rules.
> 
> I suggest a subsystem match here, or generally some
> SUBSYSTEM!="net", GOTO="end_of_file"
> around almost all rule files that should not match on network interfaces, as 
> users can rename them to almost all crazy names.
> 
> @Kay: Perhaps it could simplify some rulesets to have a special jump target or 
> option to skip entiere rules files.

Right...  Luckily, 75-persistent-net-generator.rules already has a big
SUBSYSTEM!="net", GOTO="persistent_net_generator_end" around everything.

Also, "fw*" devices related rules which I'll submit RSN will have
SUBSYSTEM=="firewire" prefixes.
-- 
Stefan Richter
-=====-==--= -=-= ==--=
http://arcgraph.de/sr/

  reply	other threads:[~2009-05-25 10:44 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-05-21 13:29 Stefan Richter
2009-05-21 13:48 ` Jiri Pirko
2009-05-21 14:31   ` Stefan Richter
2009-05-21 16:43     ` Kay Sievers
2009-05-24  6:13     ` Christian Kujau
2009-05-24  9:47       ` Stefan Richter
2009-05-25  8:33         ` Matthias Schwarzott
2009-05-25 10:43           ` Stefan Richter [this message]
2009-05-25 10:57           ` Kay Sievers
2009-05-21 19:34 ` David Miller
2009-05-21 20:13   ` Stefan Richter
2009-05-21 20:33     ` David Miller
2009-05-21 21:35       ` Stefan Richter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4A1A7659.6060201@s5r6.in-berlin.de \
    --to=stefanr@s5r6.in-berlin.de \
    --cc=linux-hotplug@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux1394-devel@lists.sourceforge.net \
    --cc=lists@nerdbynature.de \
    --cc=netdev@vger.kernel.org \
    --cc=zzam@gentoo.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®