From: Gui Jianfeng <guijianfeng@cn.fujitsu.com>
To: Chad Talbott <ctalbott@google.com>
Cc: vgoyal@redhat.com, jens.axboe@oracle.com,
linux-kernel@vger.kernel.org, Nauman Rafique <nauman@google.com>
Subject: Re: [PATCH 2/1] io-controller: Add a new interface "policy" for IO Controller
Date: Thu, 04 Mar 2010 11:23:41 +0800 [thread overview]
Message-ID: <4B8F27BD.2020704@cn.fujitsu.com> (raw)
In-Reply-To: <1786ab031003031825m5467c86jf5c355df10001dd2@mail.gmail.com>
Chad Talbott wrote:
> On Wed, Mar 3, 2010 at 3:19 PM, Nauman Rafique <nauman@google.com> wrote:
>> On Wed, Mar 03, 2010 at 09:33:11AM -0500, Vivek Goyal wrote:
>>> On Wed, Mar 03, 2010 at 02:21:11PM +0800, Gui Jianfeng wrote:
>>>> You can use the following format to assigned specific weight for a given
>>>> device:
>>>> #echo "major:minor weight" > blkio.policy
>
>>> Can we use a different name for per device weight file name than "blkio.policy".
>>> May be "blkio.weight_device" or "blkio.weight_per_device" etc.
>
> I agree with Vivek here, and his reasoning below. This becomes more
> important as more attributes are added.
>
>>> The reason being that "blkio.policy" name might be more suitable to switch
>>> between differnt kind of BW control policies (proportional, max bandwidth etc),
>>> once we implement some kind of max BW controlling policies also. So it
>>> might be a good idea to not use that file name for specifying per device
>>> weights.
>> Well, thinking more about it, what kind of policy you implement on a block
>> device will not be a per cgroup property. It will not be the case that on
>> a device you are implementing max-bw for one cgroup and proportional
>> weight for other cgroup. It probably will be a per device attribute and
>> if need be should be controlled by /sys/block/<dev> interface.
>>
>> Still, being very clear what a particular cgroup file does makes sense. So
>> that in future for max-bw control, we can bring in more cgroup files like
>> blkio.max_bw or blkio.max_iops etc which can co-exist with blkio.weight_device
>> etc.
>
> Agreed. I'd like to add that since we are already thinking about
> expanding the policy with more attributes, perhaps
> blkio_update_group_weight_fn in blkio_policy_ops should be renamed to
> blkio_policy_updated_fn. Then it could be called if the user changed
> any part of the policy. Further, instead of storing "weight" in
> blkio_cgroup, we could store a blkio_policy_node there instead. Then
> the handling of whole-cgroup and per-block-device policy items could
> be more regular.
>
> Some quick code comments:
Hi Chad,
Thanks for the comments.
>
> policy_parse_and_set() could be simplified with scanf, like:
>
> if (sscanf(buf, "%d:%d %d", &major, &minor, &temp) != 3)
> return -EINVAL;
This can't handle the invalid format like following
echo "8:16 500 500 500 ...." > blkio.policy
>
> blkcg_get_weight() might better be blkcg_get_policy() and it could
> return a per-disk policy node, or fall back to the cgroup policy if
> none existed for this dev. This would be across policy attributes,
> rather than just weight.
For the time being, i still choose blkcg_get_weight(). For there's
only one attributes here, when more attributs is added, then we might
change the name.
Thanks
Gui
>
> Thanks,
> Chad
>
>
next prev parent reply other threads:[~2010-03-04 3:29 UTC|newest]
Thread overview: 40+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-03-03 6:21 Gui Jianfeng
2010-03-03 9:01 ` Jens Axboe
2010-03-03 14:33 ` Vivek Goyal
2010-03-03 15:47 ` Vivek Goyal
[not found] ` <e98e18941003031519v14d4f79cg33da5c3cf1f5ac03@mail.gmail.com>
2010-03-04 2:25 ` Chad Talbott
2010-03-04 3:23 ` Gui Jianfeng [this message]
2010-03-04 7:35 ` [PATCH 1/2 V2] io-controller: Add a new interface "weight_device" for IO-Controller Gui Jianfeng
2010-03-04 15:24 ` Vivek Goyal
2010-03-05 0:31 ` Gui Jianfeng
2010-03-05 2:25 ` [PATCH 1/2 V3] " Gui Jianfeng
2010-03-05 14:13 ` Vivek Goyal
2010-03-08 19:39 ` Nauman Rafique
2010-03-08 23:09 ` Vivek Goyal
2010-03-09 1:52 ` Gui Jianfeng
2010-03-09 19:03 ` Vivek Goyal
2010-03-10 0:33 ` Gui Jianfeng
2010-03-10 5:41 ` Chad Talbott
2010-03-10 15:30 ` Vivek Goyal
2010-03-10 17:38 ` Chad Talbott
2010-03-10 18:03 ` Vivek Goyal
2010-03-10 20:31 ` Vivek Goyal
2010-03-11 19:21 ` Manuel Benitez
2010-03-15 13:55 ` Vivek Goyal
2010-03-09 20:16 ` Vivek Goyal
2010-03-09 20:39 ` Nauman Rafique
2010-03-25 6:28 ` Gui Jianfeng
2010-04-07 17:12 ` Chad Talbott
2010-04-07 17:28 ` Vivek Goyal
2010-04-08 0:11 ` Gui Jianfeng
2010-03-05 2:26 ` [PATCH 2/2 V3] io-controller: Document for blkio.weight_device Gui Jianfeng
2010-03-05 2:44 ` Takuya Yoshikawa
2010-03-05 2:42 ` Gui Jianfeng
2010-03-05 14:13 ` Vivek Goyal
2010-03-04 7:35 ` [PATCH 2/2 V2] " Gui Jianfeng
2010-03-04 11:22 ` Takuya Yoshikawa
2010-03-05 0:38 ` Gui Jianfeng
2010-03-04 15:06 ` [PATCH 2/1] io-controller: Add a new interface "policy" for IO Controller Vivek Goyal
2010-03-04 0:27 ` Gui Jianfeng
2010-03-03 15:36 ` Vivek Goyal
2010-03-04 0:29 ` Gui Jianfeng
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4B8F27BD.2020704@cn.fujitsu.com \
--to=guijianfeng@cn.fujitsu.com \
--cc=ctalbott@google.com \
--cc=jens.axboe@oracle.com \
--cc=linux-kernel@vger.kernel.org \
--cc=nauman@google.com \
--cc=vgoyal@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome