From: "H. Peter Anvin" <hpa@zytor.com>
To: Huang Ying <ying.huang@intel.com>
Cc: Ingo Molnar <mingo@elte.hu>, Andi Kleen <ak@linux.intel.com>,
Hidetoshi Seto <seto.hidetoshi@jp.fujitsu.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] x86, MCE, fix MSR_IA32_MCI_CTL2 CMCI threshold setup
Date: Mon, 17 May 2010 18:37:38 -0700 [thread overview]
Message-ID: <4BF1EF62.5020101@zytor.com> (raw)
In-Reply-To: <1274143905.3564.1674.camel@yhuang-dev.sh.intel.com>
On 05/17/2010 05:51 PM, Huang Ying wrote:
> Hi, Peter,
>
> Thanks for review.
>
> On Tue, 2010-05-18 at 01:59 +0800, H. Peter Anvin wrote:
>> On 05/17/2010 01:08 AM, Huang Ying wrote:
>>> It is reported that CMCI is not raised when number of corrected error
>>> reaches preset threshold. After inspection, it is found that
>>> MSR_IA32_MCI_CTL2 threshold field is not setup properly. This patch
>>> fixed it.
>>>
>>>
>>> Changelog:
>>>
>>> v2:
>>>
>>> - Rename CMCI_EN to MCI_CTL2_CMCI_EN and CMCI_THRESHOLD_MASK to
>>> MCI_CTL2_CMCI_THRESHOLD_MASK to make naming consistent.
>>>
>>
>> This looks like a mix of a renaming patch and new functionality. Please
>> submit the renaming as a one patch and then the new functionality as a
>> second patch on top, otherwise it gets hard to see what is actually
>> going on.
>>
>> If I'm not mistaken, there are at least two functionality changes:
>>
>> +#define MCI_CTL2_CMCI_THRESHOLD_MASK 0x7fffULL
>> -#define CMCI_THRESHOLD_MASK 0xffffULL
>>
>> ... change of mask, and:
>>
>> - val |= CMCI_EN | CMCI_THRESHOLD;
>> + val &= ~MCI_CTL2_CMCI_THRESHOLD_MASK;
>> + val |= MCI_CTL2_CMCI_EN | CMCI_THRESHOLD;
>>
>> bit being cleared which wasn't before.
>
> This means we need 3 patches?
>
No, two patches is fine -- one for the rename (no binary changes) and
one for the functionality changes.
-hpa
--
H. Peter Anvin, Intel Open Source Technology Center
I work for Intel. I don't speak on their behalf.
next prev parent reply other threads:[~2010-05-18 1:38 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-05-17 8:08 Huang Ying
2010-05-17 17:59 ` H. Peter Anvin
2010-05-18 0:51 ` Huang Ying
2010-05-18 1:37 ` H. Peter Anvin [this message]
-- strict thread matches above, loose matches on Subject: below --
2010-03-29 7:16 Huang Ying
2010-03-29 8:26 ` Hidetoshi Seto
2010-03-29 8:40 ` Huang Ying
2010-03-29 10:50 ` Andi Kleen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4BF1EF62.5020101@zytor.com \
--to=hpa@zytor.com \
--cc=ak@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=seto.hidetoshi@jp.fujitsu.com \
--cc=ying.huang@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome