mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Bart Van Assche <bvanassche@acm.org>
To: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>,
	Jens Axboe <axboe@kernel.dk>,
	linux-block <linux-block@vger.kernel.org>,
	LKML <linux-kernel@vger.kernel.org>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	Ming Lei <tom.leiming@gmail.com>,
	Damien Le Moal <dlemoal@kernel.org>,
	Christoph Hellwig <hch@lst.de>, Qu Wenruo <wqu@suse.com>,
	Hillf Danton <hdanton@sina.com>
Subject: Re: [PATCH] block: assign caller-specific lockdep class to disk->open_mutex
Date: Sat, 30 May 2026 14:15:04 -0700	[thread overview]
Message-ID: <4cf7ecc7-932c-4589-9d0f-3e025e83e27c@acm.org> (raw)
In-Reply-To: <147ed056-03d9-4214-b925-0f10fc00cf27@I-love.SAKURA.ne.jp>

On 5/30/26 6:45 AM, Tetsuo Handa wrote:
> -	static struct lock_class_key __key;				\
> +	static struct lock_class_key __key[2];				\
The two elements of this array have different roles. From the point of
view of code readability and maintainability it's probably much better
to make this a struct with two named members rather than a two-element
array.

Thanks,

Bart.

  reply	other threads:[~2026-05-30 21:15 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-30 13:45 Tetsuo Handa
2026-05-30 21:15 ` Bart Van Assche [this message]
2026-06-01  7:11   ` Christoph Hellwig
2026-06-03  6:25     ` [PATCH v2] " Tetsuo Handa
2026-06-03 11:54       ` [PATCH v3] " Tetsuo Handa
2026-06-04 21:07         ` Miguel Ojeda
2026-06-05  7:36           ` Andreas Hindborg
2026-06-05 10:08           ` Tetsuo Handa
2026-06-05 11:02             ` Miguel Ojeda
2026-06-05 12:04               ` Mark Brown
2026-06-05 12:40                 ` Miguel Ojeda
2026-06-05 13:03                   ` Mark Brown
2026-06-05 15:04                     ` Mark Brown
2026-06-05  7:54         ` Andreas Hindborg
2026-06-05 10:14           ` Tetsuo Handa
2026-06-19  9:49             ` Andreas Hindborg
2026-06-19 12:19               ` Tetsuo Handa
2026-06-19 13:09                 ` Andreas Hindborg
2026-06-19 13:16                   ` Andreas Hindborg
2026-05-30 22:50 ` [PATCH] " Hillf Danton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4cf7ecc7-932c-4589-9d0f-3e025e83e27c@acm.org \
    --to=bvanassche@acm.org \
    --cc=akpm@linux-foundation.org \
    --cc=axboe@kernel.dk \
    --cc=dlemoal@kernel.org \
    --cc=hch@lst.de \
    --cc=hdanton@sina.com \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=penguin-kernel@I-love.SAKURA.ne.jp \
    --cc=tom.leiming@gmail.com \
    --cc=wqu@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome