mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: David Lechner <dlechner@baylibre.com>
To: Archit Anant <architanant5@gmail.com>, jic23@kernel.org
Cc: lars@metafoo.de, Michael.Hennerich@analog.com,
	nuno.sa@analog.com, andy@kernel.org, linux-iio@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	Andy Shevchenko <andriy.shevchenko@intel.com>
Subject: Re: [PATCH v7 5/5] iio: adc: ad799x: convert to fully managed resources and drop remove()
Date: Sat, 4 Apr 2026 11:09:36 -0500	[thread overview]
Message-ID: <4e1d2bb8-50c3-4749-bf50-9cdf085e0583@baylibre.com> (raw)
In-Reply-To: <20260403080614.14213-6-architanant5@gmail.com>

On 4/3/26 3:06 AM, Archit Anant wrote:
> Convert the driver's remaining manual resource management to use the
> devm_ infrastructure, allowing for the complete removal of the
> ad799x_remove() function and the simplification of the probe error paths.
> 
> Specifically:
> - Initialize the mutex using devm_mutex_init() and move it to the top
>   of probe() (before IRQ registration) to prevent a race condition where
>   an interrupt could attempt to take an uninitialized lock.
> - Use devm_add_action_or_reset() to ensure that the VCC and VREF
>   regulators are disabled safely and in the correct order during driver
>   teardown or probe failure.
> - Refactor the optional VREF error handling path for better readability.
> - Convert iio_triggered_buffer_setup() and iio_device_register() to
>   their devm_ variants.
> 
> Because all resources are now managed by the devm core, the unwinding
> order is guaranteed to follow the reverse order of allocation. All manual
> error handling goto labels in ad799x_probe() have been removed.
> 
> Suggested-by: Jonathan Cameron <jic23@kernel.org>
> Suggested-by: David Lechner <dlechner@baylibre.com>
> Suggested-by: Andy Shevchenko <andriy.shevchenko@intel.com>
> Signed-off-by: Archit Anant <architanant5@gmail.com>
> ---
>  drivers/iio/adc/ad799x.c | 69 ++++++++++++++++------------------------
>  1 file changed, 28 insertions(+), 41 deletions(-)
> 
> diff --git a/drivers/iio/adc/ad799x.c b/drivers/iio/adc/ad799x.c
> index e37bb64edd2b..9170109d64ef 100644
> --- a/drivers/iio/adc/ad799x.c
> +++ b/drivers/iio/adc/ad799x.c
> @@ -775,6 +775,11 @@ static const struct ad799x_chip_info ad799x_chip_info_tbl[] = {
>  	},
>  };
>  
> +static void ad799x_reg_disable(void *reg)
> +{
> +	regulator_disable(reg);
> +}
> +
>  static int ad799x_probe(struct i2c_client *client)
>  {
>  	struct device *dev = &client->dev;
> @@ -793,6 +798,9 @@ static int ad799x_probe(struct i2c_client *client)
>  	st = iio_priv(indio_dev);
>  	/* this is only used for device removal purposes */
>  	i2c_set_clientdata(client, indio_dev);

Insert blank line here.

> +	ret = devm_mutex_init(dev, &st->lock);
> +	if (ret)
> +		return ret;
>  

  reply	other threads:[~2026-04-04 16:09 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-04-03  8:06 [PATCH v7 0/5] iio: adc: ad799x: modernize resource management Archit Anant
2026-04-03  8:06 ` [PATCH v7 1/5] iio: adc: ad799x: sort headers alphabetically Archit Anant
2026-04-03  8:06 ` [PATCH v7 2/5] iio: adc: ad799x: use local device pointer in probe Archit Anant
2026-04-03  8:06 ` [PATCH v7 3/5] iio: adc: ad799x: use a static buffer for scan data Archit Anant
2026-04-03  8:06 ` [PATCH v7 4/5] iio: adc: ad799x: cache regulator voltages during probe Archit Anant
2026-04-04 16:04   ` David Lechner
2026-04-03  8:06 ` [PATCH v7 5/5] iio: adc: ad799x: convert to fully managed resources and drop remove() Archit Anant
2026-04-04 16:09   ` David Lechner [this message]
2026-04-04 16:10 ` [PATCH v7 0/5] iio: adc: ad799x: modernize resource management David Lechner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4e1d2bb8-50c3-4749-bf50-9cdf085e0583@baylibre.com \
    --to=dlechner@baylibre.com \
    --cc=Michael.Hennerich@analog.com \
    --cc=andriy.shevchenko@intel.com \
    --cc=andy@kernel.org \
    --cc=architanant5@gmail.com \
    --cc=jic23@kernel.org \
    --cc=lars@metafoo.de \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nuno.sa@analog.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®